Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула суммы разности прихода и ухода на работу - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула суммы разности прихода и ухода на работу (Формулы/Formulas)
Формула суммы разности прихода и ухода на работу
Foks Дата: Пятница, 01.10.2021, 21:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Всем привет! Помогите плиз, есть таблица с временем прихода и ухода сотрудников, вырезал небольшой кусок на неделю, так таблица на месяц. Вопрос в том, чтобы высчитать за месяц сколько времени человек переработал или недоработал всвязи с опозданием или ранним уходом с работы. То, что я набрал в формуле это конечно полный бред, тем более, что это всего неделя. Ячейки "не зафиксирован" не должны учитываться в подсчёте. В пятницу короткий день на час. Плюс одна из ячеек может быть пустой, т.к. кто-то "забыл" отметиться. Строки в таблице это разные сотрудники. Переделать таблицу не представляется возможным, она создаётся определённым powershell-скриптом, в которых я не силён как и в Excel.
К сообщению приложен файл: 6103146.xlsx(13.1 Kb)


Сообщение отредактировал Foks - Пятница, 01.10.2021, 21:42
 
Ответить
СообщениеВсем привет! Помогите плиз, есть таблица с временем прихода и ухода сотрудников, вырезал небольшой кусок на неделю, так таблица на месяц. Вопрос в том, чтобы высчитать за месяц сколько времени человек переработал или недоработал всвязи с опозданием или ранним уходом с работы. То, что я набрал в формуле это конечно полный бред, тем более, что это всего неделя. Ячейки "не зафиксирован" не должны учитываться в подсчёте. В пятницу короткий день на час. Плюс одна из ячеек может быть пустой, т.к. кто-то "забыл" отметиться. Строки в таблице это разные сотрудники. Переделать таблицу не представляется возможным, она создаётся определённым powershell-скриптом, в которых я не силён как и в Excel.

Автор - Foks
Дата добавления - 01.10.2021 в 21:41
DrMini Дата: Суббота, 02.10.2021, 09:29 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Foks, добрый день.
Может так подойдёт?
Код
=СУММ(ЕСЛИОШИБКА(C3-B3-$A$28;0);ЕСЛИОШИБКА(E3-D3-$A$28;0);ЕСЛИОШИБКА(G3-F3-$A$28;0);ЕСЛИОШИБКА(I3-H3-$A$28;0);ЕСЛИОШИБКА(K3-J3-$A$29;0))
 
Ответить
СообщениеFoks, добрый день.
Может так подойдёт?
Код
=СУММ(ЕСЛИОШИБКА(C3-B3-$A$28;0);ЕСЛИОШИБКА(E3-D3-$A$28;0);ЕСЛИОШИБКА(G3-F3-$A$28;0);ЕСЛИОШИБКА(I3-H3-$A$28;0);ЕСЛИОШИБКА(K3-J3-$A$29;0))

Автор - DrMini
Дата добавления - 02.10.2021 в 09:29
Foks Дата: Суббота, 02.10.2021, 16:21 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

DrMini, хотелось бы упростить всё это как-то... у меня 30 дней, а это 30 слагаемых, плюс если результат отрицательный то отображается ошибка, так как время не может быть отрицательным. И если одна из ячеек пуста, то формула воспринимает её как 0, что неправильно. Может лучше чтобы она подставляла значение 17:00 или 8:00 в зависимости от того утро это или вечер.
 
Ответить
СообщениеDrMini, хотелось бы упростить всё это как-то... у меня 30 дней, а это 30 слагаемых, плюс если результат отрицательный то отображается ошибка, так как время не может быть отрицательным. И если одна из ячеек пуста, то формула воспринимает её как 0, что неправильно. Может лучше чтобы она подставляла значение 17:00 или 8:00 в зависимости от того утро это или вечер.

Автор - Foks
Дата добавления - 02.10.2021 в 16:21
DrMini Дата: Суббота, 02.10.2021, 17:52 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Foks, У меня знания excel минимальные. Может местные гуру форума дадут формулу на месяц.
Если привязывать к дням недели то получится слишком сложно и Вам это не подойдёт. Показ отрицательных значений я могу сделать только с доп. столбцом. А это я думаю не выход.
И если ячейка пуста то что должно считаться?


Сообщение отредактировал DrMini - Суббота, 02.10.2021, 17:54
 
Ответить
СообщениеFoks, У меня знания excel минимальные. Может местные гуру форума дадут формулу на месяц.
Если привязывать к дням недели то получится слишком сложно и Вам это не подойдёт. Показ отрицательных значений я могу сделать только с доп. столбцом. А это я думаю не выход.
И если ячейка пуста то что должно считаться?

Автор - DrMini
Дата добавления - 02.10.2021 в 17:52
Светлый Дата: Суббота, 02.10.2021, 18:50 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1708
Репутация: 457 ±
Замечаний: 0% ±

Excel 2013, 2016
Попробуйте такую массивную формулу:
Код
=СУММ(ЕСЛИОШИБКА((ЛЕВБ(B$2:K$2)="У")*(ЕСЛИ(B3:K3="";ПРАВБ($A3;5);B3:K3)-ЕСЛИ(A3:J3="";ЛЕВБ($A3;4);A3:J3));))
*А это с учётом пятниц:
Код
=СУММ(ЕСЛИОШИБКА((ЛЕВБ(B$2:K$2)="У")*(ЕСЛИ(B3:K3="";ПОДСТАВИТЬ(ПРАВБ($A3;5);".";":")-(ДЕНЬНЕД(Ч(+A$1:J$1);2)=5)/24;B3:K3)-ЕСЛИ(A3:J3="";ЛЕВБ($A3;4);A3:J3));))
Файл перезалил.
К сообщению приложен файл: 6103146-1.xlsx(14.4 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 02.10.2021, 19:36
 
Ответить
СообщениеПопробуйте такую массивную формулу:
Код
=СУММ(ЕСЛИОШИБКА((ЛЕВБ(B$2:K$2)="У")*(ЕСЛИ(B3:K3="";ПРАВБ($A3;5);B3:K3)-ЕСЛИ(A3:J3="";ЛЕВБ($A3;4);A3:J3));))
*А это с учётом пятниц:
Код
=СУММ(ЕСЛИОШИБКА((ЛЕВБ(B$2:K$2)="У")*(ЕСЛИ(B3:K3="";ПОДСТАВИТЬ(ПРАВБ($A3;5);".";":")-(ДЕНЬНЕД(Ч(+A$1:J$1);2)=5)/24;B3:K3)-ЕСЛИ(A3:J3="";ЛЕВБ($A3;4);A3:J3));))
Файл перезалил.

Автор - Светлый
Дата добавления - 02.10.2021 в 18:50
Foks Дата: Суббота, 02.10.2021, 23:19 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

DrMini, если пустая ячейка пока буду ставить время либо 8:00, либо 17:00 в зависимости от того утро это или вечер
 
Ответить
СообщениеDrMini, если пустая ячейка пока буду ставить время либо 8:00, либо 17:00 в зависимости от того утро это или вечер

Автор - Foks
Дата добавления - 02.10.2021 в 23:19
Foks Дата: Суббота, 02.10.2021, 23:39 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Светлый, Спасибо огромное!!! Это очень близко к желаемому результату. В итоговой ячейке получилось общее количество времени, проведённого на работе, как бы от этого времени теперь вычесть "чистое рабочее время" (то есть в неделе 5 дней, 4 дня человек проводит по 9 часов на рабочем месте не считая перерыва, а в пятницу 8 часов). Например, грубо говоря приходил он на работу в 7:55, уходил в 17:05, в пятницу в 16:05 за неделю время проведённого на работе получилось 44:50, если вычесть "чистое рабочее время", то он переработал 44:50-44:00, 50 минут. в конечном столбце должно быть это значение "50 минут", или если человек наоборот опаздывал и раньше уходил, то -50 минут.
 
Ответить
СообщениеСветлый, Спасибо огромное!!! Это очень близко к желаемому результату. В итоговой ячейке получилось общее количество времени, проведённого на работе, как бы от этого времени теперь вычесть "чистое рабочее время" (то есть в неделе 5 дней, 4 дня человек проводит по 9 часов на рабочем месте не считая перерыва, а в пятницу 8 часов). Например, грубо говоря приходил он на работу в 7:55, уходил в 17:05, в пятницу в 16:05 за неделю время проведённого на работе получилось 44:50, если вычесть "чистое рабочее время", то он переработал 44:50-44:00, 50 минут. в конечном столбце должно быть это значение "50 минут", или если человек наоборот опаздывал и раньше уходил, то -50 минут.

Автор - Foks
Дата добавления - 02.10.2021 в 23:39
Светлый Дата: Воскресенье, 03.10.2021, 01:20 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1708
Репутация: 457 ±
Замечаний: 0% ±

Excel 2013, 2016
Код
=ЕСЛИ(O3<СУММ(ЕСЛИОШИБКА(((ЛЕВБ(B$2:K$2)="У")*B3:K3>0)*9-(ДЕНЬНЕД(Ч(+A$1:J$1);2)=5);))/24;"-";"")&ТЕКСТ(ABS(O3-СУММ(ЕСЛИОШИБКА(((ЛЕВБ(B$2:K$2)="У")*B3:K3>0)*9-(ДЕНЬНЕД(Ч(+A$1:J$1);2)=5);))/24);"[ч]:мм:сс")
К сообщению приложен файл: 6103146-2.xlsx(15.4 Kb)


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
Код
=ЕСЛИ(O3<СУММ(ЕСЛИОШИБКА(((ЛЕВБ(B$2:K$2)="У")*B3:K3>0)*9-(ДЕНЬНЕД(Ч(+A$1:J$1);2)=5);))/24;"-";"")&ТЕКСТ(ABS(O3-СУММ(ЕСЛИОШИБКА(((ЛЕВБ(B$2:K$2)="У")*B3:K3>0)*9-(ДЕНЬНЕД(Ч(+A$1:J$1);2)=5);))/24);"[ч]:мм:сс")

Автор - Светлый
Дата добавления - 03.10.2021 в 01:20
Foks Дата: Четверг, 07.10.2021, 20:03 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Светлый, Вы гений! Спасибо Вам огромное!
 
Ответить
СообщениеСветлый, Вы гений! Спасибо Вам огромное!

Автор - Foks
Дата добавления - 07.10.2021 в 20:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула суммы разности прихода и ухода на работу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!