Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для удаления повторов с соблюдением условия - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для удаления повторов с соблюдением условия (Формулы/Formulas)
Формула для удаления повторов с соблюдением условия
Excelnoob Дата: Четверг, 21.10.2021, 11:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Добрый день. Просьба помочь с формулой, требуется формула для удаления повторов если в столбце "B" также повторяется город. Файл примера во вложении. Ранее пользовался формулой для удаления повторов
Код
=ЕСЛИ(ПОИСКПОЗ(D2;$D$2:$D$280;0)=СТРОКА()-СТРОКА($D$1);D2;"")
К сообщению приложен файл: ___.xlsx(8.9 Kb)


Сообщение отредактировал Serge_007 - Четверг, 21.10.2021, 11:22
 
Ответить
СообщениеДобрый день. Просьба помочь с формулой, требуется формула для удаления повторов если в столбце "B" также повторяется город. Файл примера во вложении. Ранее пользовался формулой для удаления повторов
Код
=ЕСЛИ(ПОИСКПОЗ(D2;$D$2:$D$280;0)=СТРОКА()-СТРОКА($D$1);D2;"")

Автор - Excelnoob
Дата добавления - 21.10.2021 в 11:18
Egyptian Дата: Четверг, 21.10.2021, 11:27 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 395
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
В D3 вправо и вниз.
Код
=IF(COUNTIFS($A$3:$A3;$A3;$B$3:$B3;$B3)>1;"";A3)
К сообщению приложен файл: 3130278.xlsx(10.7 Kb)
 
Ответить
СообщениеВ D3 вправо и вниз.
Код
=IF(COUNTIFS($A$3:$A3;$A3;$B$3:$B3;$B3)>1;"";A3)

Автор - Egyptian
Дата добавления - 21.10.2021 в 11:27
Serge_007 Дата: Четверг, 21.10.2021, 11:27 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15418
Репутация: 2538 ±
Замечаний: ±

Excel 2016
Здравствуйте
Код
=ЕСЛИ(СУММПРОИЗВ(--(A$3:A3&B$3:B3=A3&B3))=1;A3;"")
К сообщению приложен файл: 20211021_Exceln.xls(65.5 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте
Код
=ЕСЛИ(СУММПРОИЗВ(--(A$3:A3&B$3:B3=A3&B3))=1;A3;"")

Автор - Serge_007
Дата добавления - 21.10.2021 в 11:27
Excelnoob Дата: Четверг, 21.10.2021, 13:00 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Egyptian, Serge_007, благодарю!
 
Ответить
СообщениеEgyptian, Serge_007, благодарю!

Автор - Excelnoob
Дата добавления - 21.10.2021 в 13:00
Excelnoob Дата: Четверг, 21.10.2021, 16:39 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Egyptian, подскажите, пожалуйста, как добавить в эту формулу нумерацию, вместо значения ЛОЖЬ?


Сообщение отредактировал Excelnoob - Четверг, 21.10.2021, 17:42
 
Ответить
СообщениеEgyptian, подскажите, пожалуйста, как добавить в эту формулу нумерацию, вместо значения ЛОЖЬ?

Автор - Excelnoob
Дата добавления - 21.10.2021 в 16:39
Egyptian Дата: Пятница, 22.10.2021, 15:38 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 395
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Так?
Код
=IF(COUNTIFS($A$3:$A3;$A3;$B$3:$B3;$B3)>1;MAX(F$2:F2)+1;A3)
К сообщению приложен файл: 1394754.xlsx(10.9 Kb)
 
Ответить
СообщениеТак?
Код
=IF(COUNTIFS($A$3:$A3;$A3;$B$3:$B3;$B3)>1;MAX(F$2:F2)+1;A3)

Автор - Egyptian
Дата добавления - 22.10.2021 в 15:38
Excelnoob Дата: Пятница, 22.10.2021, 15:48 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Egyptian, наоборот, поменял местами, все работает, спасибо!
 
Ответить
СообщениеEgyptian, наоборот, поменял местами, все работает, спасибо!

Автор - Excelnoob
Дата добавления - 22.10.2021 в 15:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для удаления повторов с соблюдением условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!