Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выдернуть и отсортировать значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выдернуть и отсортировать значения (Формулы/Formulas)
Выдернуть и отсортировать значения
seomotiv Дата: Вторник, 26.10.2021, 00:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Доброй ночи. Сижу, ломаю голову.
В первом столбце (столбец A) допустим у нас 20 продаж яблок и винограда.
Нужно что бы столбцы "D" и "E" поняли где виноград, а где яблоки и отсортировали автоматически значения так, как сейчас в приложенном файле.

Столбец "А" будет динамическим. т.е там может быть 20, а может и 28 строк, значения постоянно будут меняться.

Надеюсь понятно написал.
К сообщению приложен файл: 0116739.xlsx(9.0 Kb)
 
Ответить
СообщениеДоброй ночи. Сижу, ломаю голову.
В первом столбце (столбец A) допустим у нас 20 продаж яблок и винограда.
Нужно что бы столбцы "D" и "E" поняли где виноград, а где яблоки и отсортировали автоматически значения так, как сейчас в приложенном файле.

Столбец "А" будет динамическим. т.е там может быть 20, а может и 28 строк, значения постоянно будут меняться.

Надеюсь понятно написал.

Автор - seomotiv
Дата добавления - 26.10.2021 в 00:05
Pelena Дата: Вторник, 26.10.2021, 08:19 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Вариант с доп. столбцом
К сообщению приложен файл: 2798842.xlsx(11.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вариант с доп. столбцом

Автор - Pelena
Дата добавления - 26.10.2021 в 08:19
seomotiv Дата: Вторник, 26.10.2021, 23:29 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Pelena, В таких формулах я бессилен.
Спасибо Вам огромное.


Сообщение отредактировал seomotiv - Вторник, 26.10.2021, 23:30
 
Ответить
СообщениеPelena, В таких формулах я бессилен.
Спасибо Вам огромное.

Автор - seomotiv
Дата добавления - 26.10.2021 в 23:29
прохожий2019 Дата: Среда, 27.10.2021, 01:08 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 717
Репутация: 181 ±
Замечаний: 0% ±

365 Beta Channel
если экселька свежий:
Код
=СОРТ(ФИЛЬТР(C1:C20;A1:A20=E1);;-1)
К сообщению приложен файл: 2419034.xlsx(11.6 Kb)
 
Ответить
Сообщениеесли экселька свежий:
Код
=СОРТ(ФИЛЬТР(C1:C20;A1:A20=E1);;-1)

Автор - прохожий2019
Дата добавления - 27.10.2021 в 01:08
Nic70y Дата: Среда, 27.10.2021, 08:56 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 7158
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
древний вариант
Код
=ЕСЛИОШИБКА(СУММЕСЛИ($A$1:ИНДЕКС($A$1:$A$999;ПСТР(-СУММПРОИЗВ(НАИБОЛЬШИЙ(($A$1:$A$999=D$1)*СТРОКА($A$1:$A$999);СТРОКА(D1)));2;15));D$1;$B$1:ИНДЕКС($B$1:$B$999;СУММПРОИЗВ(НАИБОЛЬШИЙ(($A$1:$A$999=D$1)*СТРОКА($A$1:$A$999);СТРОКА(D1)))));"")
К сообщению приложен файл: 9236584.xlsx(9.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениедревний вариант
Код
=ЕСЛИОШИБКА(СУММЕСЛИ($A$1:ИНДЕКС($A$1:$A$999;ПСТР(-СУММПРОИЗВ(НАИБОЛЬШИЙ(($A$1:$A$999=D$1)*СТРОКА($A$1:$A$999);СТРОКА(D1)));2;15));D$1;$B$1:ИНДЕКС($B$1:$B$999;СУММПРОИЗВ(НАИБОЛЬШИЙ(($A$1:$A$999=D$1)*СТРОКА($A$1:$A$999);СТРОКА(D1)))));"")

Автор - Nic70y
Дата добавления - 27.10.2021 в 08:56
seomotiv Дата: Среда, 27.10.2021, 23:32 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

прохожий2019, Nic70y, Спасибо.
 
Ответить
Сообщениепрохожий2019, Nic70y, Спасибо.

Автор - seomotiv
Дата добавления - 27.10.2021 в 23:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выдернуть и отсортировать значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!