Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Замена названий организаций на сокращенные - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена названий организаций на сокращенные (Формулы/Formulas)
Замена названий организаций на сокращенные
AndreySanich Дата: Среда, 10.11.2021, 16:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Для работы надо создать список организаций, но для удобства нужны сокращенные названия.
В примере описал малую часть.

Хотелось бы загружать полные наименования организаций в столбец А (список имеется, 20 тыс. позиций), а в столбце В иметь сокращенные наименования, в соответствии с сокращениями, как на листе "для замены" и список сокращений можно было бы дополнять.
Если ничего из списка не подходит - то наименование переноситься полностью.
Пробовал через много ЕСЛИ, но получается запутанная формула.
К сообщению приложен файл: 9543056.xlsx(11.0 Kb)
 
Ответить
СообщениеДобрый день.
Для работы надо создать список организаций, но для удобства нужны сокращенные названия.
В примере описал малую часть.

Хотелось бы загружать полные наименования организаций в столбец А (список имеется, 20 тыс. позиций), а в столбце В иметь сокращенные наименования, в соответствии с сокращениями, как на листе "для замены" и список сокращений можно было бы дополнять.
Если ничего из списка не подходит - то наименование переноситься полностью.
Пробовал через много ЕСЛИ, но получается запутанная формула.

Автор - AndreySanich
Дата добавления - 10.11.2021 в 16:32
Serge_007 Дата: Среда, 10.11.2021, 16:46 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ЕСЛИОШИБКА(ВПР(ЛЕВБ(A2;ПОИСК("""";A2)-2);'для замены'!A$1:B$3;2;)&ПРАВБ(A2;ДЛСТР(A2)-ПОИСК("""";A2)+2);A2)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ЕСЛИОШИБКА(ВПР(ЛЕВБ(A2;ПОИСК("""";A2)-2);'для замены'!A$1:B$3;2;)&ПРАВБ(A2;ДЛСТР(A2)-ПОИСК("""";A2)+2);A2)

Автор - Serge_007
Дата добавления - 10.11.2021 в 16:46
AndreySanich Дата: Среда, 10.11.2021, 18:02 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

спасибо.
Но работает не на всех строчках. Может пример был не совсем корректный, вот что получается, если название фирмы без кавычек
А так же если кавычки стоят по другому
К сообщению приложен файл: 3034382.xlsx(11.8 Kb)


Сообщение отредактировал AndreySanich - Среда, 10.11.2021, 18:26
 
Ответить
Сообщениеспасибо.
Но работает не на всех строчках. Может пример был не совсем корректный, вот что получается, если название фирмы без кавычек
А так же если кавычки стоят по другому

Автор - AndreySanich
Дата добавления - 10.11.2021 в 18:02
Pelena Дата: Среда, 10.11.2021, 18:40 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
Код
=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A2;ИНДЕКС('для замены'!$A$2:$A$4;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК('для замены'!$A$2:$A$4;A2));0));ВПР(ИНДЕКС('для замены'!$A$2:$A$4;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК('для замены'!$A$2:$A$4;A2));0));'для замены'!$A$2:$B$4;2;0)))
К сообщению приложен файл: 3281919.xlsx(12.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A2;ИНДЕКС('для замены'!$A$2:$A$4;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК('для замены'!$A$2:$A$4;A2));0));ВПР(ИНДЕКС('для замены'!$A$2:$A$4;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК('для замены'!$A$2:$A$4;A2));0));'для замены'!$A$2:$B$4;2;0)))

Автор - Pelena
Дата добавления - 10.11.2021 в 18:40
rico_crazy Дата: Вторник, 16.11.2021, 14:42 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 33
Репутация: 0 ±
Замечаний: 20% ±

Не совсем решилась проблема.
Да теперь сокращает название если есть кавычки, или же их нету.
Но если же заменяемый текст записан с ошибкой, или как то по другому, или же ячейка вообще пустая. Показывает ошибку


Сообщение отредактировал Serge_007 - Вторник, 16.11.2021, 15:49
 
Ответить
СообщениеНе совсем решилась проблема.
Да теперь сокращает название если есть кавычки, или же их нету.
Но если же заменяемый текст записан с ошибкой, или как то по другому, или же ячейка вообще пустая. Показывает ошибку

Автор - rico_crazy
Дата добавления - 16.11.2021 в 14:42
Skurko Дата: Вторник, 16.11.2021, 15:58 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 9 ±
Замечаний: 0% ±

rico_crazy, заверните в если ошибка, как во втором сообщении
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A2;ИНДЕКС('для замены'!$A$2:$A$4;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК('для замены'!$A$2:$A$4;A2));0));ВПР(ИНДЕКС('для замены'!$A$2:$A$4;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК('для замены'!$A$2:$A$4;A2));0));'для замены'!$A$2:$B$4;2;0)));A2)

и в вашем примере не ошибку показывает, а нет данных, но завернув в еслиошибка это тоже устранится.
К сообщению приложен файл: 8519946.xlsx(12.4 Kb)
 
Ответить
Сообщениеrico_crazy, заверните в если ошибка, как во втором сообщении
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A2;ИНДЕКС('для замены'!$A$2:$A$4;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК('для замены'!$A$2:$A$4;A2));0));ВПР(ИНДЕКС('для замены'!$A$2:$A$4;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК('для замены'!$A$2:$A$4;A2));0));'для замены'!$A$2:$B$4;2;0)));A2)

и в вашем примере не ошибку показывает, а нет данных, но завернув в еслиошибка это тоже устранится.

Автор - Skurko
Дата добавления - 16.11.2021 в 15:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена названий организаций на сокращенные (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!