Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование остатков по группе товаров с условием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование остатков по группе товаров с условием (Формулы/Formulas)
Суммирование остатков по группе товаров с условием
Mrak83 Дата: Вторник, 14.12.2021, 11:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день,
имеется пример сводной, в которой в колонке С нужно отобразить значения из колонки В при условии, что сумма по колонке B не превышает 100000 для определенной группы товаров (колонка А). Пример прилагаю.
Помогите пожалуйст, как это можно прописать с помощью формулы (в идеале).
К сообщению приложен файл: Book7.xlsx(11.5 Kb)
 
Ответить
СообщениеДобрый день,
имеется пример сводной, в которой в колонке С нужно отобразить значения из колонки В при условии, что сумма по колонке B не превышает 100000 для определенной группы товаров (колонка А). Пример прилагаю.
Помогите пожалуйст, как это можно прописать с помощью формулы (в идеале).

Автор - Mrak83
Дата добавления - 14.12.2021 в 11:47
Nic70y Дата: Вторник, 14.12.2021, 12:02 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7302
Репутация: 1686 ±
Замечаний: 0% ±

Excel 2010
не совсем понял ваше описание.
вдруг правильно
Код
=ЕСЛИ(ВПР(ПОДСТАВИТЬ(A2&" Total";" Total";;2);A2:B$30000;2;)<E$1;B2;"")
К сообщению приложен файл: 12-5.xlsx(11.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениене совсем понял ваше описание.
вдруг правильно
Код
=ЕСЛИ(ВПР(ПОДСТАВИТЬ(A2&" Total";" Total";;2);A2:B$30000;2;)<E$1;B2;"")

Автор - Nic70y
Дата добавления - 14.12.2021 в 12:02
Mrak83 Дата: Вторник, 14.12.2021, 12:26 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Nic70y спасибо за Вашу помощь! Т.к. в Вашем примере B13>100000, то значения в диапазоне С10:С12 в примере должен быть не пустыми по колонке C, а давать сумму С13=100000. Против В13=826112,78.
Или иначе С10+С12+(100000-С10-С12)
Или иначе 4799,35+1056,93+(100000-4799,35-1056,93)
Или иначе:
С10 = 4799,35
C12=1056,93
С11=94143,72
 
Ответить
СообщениеNic70y спасибо за Вашу помощь! Т.к. в Вашем примере B13>100000, то значения в диапазоне С10:С12 в примере должен быть не пустыми по колонке C, а давать сумму С13=100000. Против В13=826112,78.
Или иначе С10+С12+(100000-С10-С12)
Или иначе 4799,35+1056,93+(100000-4799,35-1056,93)
Или иначе:
С10 = 4799,35
C12=1056,93
С11=94143,72

Автор - Mrak83
Дата добавления - 14.12.2021 в 12:26
Nic70y Дата: Вторник, 14.12.2021, 14:20 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7302
Репутация: 1686 ±
Замечаний: 0% ±

Excel 2010
5 доп. столбцов
К сообщению приложен файл: Book7-1-.xlsx(13.8 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение5 доп. столбцов

Автор - Nic70y
Дата добавления - 14.12.2021 в 14:20
Mrak83 Дата: Вторник, 14.12.2021, 15:12 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Оромнейшее человеческое спасибо Вам! :)
Чисто из любопытства, может вы подскажете/знаете: такая задача в принципе решаема в Power Query/Pivot без конструирования длинных сложных конструкций?
 
Ответить
СообщениеОромнейшее человеческое спасибо Вам! :)
Чисто из любопытства, может вы подскажете/знаете: такая задача в принципе решаема в Power Query/Pivot без конструирования длинных сложных конструкций?

Автор - Mrak83
Дата добавления - 14.12.2021 в 15:12
Nic70y Дата: Вторник, 14.12.2021, 15:17 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7302
Репутация: 1686 ±
Замечаний: 0% ±

Excel 2010
Power Query
думаю да,
но проверить не могу
Excel 2010


ЮMoney 41001841029809
 
Ответить
Сообщение
Power Query
думаю да,
но проверить не могу
Excel 2010

Автор - Nic70y
Дата добавления - 14.12.2021 в 15:17
Serge_007 Дата: Вторник, 14.12.2021, 15:54 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 14868
Репутация: 2463 ±
Замечаний: ±

Excel 2016
Nic70y, я PQ ставил как надстройку на Excel 2010 на старом ноуте...


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеNic70y, я PQ ставил как надстройку на Excel 2010 на старом ноуте...

Автор - Serge_007
Дата добавления - 14.12.2021 в 15:54
Nic70y Дата: Вторник, 14.12.2021, 16:02 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 7302
Репутация: 1686 ±
Замечаний: 0% ±

Excel 2010
Сергей, у меня эксель только на работе) на сервере
устанавливать ни чего не могу,
только, что смог сделать - подключил всем (почти) макросы


ЮMoney 41001841029809
 
Ответить
СообщениеСергей, у меня эксель только на работе) на сервере
устанавливать ни чего не могу,
только, что смог сделать - подключил всем (почти) макросы

Автор - Nic70y
Дата добавления - 14.12.2021 в 16:02
Serge_007 Дата: Вторник, 14.12.2021, 16:13 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 14868
Репутация: 2463 ±
Замечаний: ±

Excel 2016
устанавливать ни чего не могу
Понятно
Вроде портабл ещё было, не помню уже точно сейчас


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
устанавливать ни чего не могу
Понятно
Вроде портабл ещё было, не помню уже точно сейчас

Автор - Serge_007
Дата добавления - 14.12.2021 в 16:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование остатков по группе товаров с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!