Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Простейший учет приход/расход на 1 листе - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Простейший учет приход/расход на 1 листе (Формулы/Formulas)
Простейший учет приход/расход на 1 листе
romanchenko Дата: Вторник, 21.12.2021, 22:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Всем привет. Нужна простая таблица учета прихода/расхода материалов на 1 листе. В приложенной табличке в верхней строке с цифрами должны быть остатки, а далее последовательно приходы и расходы. Мое скудоумие остановилось на втором приходе, ибо использовал функцию СУММ, то есть расход без знака "минус" считается как приход, что не удивительно. Есть ли простые варианты решения без использования знака "минус" перед каждым расходом? Если это важно, все приходы крашу в желтый цвет. MS Office 2021
К сообщению приложен файл: 3778403.xlsx(10.6 Kb)
 
Ответить
СообщениеВсем привет. Нужна простая таблица учета прихода/расхода материалов на 1 листе. В приложенной табличке в верхней строке с цифрами должны быть остатки, а далее последовательно приходы и расходы. Мое скудоумие остановилось на втором приходе, ибо использовал функцию СУММ, то есть расход без знака "минус" считается как приход, что не удивительно. Есть ли простые варианты решения без использования знака "минус" перед каждым расходом? Если это важно, все приходы крашу в желтый цвет. MS Office 2021

Автор - romanchenko
Дата добавления - 21.12.2021 в 22:50
DrMini Дата: Среда, 22.12.2021, 06:56 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Есть ли простые варианты решения без использования знака "минус" перед каждым расходом?

Может подойдёт через формат ячейки? Все отрицательные числа окрашиваются в красный цвет.
К сообщению приложен файл: 3778403-2.xlsx(12.1 Kb)


Сообщение отредактировал DrMini - Среда, 22.12.2021, 06:57
 
Ответить
Сообщение
Есть ли простые варианты решения без использования знака "минус" перед каждым расходом?

Может подойдёт через формат ячейки? Все отрицательные числа окрашиваются в красный цвет.

Автор - DrMini
Дата добавления - 22.12.2021 в 06:56
Egyptian Дата: Среда, 22.12.2021, 07:58 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 393
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Простой вариант с наглядной формулой.
Код
=SUMPRODUCT((D$3:D$7*($Q$3:$Q$7="приход"))+($Q$3:$Q$7="расход")*-D$3:D$7)
К сообщению приложен файл: 5520451.xlsx(10.4 Kb)
 
Ответить
СообщениеПростой вариант с наглядной формулой.
Код
=SUMPRODUCT((D$3:D$7*($Q$3:$Q$7="приход"))+($Q$3:$Q$7="расход")*-D$3:D$7)

Автор - Egyptian
Дата добавления - 22.12.2021 в 07:58
romanchenko Дата: Понедельник, 27.12.2021, 10:35 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Egyptian, Большое спасибо. Пришлось, конечно, почитать про СУММПРОИЗВ, чтоб разобраться, но это то, что надо.
 
Ответить
СообщениеEgyptian, Большое спасибо. Пришлось, конечно, почитать про СУММПРОИЗВ, чтоб разобраться, но это то, что надо.

Автор - romanchenko
Дата добавления - 27.12.2021 в 10:35
romanchenko Дата: Четверг, 30.12.2021, 01:01 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

и до кучи, в том же файле, что в сообщении №3 от Egyptian: как закрашивать желтым ячейки слева от ячейки "приход", включая и саму эту ячейку?
 
Ответить
Сообщениеи до кучи, в том же файле, что в сообщении №3 от Egyptian: как закрашивать желтым ячейки слева от ячейки "приход", включая и саму эту ячейку?

Автор - romanchenko
Дата добавления - 30.12.2021 в 01:01
Egyptian Дата: Четверг, 30.12.2021, 09:50 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 393
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
romanchenko, Формула УФ.
Код
=$Q3="приход"

Назначить на диапазон D3:Q7
К сообщению приложен файл: 7826319.xlsx(11.4 Kb)


Сообщение отредактировал Egyptian - Четверг, 30.12.2021, 09:50
 
Ответить
Сообщениеromanchenko, Формула УФ.
Код
=$Q3="приход"

Назначить на диапазон D3:Q7

Автор - Egyptian
Дата добавления - 30.12.2021 в 09:50
romanchenko Дата: Четверг, 10.03.2022, 09:50 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Я снова с вами. В приложенном файле, в столбце итого - формула. Как сделать так, чтобы эта формула отрабатывала только если слева от нее есть "расход"?
К сообщению приложен файл: 9262338.xlsx(12.8 Kb)
 
Ответить
СообщениеЯ снова с вами. В приложенном файле, в столбце итого - формула. Как сделать так, чтобы эта формула отрабатывала только если слева от нее есть "расход"?

Автор - romanchenko
Дата добавления - 10.03.2022 в 09:50
китин Дата: Четверг, 10.03.2022, 10:07 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
так?
Код
=СУММЕСЛИ(Z3:Z100;"расход";AA3:AA100)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениетак?
Код
=СУММЕСЛИ(Z3:Z100;"расход";AA3:AA100)

Автор - китин
Дата добавления - 10.03.2022 в 10:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Простейший учет приход/расход на 1 листе (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!