Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Данные из ячейки по столбцам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Данные из ячейки по столбцам (Формулы/Formulas)
Данные из ячейки по столбцам
sharip199605 Дата: Вторник, 18.01.2022, 16:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Доброго времени суток.
Прикрепил файл где даны данные в столбец 1, 2 и 3.
В столбце 3 данные находятся в одной ячейке по нескольку строк и необходимо вытащить информацию с каждой строки и распределить по следующим столбцам (цена).
Уже который час мучаюсь и нет вдохновения. Просьба помочь.

Примечание: Данные в столбцах 3 условные т.е. названия могут быть произвольные но формат записи такой же.
К сообщению приложен файл: 3444568.xlsx(10.1 Kb)


Сообщение отредактировал sharip199605 - Вторник, 18.01.2022, 16:58
 
Ответить
СообщениеДоброго времени суток.
Прикрепил файл где даны данные в столбец 1, 2 и 3.
В столбце 3 данные находятся в одной ячейке по нескольку строк и необходимо вытащить информацию с каждой строки и распределить по следующим столбцам (цена).
Уже который час мучаюсь и нет вдохновения. Просьба помочь.

Примечание: Данные в столбцах 3 условные т.е. названия могут быть произвольные но формат записи такой же.

Автор - sharip199605
Дата добавления - 18.01.2022 в 16:54
Nic70y Дата: Вторник, 18.01.2022, 17:14 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7723
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
вариант
Код
=ЕСЛИОШИБКА(--ЛЕВБ(ПОДСТАВИТЬ(ПСТР($C2;ПОИСК(" - ";ПСТР($C2;ПОИСК("@";ПОДСТАВИТЬ(СИМВОЛ(10)&$C2;СИМВОЛ(10);"@";СТОЛБЕЦ(A1)));99))+ПОИСК("@";ПОДСТАВИТЬ(СИМВОЛ(10)&$C2;СИМВОЛ(10);"@";СТОЛБЕЦ(A1)))+2;15);"р.";ПОВТОР(" ";15));15);"")
К сообщению приложен файл: 27.xlsx(11.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевариант
Код
=ЕСЛИОШИБКА(--ЛЕВБ(ПОДСТАВИТЬ(ПСТР($C2;ПОИСК(" - ";ПСТР($C2;ПОИСК("@";ПОДСТАВИТЬ(СИМВОЛ(10)&$C2;СИМВОЛ(10);"@";СТОЛБЕЦ(A1)));99))+ПОИСК("@";ПОДСТАВИТЬ(СИМВОЛ(10)&$C2;СИМВОЛ(10);"@";СТОЛБЕЦ(A1)))+2;15);"р.";ПОВТОР(" ";15));15);"")

Автор - Nic70y
Дата добавления - 18.01.2022 в 17:14
sharip199605 Дата: Среда, 19.01.2022, 08:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

это конечно великолепно, но как бы применить к этой таблице
в долгу не останусь )
К сообщению приложен файл: 6333626.xlsx(14.0 Kb)
 
Ответить
Сообщениеэто конечно великолепно, но как бы применить к этой таблице
в долгу не останусь )

Автор - sharip199605
Дата добавления - 19.01.2022 в 08:57
sharip199605 Дата: Среда, 19.01.2022, 09:03 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Там в таб лице просто дефисы произвольно идут и эту формулу не получается, либо можно сначала удалить все остальные дефисы в ячейке оставив только те что нужны. %)
 
Ответить
СообщениеNic70y, Там в таб лице просто дефисы произвольно идут и эту формулу не получается, либо можно сначала удалить все остальные дефисы в ячейке оставив только те что нужны. %)

Автор - sharip199605
Дата добавления - 19.01.2022 в 09:03
Nic70y Дата: Среда, 19.01.2022, 09:13 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 7723
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИОШИБКА(--ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ($C2;ПОИСК("\";ПОДСТАВИТЬ($C2;"м. ";"\";СТОЛБЕЦ(A1)))-1);" ";ПОВТОР(" ";15));15);"")
К сообщению приложен файл: 407.xlsx(15.0 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(--ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ($C2;ПОИСК("\";ПОДСТАВИТЬ($C2;"м. ";"\";СТОЛБЕЦ(A1)))-1);" ";ПОВТОР(" ";15));15);"")

Автор - Nic70y
Дата добавления - 19.01.2022 в 09:13
sharip199605 Дата: Среда, 19.01.2022, 10:01 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Да вы просто гений hands
 
Ответить
СообщениеNic70y, Да вы просто гений hands

Автор - sharip199605
Дата добавления - 19.01.2022 в 10:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Данные из ячейки по столбцам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!