Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Укоротить формулу из функций =ЕСЛИ(ИЛИ()) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Укоротить формулу из функций =ЕСЛИ(ИЛИ()) (Формулы/Formulas)
Укоротить формулу из функций =ЕСЛИ(ИЛИ())
DrMini Дата: Четверг, 27.01.2022, 11:46 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Доброго времени суток форумчане гости форума.
Подскажите пожалуйста возможно ли сделать формулу короче.
Приводу пример для трёх месяцев:
Код
=ЕСЛИ(ИЛИ($A$1=1;$A$1="Январь");"Январь";ЕСЛИ(ИЛИ($A$1=2;$A$1="Февраль");"Февраль";ЕСЛИ(ИЛИ($A$1=3;$A$1="Март");"Март";"")))

Ограничения:
Не использовать функции не поддерживаемые офисом 2007;
Не использовать массивную формулу;
Не использовать макрос.
К сообщению приложен файл: 220127-0.xls(26.5 Kb)
 
Ответить
СообщениеДоброго времени суток форумчане гости форума.
Подскажите пожалуйста возможно ли сделать формулу короче.
Приводу пример для трёх месяцев:
Код
=ЕСЛИ(ИЛИ($A$1=1;$A$1="Январь");"Январь";ЕСЛИ(ИЛИ($A$1=2;$A$1="Февраль");"Февраль";ЕСЛИ(ИЛИ($A$1=3;$A$1="Март");"Март";"")))

Ограничения:
Не использовать функции не поддерживаемые офисом 2007;
Не использовать массивную формулу;
Не использовать макрос.

Автор - DrMini
Дата добавления - 27.01.2022 в 11:46
Pelena Дата: Четверг, 27.01.2022, 11:57 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18561
Репутация: 4204 ±
Замечаний: ±

Excel 2016 & Mac Excel
Вариант
Код
=ТЕКСТ(--("1-"&A1);"ММММ")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеВариант
Код
=ТЕКСТ(--("1-"&A1);"ММММ")

Автор - Pelena
Дата добавления - 27.01.2022 в 11:57
Serge_007 Дата: Четверг, 27.01.2022, 13:07 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15428
Репутация: 2539 ±
Замечаний: ±

Excel 2016
Лена дала самый короткий вариант формулы, чем сразу убила всю интригу :D
Но можно пойти дальше, ведь в условиях задачи нет запрета на форматирование ;)

Код
=("1."&A1)*1
К сообщению приложен файл: 20220127_DrMini.xls(59.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЛена дала самый короткий вариант формулы, чем сразу убила всю интригу :D
Но можно пойти дальше, ведь в условиях задачи нет запрета на форматирование ;)

Код
=("1."&A1)*1

Автор - Serge_007
Дата добавления - 27.01.2022 в 13:07
DrMini Дата: Четверг, 27.01.2022, 13:11 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
ведь в условиях задачи нет запрета на форматирование

Неа. Нету. :D
 
Ответить
Сообщение
ведь в условиях задачи нет запрета на форматирование

Неа. Нету. :D

Автор - DrMini
Дата добавления - 27.01.2022 в 13:11
bmv98rus Дата: Четверг, 27.01.2022, 13:17 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3944
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016
Pelena, Лен текст по умолчанию преобразует в число если может
Код
=TEXT("1-"&A1;"ММММ")
но есть нюанс, формула зависит от региональных установок.

Код
=IFERROR(CHOOSE(A1;"Январь";"Февраль";"Март";"Апрель";"Май";"Июнь";"Июль";"Август";"Сентябрь";"Октябрь";"Ноябрь";"Декабрь");A1)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 27.01.2022, 13:18
 
Ответить
СообщениеPelena, Лен текст по умолчанию преобразует в число если может
Код
=TEXT("1-"&A1;"ММММ")
но есть нюанс, формула зависит от региональных установок.

Код
=IFERROR(CHOOSE(A1;"Январь";"Февраль";"Март";"Апрель";"Май";"Июнь";"Июль";"Август";"Сентябрь";"Октябрь";"Ноябрь";"Декабрь");A1)

Автор - bmv98rus
Дата добавления - 27.01.2022 в 13:17
DrMini Дата: Четверг, 27.01.2022, 13:17 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Леночка и Сергей большое человеческое СПАСИБО!
Только один вопрос что делает вот эта часть формулы:
Код
"1-"
и вот эта
Код
"1."
?
[p.s.]прошу прощения за фамильярность[/p.s.]


Сообщение отредактировал DrMini - Четверг, 27.01.2022, 13:53
 
Ответить
СообщениеЛеночка и Сергей большое человеческое СПАСИБО!
Только один вопрос что делает вот эта часть формулы:
Код
"1-"
и вот эта
Код
"1."
?
[p.s.]прошу прощения за фамильярность[/p.s.]

Автор - DrMini
Дата добавления - 27.01.2022 в 13:17
bmv98rus Дата: Четверг, 27.01.2022, 13:21 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3944
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016
что делаетт вот эта часть формулы
закладывает региональную мину замедленного действия :-)
Текст подобный 1.Январь .....или 1-1 ..... преобразуется в дату текущего года. Даже 1Январь тоже, но как уже писал выше, при определенных региональных.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 27.01.2022, 13:26
 
Ответить
Сообщение
что делаетт вот эта часть формулы
закладывает региональную мину замедленного действия :-)
Текст подобный 1.Январь .....или 1-1 ..... преобразуется в дату текущего года. Даже 1Январь тоже, но как уже писал выше, при определенных региональных.

Автор - bmv98rus
Дата добавления - 27.01.2022 в 13:21
DrMini Дата: Четверг, 27.01.2022, 13:35 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
закладывает региональную мину замедленного действия

Мне нужна только надпись названия месяца. Думаю всё будет норм. С ячейкой в которую вписывается эта формула дальнейших расчётов не будет.


Сообщение отредактировал DrMini - Четверг, 27.01.2022, 13:36
 
Ответить
Сообщение
закладывает региональную мину замедленного действия

Мне нужна только надпись названия месяца. Думаю всё будет норм. С ячейкой в которую вписывается эта формула дальнейших расчётов не будет.

Автор - DrMini
Дата добавления - 27.01.2022 в 13:35
Serge_007 Дата: Четверг, 27.01.2022, 13:47 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 15428
Репутация: 2539 ±
Замечаний: ±

Excel 2016
что делаетт вот эта часть формулы
Конкатенирует день "1", "1." или "1-" и месяц (значение из ячейки А1)
В результате получается дата, из которой функцией ТЕКСТ или форматом ячеек возвращаем месяц

региональную мину
Да, есть такое...


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
что делаетт вот эта часть формулы
Конкатенирует день "1", "1." или "1-" и месяц (значение из ячейки А1)
В результате получается дата, из которой функцией ТЕКСТ или форматом ячеек возвращаем месяц

региональную мину
Да, есть такое...

Автор - Serge_007
Дата добавления - 27.01.2022 в 13:47
DrMini Дата: Четверг, 27.01.2022, 13:56 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Конкатенирует

Я и слова то такого не слыхивал.
Постараюсь запомнить может, где это словцо и "вставить" получится.
:p
 
Ответить
Сообщение
Конкатенирует

Я и слова то такого не слыхивал.
Постараюсь запомнить может, где это словцо и "вставить" получится.
:p

Автор - DrMini
Дата добавления - 27.01.2022 в 13:56
Serge_007 Дата: Четверг, 27.01.2022, 14:21 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 15428
Репутация: 2539 ±
Замечаний: ±

Excel 2016
"Конкатенация" - иначе "сцепка"

В Excel есть функция СЦЕПИТЬ(), ну, или амперсанд & - они равнозначны по своему действию


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение"Конкатенация" - иначе "сцепка"

В Excel есть функция СЦЕПИТЬ(), ну, или амперсанд & - они равнозначны по своему действию

Автор - Serge_007
Дата добавления - 27.01.2022 в 14:21
bmv98rus Дата: Четверг, 27.01.2022, 14:29 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3944
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016
В Excel есть функция СЦЕПИТЬ()
почему не перевели нормально ПАРАВОЗ() например :D, раз уж CONCATENATE заменили не на СОЕДИНИТЬ.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
В Excel есть функция СЦЕПИТЬ()
почему не перевели нормально ПАРАВОЗ() например :D, раз уж CONCATENATE заменили не на СОЕДИНИТЬ.

Автор - bmv98rus
Дата добавления - 27.01.2022 в 14:29
DrMini Дата: Четверг, 27.01.2022, 14:44 | Сообщение № 13
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
"Конкатенация" - иначе "сцепка"

Ага. Сразу в Википедии поглядел.
 
Ответить
Сообщение
"Конкатенация" - иначе "сцепка"

Ага. Сразу в Википедии поглядел.

Автор - DrMini
Дата добавления - 27.01.2022 в 14:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Укоротить формулу из функций =ЕСЛИ(ИЛИ()) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!