Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка ячеек данных с датой относительно выбранной даты - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка ячеек данных с датой относительно выбранной даты (Формулы/Formulas)
Сортировка ячеек данных с датой относительно выбранной даты
filipp1701 Дата: Среда, 02.02.2022, 14:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Подскажите, как можно автоматически преобразовать данные из листа 1, чтобы они приняли вид данных из листа 2. Продукты должны сортироваться по дате. Начальной датой является 01.01.2010.
К сообщению приложен файл: 6798759.xlsx(13.0 Kb)
 
Ответить
СообщениеПодскажите, как можно автоматически преобразовать данные из листа 1, чтобы они приняли вид данных из листа 2. Продукты должны сортироваться по дате. Начальной датой является 01.01.2010.

Автор - filipp1701
Дата добавления - 02.02.2022 в 14:56
Nic70y Дата: Среда, 02.02.2022, 16:11 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7744
Репутация: 1858 ±
Замечаний: 0% ±

Excel 2010
вариант формулами.
самая тяжелая
Код
=СУММЕСЛИМН(Лист1!$C:$C;Лист1!$A:$A;$B4;Лист1!$B:$B;C$1)
если будет тормозить - ссылки на столбцы замените на максимально возможные, например:
Лист1!$C$1:$C$1000 и т.п.
К сообщению приложен файл: 92.xlsx(21.6 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Среда, 02.02.2022, 16:14
 
Ответить
Сообщениевариант формулами.
самая тяжелая
Код
=СУММЕСЛИМН(Лист1!$C:$C;Лист1!$A:$A;$B4;Лист1!$B:$B;C$1)
если будет тормозить - ссылки на столбцы замените на максимально возможные, например:
Лист1!$C$1:$C$1000 и т.п.

Автор - Nic70y
Дата добавления - 02.02.2022 в 16:11
filipp1701 Дата: Четверг, 03.02.2022, 07:42 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Можете более подробно объяснить смысл использования формулы (2 лист (01.01.2010)) =ЕСЛИ(C4;C$1;"") - В чем здесь заключается условие?
 
Ответить
СообщениеNic70y, Можете более подробно объяснить смысл использования формулы (2 лист (01.01.2010)) =ЕСЛИ(C4;C$1;"") - В чем здесь заключается условие?

Автор - filipp1701
Дата добавления - 03.02.2022 в 07:42
Nic70y Дата: Четверг, 03.02.2022, 07:59 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7744
Репутация: 1858 ±
Замечаний: 0% ±

Excel 2010
в строках "Кол-во штук" сумма по условиям даты и наименования, если по данным даты/наименования ни чего нет формула
выводит значение 0,
в ячейках установлен формат 0;; - т.е. 0 не отображается.
=ЕСЛИ(C4;
0 = ЛОЖЬ, не 0 = ИСТИНА
если ИСТИНА = дата, если ЛОЖЬ = "" (условно пусто)


ЮMoney 41001841029809
 
Ответить
Сообщениев строках "Кол-во штук" сумма по условиям даты и наименования, если по данным даты/наименования ни чего нет формула
выводит значение 0,
в ячейках установлен формат 0;; - т.е. 0 не отображается.
=ЕСЛИ(C4;
0 = ЛОЖЬ, не 0 = ИСТИНА
если ИСТИНА = дата, если ЛОЖЬ = "" (условно пусто)

Автор - Nic70y
Дата добавления - 03.02.2022 в 07:59
filipp1701 Дата: Четверг, 03.02.2022, 09:26 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо, с этим разобрался.
И еще вот такой вопрос, если на первом листе появится дополнительная колонка склад, как можно информацию из этой колонки перенести на второй лист?
К сообщению приложен файл: 2013154.xlsx(21.9 Kb)
 
Ответить
СообщениеNic70y, спасибо, с этим разобрался.
И еще вот такой вопрос, если на первом листе появится дополнительная колонка склад, как можно информацию из этой колонки перенести на второй лист?

Автор - filipp1701
Дата добавления - 03.02.2022 в 09:26
китин Дата: Четверг, 03.02.2022, 09:28 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 6898
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
filipp1701, это уже второй вопрос, а следовательно новая тема


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеfilipp1701, это уже второй вопрос, а следовательно новая тема

Автор - китин
Дата добавления - 03.02.2022 в 09:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка ячеек данных с датой относительно выбранной даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!