Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Пустые ячейки, вместо ошибок из формул - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пустые ячейки, вместо ошибок из формул (Формулы/Formulas)
Пустые ячейки, вместо ошибок из формул
Vasian55 Дата: Четверг, 10.02.2022, 16:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Добрый день
прошу помощи, уже вбиты формулы для расчета показателей, но первичных данных пока нету, из-за этого вылезают ошибки #Н/Д итд
как вместо ошибок оставить пустые ячейки, на большой таблице очень неудобно смотреть такие данные
К сообщению приложен файл: ___.xls(35.0 Kb)
 
Ответить
СообщениеДобрый день
прошу помощи, уже вбиты формулы для расчета показателей, но первичных данных пока нету, из-за этого вылезают ошибки #Н/Д итд
как вместо ошибок оставить пустые ячейки, на большой таблице очень неудобно смотреть такие данные

Автор - Vasian55
Дата добавления - 10.02.2022 в 16:31
baxtiyor1916 Дата: Четверг, 10.02.2022, 16:56 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

например, вместо
Код
=СРГАРМ(B3;C3)

пишите:
Код
=ЕСНД(СРГАРМ(B3;C3);"")


или вместо
Код
=ВПР(A1;B:D;2)


Код
=ЕСНД(ВПР(A1;B:D;2);"")
 
Ответить
Сообщениенапример, вместо
Код
=СРГАРМ(B3;C3)

пишите:
Код
=ЕСНД(СРГАРМ(B3;C3);"")


или вместо
Код
=ВПР(A1;B:D;2)


Код
=ЕСНД(ВПР(A1;B:D;2);"")

Автор - baxtiyor1916
Дата добавления - 10.02.2022 в 16:56
Vasian55 Дата: Четверг, 10.02.2022, 17:19 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

только в стобце I получилось
Код
=ЕСНД(СРГАРМ(B3;C3);"")
прописать, остальное или сама формула ругается что мало данных или не делает пустуй строчку
 
Ответить
Сообщениетолько в стобце I получилось
Код
=ЕСНД(СРГАРМ(B3;C3);"")
прописать, остальное или сама формула ругается что мало данных или не делает пустуй строчку

Автор - Vasian55
Дата добавления - 10.02.2022 в 17:19
Pelena Дата: Четверг, 10.02.2022, 17:35 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Vasian55, откройте для себя функцию ЕСЛИОШИБКА()


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеVasian55, откройте для себя функцию ЕСЛИОШИБКА()

Автор - Pelena
Дата добавления - 10.02.2022 в 17:35
Смольный Дата: Четверг, 10.02.2022, 17:41 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Vasian55, ячейка I3 там формула
Код
=ЕСЛИОШИБКА(СРГАРМ(B3;C3);"")
и так во всех где #Н/Д =ЕСЛИОШИБКА(ваша формула;"")
 
Ответить
СообщениеVasian55, ячейка I3 там формула
Код
=ЕСЛИОШИБКА(СРГАРМ(B3;C3);"")
и так во всех где #Н/Д =ЕСЛИОШИБКА(ваша формула;"")

Автор - Смольный
Дата добавления - 10.02.2022 в 17:41
_Igor_61 Дата: Четверг, 10.02.2022, 18:19 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 504
Репутация: 90 ±
Замечаний: 0% ±

Excel 2007
Будем надеяться, что старые функции производитель будет оставлять нетронутыми... Предлагают новые недоработанные взамен проверенных... А у детей когнитивный диссонанс получается... Хорошо что из 2003 и 2007 пока живые...
 
Ответить
СообщениеБудем надеяться, что старые функции производитель будет оставлять нетронутыми... Предлагают новые недоработанные взамен проверенных... А у детей когнитивный диссонанс получается... Хорошо что из 2003 и 2007 пока живые...

Автор - _Igor_61
Дата добавления - 10.02.2022 в 18:19
DrMini Дата: Четверг, 10.02.2022, 20:17 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Если без стёба, то может так?
К сообщению приложен файл: 6866708.xls(35.5 Kb)
 
Ответить
СообщениеЕсли без стёба, то может так?

Автор - DrMini
Дата добавления - 10.02.2022 в 20:17
Vasian55 Дата: Четверг, 10.02.2022, 21:35 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

спасибо большое


Сообщение отредактировал Serge_007 - Пятница, 11.02.2022, 10:04
 
Ответить
Сообщениеспасибо большое

Автор - Vasian55
Дата добавления - 10.02.2022 в 21:35
DrMini Дата: Пятница, 11.02.2022, 11:17 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Здравствуйте Vasian55
По Вашему вопросу в личку.
Выделите ячейки=>ПКМ=>Формат ячеек=>Число=>Число десятичных знаков=>1 (там по умолчанию 2 знака после запятой.
Файл приложил.
К сообщению приложен файл: 0773836.xls(39.0 Kb) · __2.xls(39.0 Kb)


Сообщение отредактировал DrMini - Суббота, 12.02.2022, 10:19
 
Ответить
СообщениеЗдравствуйте Vasian55
По Вашему вопросу в личку.
Выделите ячейки=>ПКМ=>Формат ячеек=>Число=>Число десятичных знаков=>1 (там по умолчанию 2 знака после запятой.
Файл приложил.

Автор - DrMini
Дата добавления - 11.02.2022 в 11:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пустые ячейки, вместо ошибок из формул (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!