Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет разницы времени в определенном месяце - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет разницы времени в определенном месяце (Формулы/Formulas)
Расчет разницы времени в определенном месяце
Xoloitzcuintle Дата: Воскресенье, 13.02.2022, 10:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Всем добрый день!
Не могу никак сообразить как рассчитать разницу дат в определенном месяце.
В общем имеется таблица № пункта, Название агрегата, Дата пуска, Дата останова.

В итоговой таблице за январь и другие месяцы необходимо рассчитать сколько времени работал каждый агрегат в данном месяце.

Приходит только на ум использовать функцию СУММЕСЛИМН. Но из-за того что время работы перетекает на другой месяц использовать функцию СУММЕСЛИМН получается проблематично.
К сообщению приложен файл: ___.xlsx(9.4 Kb)
 
Ответить
СообщениеВсем добрый день!
Не могу никак сообразить как рассчитать разницу дат в определенном месяце.
В общем имеется таблица № пункта, Название агрегата, Дата пуска, Дата останова.

В итоговой таблице за январь и другие месяцы необходимо рассчитать сколько времени работал каждый агрегат в данном месяце.

Приходит только на ум использовать функцию СУММЕСЛИМН. Но из-за того что время работы перетекает на другой месяц использовать функцию СУММЕСЛИМН получается проблематично.

Автор - Xoloitzcuintle
Дата добавления - 13.02.2022 в 10:41
Pelena Дата: Воскресенье, 13.02.2022, 11:57 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Вариант в часах
Код
=СУММПРОИЗВ(($B$2:$B$6=$G2)*ТЕКСТ(ДАТАМЕС(H$1;1)-($C$2:$C$6+ТЕКСТ(H$1-$C$2:$C$6;"[ч];\0")/24)-(ТЕКСТ(ДАТАМЕС(H$1;1)-$D$2:$D$6;"[ч];\0")/24);"[ч];\0"))
К сообщению приложен файл: -3-.xlsx(11.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вариант в часах
Код
=СУММПРОИЗВ(($B$2:$B$6=$G2)*ТЕКСТ(ДАТАМЕС(H$1;1)-($C$2:$C$6+ТЕКСТ(H$1-$C$2:$C$6;"[ч];\0")/24)-(ТЕКСТ(ДАТАМЕС(H$1;1)-$D$2:$D$6;"[ч];\0")/24);"[ч];\0"))

Автор - Pelena
Дата добавления - 13.02.2022 в 11:57
Xoloitzcuintle Дата: Воскресенье, 13.02.2022, 14:01 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Спасибо за ценный ответ
 
Ответить
СообщениеPelena, Спасибо за ценный ответ

Автор - Xoloitzcuintle
Дата добавления - 13.02.2022 в 14:01
bmv98rus Дата: Понедельник, 14.02.2022, 11:48 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3944
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016
Избавимся от привязки к региональным установкам ( ч )
Код
=SUMPRODUCT(($B$2:$B$6=$G2)*TEXT(($D$2:$D$6+EDATE(H$1;1)-ABS($D$2:$D$6-EDATE(H$1;1))-$C$2:$C$6-H$1-ABS($C$2:$C$6-H$1))*12;"0;\0"))
К сообщению приложен файл: example2602.xlsx(10.9 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеИзбавимся от привязки к региональным установкам ( ч )
Код
=SUMPRODUCT(($B$2:$B$6=$G2)*TEXT(($D$2:$D$6+EDATE(H$1;1)-ABS($D$2:$D$6-EDATE(H$1;1))-$C$2:$C$6-H$1-ABS($C$2:$C$6-H$1))*12;"0;\0"))

Автор - bmv98rus
Дата добавления - 14.02.2022 в 11:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет разницы времени в определенном месяце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!