Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма по критериям из двух таблиц - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по критериям из двух таблиц (Формулы/Formulas)
Сумма по критериям из двух таблиц
Алламер Дата: Понедельник, 04.04.2022, 15:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Всем добрый день!
Столкнулся с проблемой при попытке свода суммы по двум критериям из двух разных таблиц.

У меня есть две таблицы. В первой номера клиентов и суммы по каждой из операций. Во второй таблице номера клиентов и их принадлежность к регионам.
Мне нужно свести сумму по регионам.

Всё, казалось бы, очень просто, но:
1. сумму я свожу не в этих двух таблицах, а отдельно (скажем так, в третей таблице)
2. первые две таблицы данных нельзя изменять (они обновляются, так сказать, автоматически, поэтому я не могу добавить новую колонку и тем самым "перетащить" один из критериев из другой таблицы)

Пример прикрепил.

Пробовал через суммесли + впр, но ничего не получилось.

Заранее благодарю за помощь!
К сообщению приложен файл: Tab1.xlsx(10.7 Kb)
 
Ответить
СообщениеВсем добрый день!
Столкнулся с проблемой при попытке свода суммы по двум критериям из двух разных таблиц.

У меня есть две таблицы. В первой номера клиентов и суммы по каждой из операций. Во второй таблице номера клиентов и их принадлежность к регионам.
Мне нужно свести сумму по регионам.

Всё, казалось бы, очень просто, но:
1. сумму я свожу не в этих двух таблицах, а отдельно (скажем так, в третей таблице)
2. первые две таблицы данных нельзя изменять (они обновляются, так сказать, автоматически, поэтому я не могу добавить новую колонку и тем самым "перетащить" один из критериев из другой таблицы)

Пример прикрепил.

Пробовал через суммесли + впр, но ничего не получилось.

Заранее благодарю за помощь!

Автор - Алламер
Дата добавления - 04.04.2022 в 15:22
_Boroda_ Дата: Понедельник, 04.04.2022, 15:26 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИ(A$3:A$10;ПРОСМОТР(A15;E$3:E$7;D$3:D$7);B$3:B$10)

Код
=СУММЕСЛИ(A$3:A$10;ИНДЕКС(D$3:D$7;ПОИСКПОЗ(A15;E$3:E$7;));B$3:B$10)

Код
=СУММЕСЛИ(A$3:A$10;СУММЕСЛИ(E$3:E$7;A15;D$3:D$7);B$3:B$10)

Код
=СУММЕСЛИ(A$3:A$10;СУММПРОИЗВ((E$3:E$7=A15)*D$3:D$7);B$3:B$10)

Код
=СУММ(B$3:B$10*(A$3:A$10=ТРАНСП(D$3:D$7*(E$3:E$7=A15))))

Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
К сообщению приложен файл: Tab1_.xlsx(11.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Понедельник, 04.04.2022, 15:35
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИ(A$3:A$10;ПРОСМОТР(A15;E$3:E$7;D$3:D$7);B$3:B$10)

Код
=СУММЕСЛИ(A$3:A$10;ИНДЕКС(D$3:D$7;ПОИСКПОЗ(A15;E$3:E$7;));B$3:B$10)

Код
=СУММЕСЛИ(A$3:A$10;СУММЕСЛИ(E$3:E$7;A15;D$3:D$7);B$3:B$10)

Код
=СУММЕСЛИ(A$3:A$10;СУММПРОИЗВ((E$3:E$7=A15)*D$3:D$7);B$3:B$10)

Код
=СУММ(B$3:B$10*(A$3:A$10=ТРАНСП(D$3:D$7*(E$3:E$7=A15))))

Формула массива, вводится одновременным нажатием Контрл Шифт Ентер

Автор - _Boroda_
Дата добавления - 04.04.2022 в 15:26
Алламер Дата: Понедельник, 04.04.2022, 15:36 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Так нужно?


увы, не совсем. Оно не видит нескольких из одного и того самого региона. Пример прикрепил.
К сообщению приложен файл: Tab2.xlsx(11.4 Kb)
 
Ответить
Сообщение
Так нужно?


увы, не совсем. Оно не видит нескольких из одного и того самого региона. Пример прикрепил.

Автор - Алламер
Дата добавления - 04.04.2022 в 15:36
_Boroda_ Дата: Понедельник, 04.04.2022, 15:46 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Дык, каков пример был, таков и ответ )))

Последняя формула работает. Только измените в ячейке Е4 английскую А на русскую


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДык, каков пример был, таков и ответ )))

Последняя формула работает. Только измените в ячейке Е4 английскую А на русскую

Автор - _Boroda_
Дата добавления - 04.04.2022 в 15:46
_Boroda_ Дата: Понедельник, 04.04.2022, 15:49 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСКПОЗ(A$3:A$10;(E$3:E$7=A15)*D$3:D$7;))*B$3:B$10)
К сообщению приложен файл: Tab2_1.xlsx(11.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСКПОЗ(A$3:A$10;(E$3:E$7=A15)*D$3:D$7;))*B$3:B$10)

Автор - _Boroda_
Дата добавления - 04.04.2022 в 15:49
Алламер Дата: Понедельник, 04.04.2022, 15:51 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Тупанул, уж простите. Параллельно работаю, вот и не заметил. Думал Вы про последнюю в файле. Попробовал с той, что Вы прописали тут, на форуме - вроде как работает. Нужно протестить с настоящими данными.

Благодарю!


Сообщение отредактировал Serge_007 - Понедельник, 04.04.2022, 17:25
 
Ответить
СообщениеТупанул, уж простите. Параллельно работаю, вот и не заметил. Думал Вы про последнюю в файле. Попробовал с той, что Вы прописали тут, на форуме - вроде как работает. Нужно протестить с настоящими данными.

Благодарю!

Автор - Алламер
Дата добавления - 04.04.2022 в 15:51
jakim Дата: Понедельник, 04.04.2022, 18:16 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1116
Репутация: 295 ±
Замечаний: 0% ±

Excel 2010
Power Query

[vba]
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    #"Changed Type" = Table.TransformColumnTypes(Source,{{"Номер клиента", Int64.Type}, {"Сумма", type number}}),
    #"Merged Queries" = Table.NestedJoin(#"Changed Type",{"Номер клиента"},Table2,{"Номер клиента"},"NewColumn",JoinKind.LeftOuter),
    #"Expanded NewColumn" = Table.ExpandTableColumn(#"Merged Queries", "NewColumn", {"Регион"}, {"NewColumn.Регион"}),
    #"Reordered Columns" = Table.ReorderColumns(#"Expanded NewColumn",{"Номер клиента", "NewColumn.Регион", "Сумма"}),
    #"Grouped Rows" = Table.Group(#"Reordered Columns", {"Номер клиента", "NewColumn.Регион"}, {{"Count", each List.Sum([Сумма]), type number}}),
    #"Removed Columns" = Table.RemoveColumns(#"Grouped Rows",{"Номер клиента"}),
    #"Renamed Columns" = Table.RenameColumns(#"Removed Columns",{{"NewColumn.Регион", "Регион"}, {"Count", "Сумма"}})
in
    #"Renamed Columns"
[/vba]
К сообщению приложен файл: 9324566.xlsx(19.2 Kb)
 
Ответить
Сообщение
Power Query

[vba]
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    #"Changed Type" = Table.TransformColumnTypes(Source,{{"Номер клиента", Int64.Type}, {"Сумма", type number}}),
    #"Merged Queries" = Table.NestedJoin(#"Changed Type",{"Номер клиента"},Table2,{"Номер клиента"},"NewColumn",JoinKind.LeftOuter),
    #"Expanded NewColumn" = Table.ExpandTableColumn(#"Merged Queries", "NewColumn", {"Регион"}, {"NewColumn.Регион"}),
    #"Reordered Columns" = Table.ReorderColumns(#"Expanded NewColumn",{"Номер клиента", "NewColumn.Регион", "Сумма"}),
    #"Grouped Rows" = Table.Group(#"Reordered Columns", {"Номер клиента", "NewColumn.Регион"}, {{"Count", each List.Sum([Сумма]), type number}}),
    #"Removed Columns" = Table.RemoveColumns(#"Grouped Rows",{"Номер клиента"}),
    #"Renamed Columns" = Table.RenameColumns(#"Removed Columns",{{"NewColumn.Регион", "Регион"}, {"Count", "Сумма"}})
in
    #"Renamed Columns"
[/vba]

Автор - jakim
Дата добавления - 04.04.2022 в 18:16
Egyptian Дата: Вторник, 05.04.2022, 10:15 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 393
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Еще формульный вариант:
Код
=SUMPRODUCT(COUNTIFS(E$3:E$7;A15;D$3:D$7;$A$3:$A$10)*B$3:B$10)
К сообщению приложен файл: 0870375.xlsx(10.9 Kb)
 
Ответить
СообщениеЕще формульный вариант:
Код
=SUMPRODUCT(COUNTIFS(E$3:E$7;A15;D$3:D$7;$A$3:$A$10)*B$3:B$10)

Автор - Egyptian
Дата добавления - 05.04.2022 в 10:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по критериям из двух таблиц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!