Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечение данных из таблицы по уникальности - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение данных из таблицы по уникальности (Формулы/Formulas)
Извлечение данных из таблицы по уникальности
elitvinenkophilips Дата: Понедельник, 04.04.2022, 16:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2010
Добрый день!

Есть такая задача, решить ее не получается:

база данных состоящая из столбцов, нужно на отдельный лист вынести все уникальные значения из одного из столбцов в базе.

В базе данные по вертикали, вынести нужно в горизонтальный ряд.
Что можно использовать для этого?

Пример прикрепляю.
К сообщению приложен файл: 5022921.xlsx(9.5 Kb)
 
Ответить
СообщениеДобрый день!

Есть такая задача, решить ее не получается:

база данных состоящая из столбцов, нужно на отдельный лист вынести все уникальные значения из одного из столбцов в базе.

В базе данные по вертикали, вынести нужно в горизонтальный ряд.
Что можно использовать для этого?

Пример прикрепляю.

Автор - elitvinenkophilips
Дата добавления - 04.04.2022 в 16:24
Nic70y Дата: Понедельник, 04.04.2022, 16:40 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
в файле 2 варианта: формулой массива
Код
=ИНДЕКС(база!$C2:$C7;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(база!$C2:$C7;база!$C2:$C7;)=СТРОКА(база!$C2:$C7)-1;СТРОКА(база!$C2:$C7)-1);СТОЛБЕЦ()))
и с доп.столбцом
К сообщению приложен файл: 5991196.xlsx(11.3 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениев файле 2 варианта: формулой массива
Код
=ИНДЕКС(база!$C2:$C7;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(база!$C2:$C7;база!$C2:$C7;)=СТРОКА(база!$C2:$C7)-1;СТРОКА(база!$C2:$C7)-1);СТОЛБЕЦ()))
и с доп.столбцом

Автор - Nic70y
Дата добавления - 04.04.2022 в 16:40
elitvinenkophilips Дата: Понедельник, 04.04.2022, 16:43 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2010
Nic70y, выглядит гениально. Буду вникать.
Спасибо!
 
Ответить
СообщениеNic70y, выглядит гениально. Буду вникать.
Спасибо!

Автор - elitvinenkophilips
Дата добавления - 04.04.2022 в 16:43
_Boroda_ Дата: Понедельник, 04.04.2022, 16:43 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант. Начиная со столбца В, формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(база!$C2:$C99;ПОИСКПОЗ(;СЧЁТЕСЛИ($A1:A1;база!$C2:$C99);))&"";"")
К сообщению приложен файл: 5022921_1.xlsx(9.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант. Начиная со столбца В, формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(база!$C2:$C99;ПОИСКПОЗ(;СЧЁТЕСЛИ($A1:A1;база!$C2:$C99);))&"";"")

Автор - _Boroda_
Дата добавления - 04.04.2022 в 16:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение данных из таблицы по уникальности (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!