Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение двух таблиц - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух таблиц (Формулы/Formulas)
Сравнение двух таблиц
serjiktsapin Дата: Понедельник, 11.04.2022, 00:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Требуется:
Таблица 1, имеющая в себе столбцы: склад, локация, вид упаковки, артикул, кол-во
Таблица 2, имеющая в себе столбцы: склад, локация, вид упаковки, артикул, кол-во
Требуется сравнить 2 таблицы, и найти расхождение (где то строки - лишние (которых нет в таблице - 1), где то в строках - отличается кол-во)

p.s. готов поблагодарить
К сообщению приложен файл: 6722701.xlsx(11.2 Kb)


Сообщение отредактировал serjiktsapin - Понедельник, 11.04.2022, 07:00
 
Ответить
СообщениеДобрый день.
Требуется:
Таблица 1, имеющая в себе столбцы: склад, локация, вид упаковки, артикул, кол-во
Таблица 2, имеющая в себе столбцы: склад, локация, вид упаковки, артикул, кол-во
Требуется сравнить 2 таблицы, и найти расхождение (где то строки - лишние (которых нет в таблице - 1), где то в строках - отличается кол-во)

p.s. готов поблагодарить

Автор - serjiktsapin
Дата добавления - 11.04.2022 в 00:46
_Boroda_ Дата: Понедельник, 11.04.2022, 09:08 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тема в ветке "Фриланс"
Вот она


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТема в ветке "Фриланс"
Вот она

Автор - _Boroda_
Дата добавления - 11.04.2022 в 09:08
китин Дата: Понедельник, 11.04.2022, 09:39 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A2&B2&C2&D2;$F$2:$F$56&$G$2:$G$56&$H$2:$H$56&$I$2:$I$56;0));"Нет в 1 таблице";"ОК")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: serjiktsapin.xlsx(13.2 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A2&B2&C2&D2;$F$2:$F$56&$G$2:$G$56&$H$2:$H$56&$I$2:$I$56;0));"Нет в 1 таблице";"ОК")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 11.04.2022 в 09:39
_Boroda_ Дата: Понедельник, 11.04.2022, 09:54 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно рядом с каждой из таблиц выводить количество
Код
=СУММЕСЛИМН(L$2:L$999;I$2:I$999;A2;J$2:J$999;B2;K$2:K$999;C2)
и сравнивать потом
В шапке пишем количество разночтений и их сумму
И красим все это безобразие условным форматированием
К сообщению приложен файл: 6722701_1.xlsx(13.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно рядом с каждой из таблиц выводить количество
Код
=СУММЕСЛИМН(L$2:L$999;I$2:I$999;A2;J$2:J$999;B2;K$2:K$999;C2)
и сравнивать потом
В шапке пишем количество разночтений и их сумму
И красим все это безобразие условным форматированием

Автор - _Boroda_
Дата добавления - 11.04.2022 в 09:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух таблиц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!