Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Простое условие по дате с возможностью автоматического ввода - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Простое условие по дате с возможностью автоматического ввода (Формулы/Formulas)
Простое условие по дате с возможностью автоматического ввода
kolyan13842 Дата: Понедельник, 02.05.2022, 17:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

У меня имеется список продаж. У каждой продажи указана дата продажи, источник получения заявки и тип (Впервые или Гарантия). Нужно из этого списка вычислять средний чек от продажи по типам, выручку и количество продаж каждого типа. Также нужен вывод информации по месяцам.
Я всё ввёл, вместе с месяцами, всё считается корректно. Условия для даты писал так ">=01.05.2022" "<=31.05.2022" . Но почему то от такого условия не получается сделать автоввод формул на дальнейшие месяца через протягивание, а писать всё вручную - это очень много писать придётся, да и как то неправильно это. Видимо условие для даты слишком сложно написано.
Вроде как можно сделать, чтоб в формуле была ссылка на месяц и год для которого эта формула считает, но я никак не могу найти.
Подскажите, как сделать возможность автоматического заполнения для следующих месяцев и лет?
Я новичок в этом деле, возможно мой вопрос может показаться глупым. Хотелось бы по возможности увидеть понятное новичку решение, очень хочу сам разобраться.
К сообщению приложен файл: 3732356.xlsx(13.6 Kb)
 
Ответить
СообщениеУ меня имеется список продаж. У каждой продажи указана дата продажи, источник получения заявки и тип (Впервые или Гарантия). Нужно из этого списка вычислять средний чек от продажи по типам, выручку и количество продаж каждого типа. Также нужен вывод информации по месяцам.
Я всё ввёл, вместе с месяцами, всё считается корректно. Условия для даты писал так ">=01.05.2022" "<=31.05.2022" . Но почему то от такого условия не получается сделать автоввод формул на дальнейшие месяца через протягивание, а писать всё вручную - это очень много писать придётся, да и как то неправильно это. Видимо условие для даты слишком сложно написано.
Вроде как можно сделать, чтоб в формуле была ссылка на месяц и год для которого эта формула считает, но я никак не могу найти.
Подскажите, как сделать возможность автоматического заполнения для следующих месяцев и лет?
Я новичок в этом деле, возможно мой вопрос может показаться глупым. Хотелось бы по возможности увидеть понятное новичку решение, очень хочу сам разобраться.

Автор - kolyan13842
Дата добавления - 02.05.2022 в 17:15
Pelena Дата: Понедельник, 02.05.2022, 18:28 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18394
Репутация: 4148 ±
Замечаний: ±

Excel 2016 & Mac Excel
И Вам здравствуйте.
Сводной таблицей не вариант?
К сообщению приложен файл: 4302130.xlsx(20.2 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Сводной таблицей не вариант?

Автор - Pelena
Дата добавления - 02.05.2022 в 18:28
kolyan13842 Дата: Понедельник, 02.05.2022, 18:53 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

И Вам здравствуйте.
Сводной таблицей не вариант?
К сообщению приложен файл: 4302130.xlsx(20.2 Kb)

Добрый день. Нет, нужно чтоб без сводной таблицы.
 
Ответить
Сообщение
И Вам здравствуйте.
Сводной таблицей не вариант?
К сообщению приложен файл: 4302130.xlsx(20.2 Kb)

Добрый день. Нет, нужно чтоб без сводной таблицы.

Автор - kolyan13842
Дата добавления - 02.05.2022 в 18:53
Pelena Дата: Понедельник, 02.05.2022, 19:11 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18394
Репутация: 4148 ±
Замечаний: ±

Excel 2016 & Mac Excel
Нет, нужно чтоб без сводной таблицы
ну да, лучше писать в каждой строке новую формулу >(
Но хозяин барин.
Как вариант, можно сделать доп. столбец с формулой
Код
=ТЕКСТ(C2;"ММММ ГГГГ")
и по нему уже ставить условие
[p.s.]И да, излишнее цитирование не приветствуется[/p.s.]


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
Нет, нужно чтоб без сводной таблицы
ну да, лучше писать в каждой строке новую формулу >(
Но хозяин барин.
Как вариант, можно сделать доп. столбец с формулой
Код
=ТЕКСТ(C2;"ММММ ГГГГ")
и по нему уже ставить условие
[p.s.]И да, излишнее цитирование не приветствуется[/p.s.]

Автор - Pelena
Дата добавления - 02.05.2022 в 19:11
kolyan13842 Дата: Понедельник, 02.05.2022, 21:24 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

ну да, лучше писать в каждой строке новую формулу

А чем это плохо и чем лучше сводная таблица? Серьёзно спрашиваю, я новичок в excel.
 
Ответить
Сообщение
ну да, лучше писать в каждой строке новую формулу

А чем это плохо и чем лучше сводная таблица? Серьёзно спрашиваю, я новичок в excel.

Автор - kolyan13842
Дата добавления - 02.05.2022 в 21:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Простое условие по дате с возможностью автоматического ввода (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!