Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР дублирующиеся данные - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР дублирующиеся данные (Формулы/Formulas)
ВПР дублирующиеся данные
russiapwnz Дата: Понедельник, 16.05.2022, 14:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!

Прошу помочь разбирающихся людей, суть проблемы в том что есть колонка D (артикул мы по нему ищем) но при стандартной формуле ВПР значение в колнке C дублируется при совпадении артикула, как заставить формулу пропускать полученное уже однажды значение?

Видел похожую тему с днями рождения, но там не совсем понятно как это прописать и как это работает, хотя суть очень похожа.

Заранее огромнейшее спасибо.
К сообщению приложен файл: 7995237.xlsx(43.6 Kb)
 
Ответить
СообщениеДобрый день!

Прошу помочь разбирающихся людей, суть проблемы в том что есть колонка D (артикул мы по нему ищем) но при стандартной формуле ВПР значение в колнке C дублируется при совпадении артикула, как заставить формулу пропускать полученное уже однажды значение?

Видел похожую тему с днями рождения, но там не совсем понятно как это прописать и как это работает, хотя суть очень похожа.

Заранее огромнейшее спасибо.

Автор - russiapwnz
Дата добавления - 16.05.2022 в 14:52
Serge_007 Дата: Понедельник, 16.05.2022, 15:02 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15298
Репутация: 2518 ±
Замечаний: ±

Excel 2016
Здравствуйте

Можно вместо полутора тысяч строк - не более десятка, но таких, что бы понятно было, что требуется сделать?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Можно вместо полутора тысяч строк - не более десятка, но таких, что бы понятно было, что требуется сделать?

Автор - Serge_007
Дата добавления - 16.05.2022 в 15:02
russiapwnz Дата: Понедельник, 16.05.2022, 15:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Прощу прощения, за много строк.
Требуется сделать так чтоб при поиске например по артикулу 1103301 мы не получали в столбе "C" один и тот же номер заказа (взятый из столбца B) в данном случае по моей формуле ВПР он дважды дублирует номер 254964848. Но нужно чтоб формула только 1 раз использовала заказ, а уже во второй строке использовала 252715636 следующий номер заказа и так далее.

В моем случае формула просто копирует первое полученное значение и вставляет его. Нужно чтоб у каждого артикула был свой индивидуальный номер из поля "B" находя его по поиску из поля "А"
Звучит сложно но по простому:

Нужно чтоб результат в колонке Ц не дублировался (ВПР в моем случае берет первое значение из поиска и его вставляет везде где подходит артикул) надо чтоб 1 артикул = 1 значению, и не дублировался в результате, не смотря на то что артикулы повторяются.
 
Ответить
СообщениеПрощу прощения, за много строк.
Требуется сделать так чтоб при поиске например по артикулу 1103301 мы не получали в столбе "C" один и тот же номер заказа (взятый из столбца B) в данном случае по моей формуле ВПР он дважды дублирует номер 254964848. Но нужно чтоб формула только 1 раз использовала заказ, а уже во второй строке использовала 252715636 следующий номер заказа и так далее.

В моем случае формула просто копирует первое полученное значение и вставляет его. Нужно чтоб у каждого артикула был свой индивидуальный номер из поля "B" находя его по поиску из поля "А"
Звучит сложно но по простому:

Нужно чтоб результат в колонке Ц не дублировался (ВПР в моем случае берет первое значение из поиска и его вставляет везде где подходит артикул) надо чтоб 1 артикул = 1 значению, и не дублировался в результате, не смотря на то что артикулы повторяются.

Автор - russiapwnz
Дата добавления - 16.05.2022 в 15:08
Nic70y Дата: Понедельник, 16.05.2022, 15:16 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7646
Репутация: 1827 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(D2<>D1;ВПР(D2;A:B;2;);ВПР(D2;ИНДЕКС(A:B;ПОИСКПОЗ(C1;B:B;)+1;):B$9999;2;))
возможно


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 16.05.2022, 15:21
 
Ответить
Сообщение
Код
=ЕСЛИ(D2<>D1;ВПР(D2;A:B;2;);ВПР(D2;ИНДЕКС(A:B;ПОИСКПОЗ(C1;B:B;)+1;):B$9999;2;))
возможно

Автор - Nic70y
Дата добавления - 16.05.2022 в 15:16
russiapwnz Дата: Понедельник, 16.05.2022, 15:19 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Nic70y за попытку спасибо, но не совсем, если протянуть формулу чуть ниже то на артикуле 1051091 она спотыкается и дает 3 раза одинаковое значение в виде заказа № 251947310, а должна брать поочереди заказы по артикулу 1051091 т.е. 250956709 \ 258842252 \ 251947310 (их всего 3 получается по данному артикулу)
 
Ответить
СообщениеNic70y за попытку спасибо, но не совсем, если протянуть формулу чуть ниже то на артикуле 1051091 она спотыкается и дает 3 раза одинаковое значение в виде заказа № 251947310, а должна брать поочереди заказы по артикулу 1051091 т.е. 250956709 \ 258842252 \ 251947310 (их всего 3 получается по данному артикулу)

Автор - russiapwnz
Дата добавления - 16.05.2022 в 15:19
Nic70y Дата: Понедельник, 16.05.2022, 15:22 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7646
Репутация: 1827 ±
Замечаний: 0% ±

Excel 2010
russiapwnz, да я уже заметил, исправил формулу.
файл здесь:
К сообщению приложен файл: 22-1-.xlsx(81.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеrussiapwnz, да я уже заметил, исправил формулу.
файл здесь:

Автор - Nic70y
Дата добавления - 16.05.2022 в 15:22
китин Дата: Понедельник, 16.05.2022, 15:23 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 6875
Репутация: 1055 ±
Замечаний: 0% ±

Excel 2007;2010;2016
как понял
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$1418;НАИМЕНЬШИЙ(ЕСЛИ($D2=$A$2:$A$1418;СТРОКА($A$2:$A$1418)-1);СЧЁТЕСЛИ($D$2:D2;D2)));0)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 9698236.xlsx(77.5 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениекак понял
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$1418;НАИМЕНЬШИЙ(ЕСЛИ($D2=$A$2:$A$1418;СТРОКА($A$2:$A$1418)-1);СЧЁТЕСЛИ($D$2:D2;D2)));0)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 16.05.2022 в 15:23
russiapwnz Дата: Понедельник, 16.05.2022, 15:29 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Да, это оно. Nic70y Большое спасибо!
Правда не совсем понятно как это Вы сделали, и как это на другую таблицу с подобной проблемой это перенести, но буду пробовать. Главное это возможно вообще :D yes
 
Ответить
СообщениеДа, это оно. Nic70y Большое спасибо!
Правда не совсем понятно как это Вы сделали, и как это на другую таблицу с подобной проблемой это перенести, но буду пробовать. Главное это возможно вообще :D yes

Автор - russiapwnz
Дата добавления - 16.05.2022 в 15:29
russiapwnz Дата: Понедельник, 16.05.2022, 15:32 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

китин тоже получилось...
Боже вы гении ребят, спасибо большое)
 
Ответить
Сообщениекитин тоже получилось...
Боже вы гении ребят, спасибо большое)

Автор - russiapwnz
Дата добавления - 16.05.2022 в 15:32
vopros799 Дата: Пятница, 27.05.2022, 13:42 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Ребята,подскажите как сделать так,чтобы к искому значению,они повторяются,всегда подтягивались значения из массива.
У меня к искомому значению подтягиваются данные из массива только единожды.А если же наименование написано несколько раз,то в остальных случаях стоит Н/Д.
Пример во вложении.Нужно чтобы к названию подятгивался адрес из массива,даже если это название повторяется несколько раз.
Вроде понятно обьяснила))
Подскажите пожалуйста.
К сообщению приложен файл: 9459805.xlsx(11.0 Kb)
 
Ответить
СообщениеРебята,подскажите как сделать так,чтобы к искому значению,они повторяются,всегда подтягивались значения из массива.
У меня к искомому значению подтягиваются данные из массива только единожды.А если же наименование написано несколько раз,то в остальных случаях стоит Н/Д.
Пример во вложении.Нужно чтобы к названию подятгивался адрес из массива,даже если это название повторяется несколько раз.
Вроде понятно обьяснила))
Подскажите пожалуйста.

Автор - vopros799
Дата добавления - 27.05.2022 в 13:42
Egyptian Дата: Пятница, 27.05.2022, 14:04 | Сообщение № 11
Группа: Проверенные
Ранг: Обитатель
Сообщений: 372
Репутация: 126 ±
Замечаний: 0% ±

Excel 2013/2016
vopros799, Закрепите диапазон баксами)
Код
$I$4:$J$7
 
Ответить
Сообщениеvopros799, Закрепите диапазон баксами)
Код
$I$4:$J$7

Автор - Egyptian
Дата добавления - 27.05.2022 в 14:04
vopros799 Дата: Суббота, 28.05.2022, 08:07 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, спасибо,все получилось
 
Ответить
СообщениеEgyptian, спасибо,все получилось

Автор - vopros799
Дата добавления - 28.05.2022 в 08:07
russiapwnz Дата: Четверг, 09.06.2022, 10:18 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте, уважаемые.
Буквально вчера наступил день "X" когда данная форумал потребовалась в бою, я был очень удивлен когда сам видел своими глазами что они работали а теперь нет.
Конечно массив изменился до 18-19 000 строк.
1. Случай
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$1418;НАИМЕНЬШИЙ(ЕСЛИ($D1=$A$2:$A$21418;СТРОКА($A$2:$A$21418)-1);СЧЁТЕСЛИ($D1:D$2;D1)));0)

Выдает очень много нулей почти в каждой 2 строке.
2. Случай
Код
=ЕСЛИ(D2<>D1;ВПР(D2;A:B;2;);ВПР(D2;ИНДЕКС(A:B;ПОИСКПОЗ(C1;B:B;)+1;):B$19999;2;))

Срабатывает но дает очень много повторений с 18 000 срезается после сводной таблицы до 2000 строк.
Если кто-то может помочь - буду безгранично признателен.
К сообщению приложен файл: 3845493.xlsx(463.2 Kb)


Сообщение отредактировал russiapwnz - Четверг, 09.06.2022, 10:41
 
Ответить
СообщениеЗдравствуйте, уважаемые.
Буквально вчера наступил день "X" когда данная форумал потребовалась в бою, я был очень удивлен когда сам видел своими глазами что они работали а теперь нет.
Конечно массив изменился до 18-19 000 строк.
1. Случай
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$1418;НАИМЕНЬШИЙ(ЕСЛИ($D1=$A$2:$A$21418;СТРОКА($A$2:$A$21418)-1);СЧЁТЕСЛИ($D1:D$2;D1)));0)

Выдает очень много нулей почти в каждой 2 строке.
2. Случай
Код
=ЕСЛИ(D2<>D1;ВПР(D2;A:B;2;);ВПР(D2;ИНДЕКС(A:B;ПОИСКПОЗ(C1;B:B;)+1;):B$19999;2;))

Срабатывает но дает очень много повторений с 18 000 срезается после сводной таблицы до 2000 строк.
Если кто-то может помочь - буду безгранично признателен.

Автор - russiapwnz
Дата добавления - 09.06.2022 в 10:18
китин Дата: Четверг, 09.06.2022, 10:38 | Сообщение № 14
Группа: Модераторы
Ранг: Экселист
Сообщений: 6875
Репутация: 1055 ±
Замечаний: 0% ±

Excel 2007;2010;2016
russiapwnz, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеrussiapwnz, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 09.06.2022 в 10:38
russiapwnz Дата: Четверг, 09.06.2022, 10:42 | Сообщение № 15
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Исправлено
 
Ответить
СообщениеИсправлено

Автор - russiapwnz
Дата добавления - 09.06.2022 в 10:42
китин Дата: Четверг, 09.06.2022, 10:47 | Сообщение № 16
Группа: Модераторы
Ранг: Экселист
Сообщений: 6875
Репутация: 1055 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$21148;НАИМЕНЬШИЙ(ЕСЛИ($D1=$A$2:$A$21418;СТРОКА($A$2:$A$21418)-1);СЧЁТЕСЛИ($D$2:D2;D2)));0)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
сравните и найдите разницу


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$21148;НАИМЕНЬШИЙ(ЕСЛИ($D1=$A$2:$A$21418;СТРОКА($A$2:$A$21418)-1);СЧЁТЕСЛИ($D$2:D2;D2)));0)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
сравните и найдите разницу

Автор - китин
Дата добавления - 09.06.2022 в 10:47
russiapwnz Дата: Четверг, 09.06.2022, 10:54 | Сообщение № 17
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

В этом случае везде пишется #ИМЯ? и так по всем строкам. Хотя раньше такого не замечалось.
Исправил, но низ документа весь в значениях "0"
Что-то работает не корректно =(


Сообщение отредактировал russiapwnz - Четверг, 09.06.2022, 11:00
 
Ответить
СообщениеВ этом случае везде пишется #ИМЯ? и так по всем строкам. Хотя раньше такого не замечалось.
Исправил, но низ документа весь в значениях "0"
Что-то работает не корректно =(

Автор - russiapwnz
Дата добавления - 09.06.2022 в 10:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР дублирующиеся данные (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!