Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/определить значение в зависимости от даты и объема - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » определить значение в зависимости от даты и объема (Формулы/Formulas)
определить значение в зависимости от даты и объема
Merkuriy Дата: Пятница, 20.05.2022, 15:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.
Помогите пожалуйста в следующем: есть значение затрат, которые зависят от даты действия и объема (лист1). Как сделать чтобы значение затрат автоматически вносилось в зависимости от даты и объема на лист 2. Для наглядности, что должно получаться, на листе 2 результат внесен в ручную. В ответах на форме по данному вопросу ничего не нашел.
Спасибо за помощь.
К сообщению приложен файл: 11111.xls(29.5 Kb)
 
Ответить
СообщениеЗдравствуйте.
Помогите пожалуйста в следующем: есть значение затрат, которые зависят от даты действия и объема (лист1). Как сделать чтобы значение затрат автоматически вносилось в зависимости от даты и объема на лист 2. Для наглядности, что должно получаться, на листе 2 результат внесен в ручную. В ответах на форме по данному вопросу ничего не нашел.
Спасибо за помощь.

Автор - Merkuriy
Дата добавления - 20.05.2022 в 15:28
_Boroda_ Дата: Пятница, 20.05.2022, 15:54 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16212
Репутация: 6296 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ИНДЕКС(Лист1!C$3:E$8;ПОИСКПОЗ(--B3;Лист1!B$3:B$6);ПОИСКПОЗ(C3;Лист1!B$3:E$3))

Чуть изменив шапку в исходнике
К сообщению приложен файл: 11111_1.xls(32.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ИНДЕКС(Лист1!C$3:E$8;ПОИСКПОЗ(--B3;Лист1!B$3:B$6);ПОИСКПОЗ(C3;Лист1!B$3:E$3))

Чуть изменив шапку в исходнике

Автор - _Boroda_
Дата добавления - 20.05.2022 в 15:54
Nic70y Дата: Пятница, 20.05.2022, 16:08 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 7567
Репутация: 1809 ±
Замечаний: 0% ±

Excel 2010
изменив шапку в исходнике
аналогично
Код
=ВПР(9E+307;ИНДЕКС(Лист1!C$4:E$8;1;ПОИСКПОЗ(C3;Лист1!C$3:E$3)):ИНДЕКС(Лист1!C$4:E$8;ЕСЛИОШИБКА(ПОИСКПОЗ(B3;Лист1!B$4:B$8);1);ПОИСКПОЗ(C3;Лист1!C$3:E$3));1)
К сообщению приложен файл: 28.xls(35.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
изменив шапку в исходнике
аналогично
Код
=ВПР(9E+307;ИНДЕКС(Лист1!C$4:E$8;1;ПОИСКПОЗ(C3;Лист1!C$3:E$3)):ИНДЕКС(Лист1!C$4:E$8;ЕСЛИОШИБКА(ПОИСКПОЗ(B3;Лист1!B$4:B$8);1);ПОИСКПОЗ(C3;Лист1!C$3:E$3));1)

Автор - Nic70y
Дата добавления - 20.05.2022 в 16:08
Merkuriy Дата: Пятница, 20.05.2022, 21:20 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y,
Спасибо огромное.
Переделал ее под себя - формула прекрасно работает.
Для саморазвития поясните пожалуйста начало формулы =...(9E+307
hands
 
Ответить
СообщениеNic70y,
Спасибо огромное.
Переделал ее под себя - формула прекрасно работает.
Для саморазвития поясните пожалуйста начало формулы =...(9E+307
hands

Автор - Merkuriy
Дата добавления - 20.05.2022 в 21:20
Merkuriy Дата: Пятница, 20.05.2022, 21:22 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_,
Спасибо за помощь.
В вашем ответе почему то для даты 01.05.2022 формула выдает значение 0. Почему - не смог разобраться.
:D
 
Ответить
Сообщение_Boroda_,
Спасибо за помощь.
В вашем ответе почему то для даты 01.05.2022 формула выдает значение 0. Почему - не смог разобраться.
:D

Автор - Merkuriy
Дата добавления - 20.05.2022 в 21:22
Merkuriy Дата: Пятница, 20.05.2022, 21:38 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_,
Написал вам что не смог разобраться, а потом осенило.
Для вашей формулы нужно всего навсего чтобы всегда вносились в дату все значения, как изменившиеся, так и те, которые не изменились, и тогда формула также прекрасно работает.
Спасибо!!!
hands
 
Ответить
Сообщение_Boroda_,
Написал вам что не смог разобраться, а потом осенило.
Для вашей формулы нужно всего навсего чтобы всегда вносились в дату все значения, как изменившиеся, так и те, которые не изменились, и тогда формула также прекрасно работает.
Спасибо!!!
hands

Автор - Merkuriy
Дата добавления - 20.05.2022 в 21:38
Nic70y Дата: Суббота, 21.05.2022, 07:40 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 7567
Репутация: 1809 ±
Замечаний: 0% ±

Excel 2010
9E+307
это очень большое число, при "неточном" поиске найдется число в крайней заполненной ячейки, т.е.
вносились в дату все значения
не требуется


ЮMoney 41001841029809
 
Ответить
Сообщение
9E+307
это очень большое число, при "неточном" поиске найдется число в крайней заполненной ячейки, т.е.
вносились в дату все значения
не требуется

Автор - Nic70y
Дата добавления - 21.05.2022 в 07:40
Merkuriy Дата: Воскресенье, 22.05.2022, 09:43 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y,
Спасибо
 
Ответить
СообщениеNic70y,
Спасибо

Автор - Merkuriy
Дата добавления - 22.05.2022 в 09:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » определить значение в зависимости от даты и объема (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!