Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложный подсчёт интервалов между повторяющимися значениями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложный подсчёт интервалов между повторяющимися значениями (Формулы/Formulas)
Сложный подсчёт интервалов между повторяющимися значениями
emmett_brown Дата: Среда, 25.05.2022, 18:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Необходимо в столбце подсчитать количество ячеек между повторяющимися значениями в столбце B, в данном случае это значение 0, как в столбце С только автоматически, но при условии что считаются только первые 1,2,3 до того момента пока следующим, за 1,2или 3 числом не будет 1, тогда интервал начинает считаться заново, и если значение в столбце B будет 1 то счет останавливается на предыдущем значении до тех пор пока не будет 0-когда счет пойдёт по новой или другого значения когда счет продолжится до нужного, если его не будет тогда счет продолжается, соответственно следующие 1,2 или три будут по счету будут 4,5,6 и т.д., Объяснил криво но надеюсь, на снисходительность и помощь .Помогите, пожалуйста, заранее спасибо.
К сообщению приложен файл: 9877653.xlsx(10.1 Kb)


Rock'N'Roll
 
Ответить
СообщениеНеобходимо в столбце подсчитать количество ячеек между повторяющимися значениями в столбце B, в данном случае это значение 0, как в столбце С только автоматически, но при условии что считаются только первые 1,2,3 до того момента пока следующим, за 1,2или 3 числом не будет 1, тогда интервал начинает считаться заново, и если значение в столбце B будет 1 то счет останавливается на предыдущем значении до тех пор пока не будет 0-когда счет пойдёт по новой или другого значения когда счет продолжится до нужного, если его не будет тогда счет продолжается, соответственно следующие 1,2 или три будут по счету будут 4,5,6 и т.д., Объяснил криво но надеюсь, на снисходительность и помощь .Помогите, пожалуйста, заранее спасибо.

Автор - emmett_brown
Дата добавления - 25.05.2022 в 18:14
msi2102 Дата: Среда, 25.05.2022, 19:09 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 89 ±
Замечаний: 0% ±

Excel 2007
Как понял. Попробуйте так
Код
=ЕСЛИ(B2=0;C2;ЕСЛИ(B1=1;E1;ЕСЛИ(B1=0;1;E1+1)))

только в диапазоне с 18 по 20 и с 26 по 29 строку несовпадение
К сообщению приложен файл: 5337801.xlsx(10.9 Kb)


Сообщение отредактировал msi2102 - Среда, 25.05.2022, 19:10
 
Ответить
СообщениеКак понял. Попробуйте так
Код
=ЕСЛИ(B2=0;C2;ЕСЛИ(B1=1;E1;ЕСЛИ(B1=0;1;E1+1)))

только в диапазоне с 18 по 20 и с 26 по 29 строку несовпадение

Автор - msi2102
Дата добавления - 25.05.2022 в 19:09
emmett_brown Дата: Пятница, 27.05.2022, 12:46 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
только в диапазоне с 18 по 20 и с 26 по 29 строку несовпадение
-спасибо большое, исправил

Как понял. Попробуйте так
[Перевод / Translate]
=ЕСЛИ(B2=0;C2;ЕСЛИ(B1=1;E1;ЕСЛИ(B1=0;1;E1+1)))
-не подходит, но это моя вина т.к. я не очень описал условия задачи, попробую еще раз понятнее -


Необходимо в столбце B подсчитать количество значений между повторяющимися "0" в столбце A, но при условии, если значение в столбце А будет 1 то счет останавливается на предыдущем значении, для следующего числа счета.
К сообщению приложен файл: 2933235.xlsx(9.5 Kb)


Rock'N'Roll
 
Ответить
Сообщение
только в диапазоне с 18 по 20 и с 26 по 29 строку несовпадение
-спасибо большое, исправил

Как понял. Попробуйте так
[Перевод / Translate]
=ЕСЛИ(B2=0;C2;ЕСЛИ(B1=1;E1;ЕСЛИ(B1=0;1;E1+1)))
-не подходит, но это моя вина т.к. я не очень описал условия задачи, попробую еще раз понятнее -


Необходимо в столбце B подсчитать количество значений между повторяющимися "0" в столбце A, но при условии, если значение в столбце А будет 1 то счет останавливается на предыдущем значении, для следующего числа счета.

Автор - emmett_brown
Дата добавления - 27.05.2022 в 12:46
Nic70y Дата: Пятница, 27.05.2022, 13:14 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7867
Репутация: 1892 ±
Замечаний: 0% ±

Excel 2010
с B3
Код
=ЕСЛИ(И(A3<>0;A2=1);B2;ЕСЛИ(A2=0;1;B2+1))
К сообщению приложен файл: 27.xlsx(11.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениес B3
Код
=ЕСЛИ(И(A3<>0;A2=1);B2;ЕСЛИ(A2=0;1;B2+1))

Автор - Nic70y
Дата добавления - 27.05.2022 в 13:14
emmett_brown Дата: Пятница, 27.05.2022, 18:06 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Nic70y, Спасибо большое все так


Rock'N'Roll
 
Ответить
СообщениеNic70y, Спасибо большое все так

Автор - emmett_brown
Дата добавления - 27.05.2022 в 18:06
emmett_brown Дата: Пятница, 27.05.2022, 19:07 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Nic70y, а подскажите пожалуйста как подкорректировать счет интервалов в столбцах B и C с учетом значений в столбце А, что бы они соотносились
К сообщению приложен файл: 2470829.xlsx(28.8 Kb)


Rock'N'Roll
 
Ответить
СообщениеNic70y, а подскажите пожалуйста как подкорректировать счет интервалов в столбцах B и C с учетом значений в столбце А, что бы они соотносились

Автор - emmett_brown
Дата добавления - 27.05.2022 в 19:07
Nic70y Дата: Суббота, 28.05.2022, 08:53 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 7867
Репутация: 1892 ±
Замечаний: 0% ±

Excel 2010
emmett_brown, не понял ваш вопрос


ЮMoney 41001841029809
 
Ответить
Сообщениеemmett_brown, не понял ваш вопрос

Автор - Nic70y
Дата добавления - 28.05.2022 в 08:53
emmett_brown Дата: Суббота, 28.05.2022, 13:20 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
emmett_brown, не понял ваш вопрос
Видимо я его криво задал, за что прошу прощения, бывает сложно сформулировать мысль в малознакомой и достаточно сложной для себя сфере, поэтому надеюсь на ваше снисхождение. Я имел ввиду как в столбцах B и C сделать так что бы значения были как в столбце А, как точнее объяснить не знаю, поэтому лучше визуализирую в прикрепленном файле желаемые результаты, в графе как нужно.
К сообщению приложен файл: 0950358.xlsx(26.9 Kb)


Rock'N'Roll

Сообщение отредактировал emmett_brown - Суббота, 28.05.2022, 13:20
 
Ответить
Сообщение
emmett_brown, не понял ваш вопрос
Видимо я его криво задал, за что прошу прощения, бывает сложно сформулировать мысль в малознакомой и достаточно сложной для себя сфере, поэтому надеюсь на ваше снисхождение. Я имел ввиду как в столбцах B и C сделать так что бы значения были как в столбце А, как точнее объяснить не знаю, поэтому лучше визуализирую в прикрепленном файле желаемые результаты, в графе как нужно.

Автор - emmett_brown
Дата добавления - 28.05.2022 в 13:20
Nic70y Дата: Понедельник, 30.05.2022, 17:21 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 7867
Репутация: 1892 ±
Замечаний: 0% ±

Excel 2010
я так и не понял алгоритма
К сообщению приложен файл: 2415290.xlsx(28.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениея так и не понял алгоритма

Автор - Nic70y
Дата добавления - 30.05.2022 в 17:21
emmett_brown Дата: Вторник, 14.06.2022, 18:30 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Nic70y, Необходимо в столбцах С,D подсчитать интервал между повторяющимися значениями в столбце B, как в столбце E,F только автоматически, но при условии что считаются только первые 10 по значению, а не по количеству ячеек, до того момента пока следующим, числом не будет 1, тогда интервал начинает считаться заново, если его не будет, когда значение в столбце B достигнет 10, тогда счет продолжается, следующие 1,2,3,4... будут по счету будут 11,12,13,14...20 и т.д.
К сообщению приложен файл: 0950358-1-.xlsx(26.9 Kb)


Rock'N'Roll
 
Ответить
СообщениеNic70y, Необходимо в столбцах С,D подсчитать интервал между повторяющимися значениями в столбце B, как в столбце E,F только автоматически, но при условии что считаются только первые 10 по значению, а не по количеству ячеек, до того момента пока следующим, числом не будет 1, тогда интервал начинает считаться заново, если его не будет, когда значение в столбце B достигнет 10, тогда счет продолжается, следующие 1,2,3,4... будут по счету будут 11,12,13,14...20 и т.д.

Автор - emmett_brown
Дата добавления - 14.06.2022 в 18:30
msi2102 Дата: Среда, 15.06.2022, 09:11 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 89 ±
Замечаний: 0% ±

Excel 2007
emmett_brown, Вы определитесь, что именно Вы хотите. Попробуйте так
Код
=ЕСЛИ(B2>10;"";ЕСЛИ(И(B2=1;G1="");11;ЕСЛИ(И(B2=1;G1<>"");1;ЕСЛИ(B2=B1;G1;G1+1))))
К сообщению приложен файл: 1865818.xlsx(34.4 Kb)
 
Ответить
Сообщениеemmett_brown, Вы определитесь, что именно Вы хотите. Попробуйте так
Код
=ЕСЛИ(B2>10;"";ЕСЛИ(И(B2=1;G1="");11;ЕСЛИ(И(B2=1;G1<>"");1;ЕСЛИ(B2=B1;G1;G1+1))))

Автор - msi2102
Дата добавления - 15.06.2022 в 09:11
emmett_brown Дата: Среда, 15.06.2022, 13:38 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
msi2102, Спасибо огромное это именно то что нужно и то что я хотел)) только еще один момент, как сделать так что бы показывались только итоговые результаты подсчета как в столбце Е?
К сообщению приложен файл: 1451674.xlsx(34.4 Kb)


Rock'N'Roll
 
Ответить
Сообщениеmsi2102, Спасибо огромное это именно то что нужно и то что я хотел)) только еще один момент, как сделать так что бы показывались только итоговые результаты подсчета как в столбце Е?

Автор - emmett_brown
Дата добавления - 15.06.2022 в 13:38
msi2102 Дата: Среда, 15.06.2022, 14:27 | Сообщение № 13
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 89 ±
Замечаний: 0% ±

Excel 2007
как сделать так что бы показывались только итоговые результаты подсчета как в столбце Е
В соседний столбец формулу:
Код
=ЕСЛИ(G3=1;G2;"")

А столбец с расчетом скрыть
PS: Так будет покороче
Код
=ЕСЛИ(B2=B1;B2;ЕСЛИ(B2=1;ЕСЛИ(B1>10;11;1);ЕСЛИ(B2>10;"";G1+1)))
К сообщению приложен файл: 4472504.xlsx(31.1 Kb)
 
Ответить
Сообщение
как сделать так что бы показывались только итоговые результаты подсчета как в столбце Е
В соседний столбец формулу:
Код
=ЕСЛИ(G3=1;G2;"")

А столбец с расчетом скрыть
PS: Так будет покороче
Код
=ЕСЛИ(B2=B1;B2;ЕСЛИ(B2=1;ЕСЛИ(B1>10;11;1);ЕСЛИ(B2>10;"";G1+1)))

Автор - msi2102
Дата добавления - 15.06.2022 в 14:27
emmett_brown Дата: Четверг, 16.06.2022, 17:41 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
msi2102, Спасибо большое все так


Rock'N'Roll
 
Ответить
Сообщениеmsi2102, Спасибо большое все так

Автор - emmett_brown
Дата добавления - 16.06.2022 в 17:41
emmett_brown Дата: Суббота, 18.06.2022, 10:37 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
msi2102, но есть проблема если заменить значения в ячейке В то она считает не корректно в ряде случаев
К сообщению приложен файл: 4472504-1-.xlsx(31.9 Kb)


Rock'N'Roll

Сообщение отредактировал emmett_brown - Суббота, 18.06.2022, 19:39
 
Ответить
Сообщениеmsi2102, но есть проблема если заменить значения в ячейке В то она считает не корректно в ряде случаев

Автор - emmett_brown
Дата добавления - 18.06.2022 в 10:37
emmett_brown Дата: Понедельник, 04.07.2022, 18:35 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Помогите пожалуйста с решением проблемы, допилить формулу для корректного подсчета интервалов в ячейке E, в ячейке D показано как нужно что бы считало, красным выделены ошибки подсчета.
К сообщению приложен файл: 4472504-1-3-.xlsx(22.7 Kb)


Rock'N'Roll
 
Ответить
СообщениеПомогите пожалуйста с решением проблемы, допилить формулу для корректного подсчета интервалов в ячейке E, в ячейке D показано как нужно что бы считало, красным выделены ошибки подсчета.

Автор - emmett_brown
Дата добавления - 04.07.2022 в 18:35
msi2102 Дата: Вторник, 05.07.2022, 08:35 | Сообщение № 17
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 89 ±
Замечаний: 0% ±

Excel 2007
Попробуйте так
Код
=ЕСЛИ(И(B2=B1;B2<>1);G1;ЕСЛИ(B2=1;ЕСЛИ(B1>10;ИНДЕКС($G1:G$2;ПОИСКПОЗ(1E+306;$G1:G$2;1))+1;1);ЕСЛИ(B2>10;"";G1+1)))
К сообщению приложен файл: 2774330.xlsx(27.7 Kb)
 
Ответить
СообщениеПопробуйте так
Код
=ЕСЛИ(И(B2=B1;B2<>1);G1;ЕСЛИ(B2=1;ЕСЛИ(B1>10;ИНДЕКС($G1:G$2;ПОИСКПОЗ(1E+306;$G1:G$2;1))+1;1);ЕСЛИ(B2>10;"";G1+1)))

Автор - msi2102
Дата добавления - 05.07.2022 в 08:35
emmett_brown Дата: Вторник, 05.07.2022, 18:47 | Сообщение № 18
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
msi2102, Спасибо большое Вы настоящий кудесник таблиц, всё именно так как нужно)


Rock'N'Roll
 
Ответить
Сообщениеmsi2102, Спасибо большое Вы настоящий кудесник таблиц, всё именно так как нужно)

Автор - emmett_brown
Дата добавления - 05.07.2022 в 18:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложный подсчёт интервалов между повторяющимися значениями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!