Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для сбора значений по данному месяцу - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для сбора значений по данному месяцу (Формулы/Formulas)
Формула для сбора значений по данному месяцу
remis8423 Дата: Вторник, 31.05.2022, 10:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Нужна формула для выбора суммы значений при указанном месяце из нескольких вкладок.
Расчетная - сумма значений из разных вкладок. Факт - из одной вкладки (для сравнения).
Пример выкладываю.
К сообщению приложен файл: 0751410.xlsx(13.9 Kb)
 
Ответить
СообщениеДобрый день!
Нужна формула для выбора суммы значений при указанном месяце из нескольких вкладок.
Расчетная - сумма значений из разных вкладок. Факт - из одной вкладки (для сравнения).
Пример выкладываю.

Автор - remis8423
Дата добавления - 31.05.2022 в 10:44
_Boroda_ Дата: Вторник, 31.05.2022, 11:29 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16510
Репутация: 6425 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не динамический вариант
Код
=СУММПРОИЗВ(СУММЕСЛИ(ДВССЫЛ("'"&СТРОКА(1:3)&"'!B10:M10");C5;ДВССЫЛ("'"&СТРОКА(1:3)&"'!B18:M18")))

Код
=ИНДЕКС('Общая факт'!B18:M18;МЕСЯЦ(C5&-1))
К сообщению приложен файл: 0751410_1.xlsx(13.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе динамический вариант
Код
=СУММПРОИЗВ(СУММЕСЛИ(ДВССЫЛ("'"&СТРОКА(1:3)&"'!B10:M10");C5;ДВССЫЛ("'"&СТРОКА(1:3)&"'!B18:M18")))

Код
=ИНДЕКС('Общая факт'!B18:M18;МЕСЯЦ(C5&-1))

Автор - _Boroda_
Дата добавления - 31.05.2022 в 11:29
msi2102 Дата: Вторник, 31.05.2022, 11:38 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 247
Репутация: 90 ±
Замечаний: 0% ±

Excel 2007
Может так
Код
=ГПР(C5;'1'!B10:M18;ПОИСКПОЗ("Итого*";'1'!A:A;0)-9;0)+ГПР(C5;'2'!B10:M18;ПОИСКПОЗ("Итого*";'2'!A:A;0)-9;0)+ГПР(C5;'3'!B10:M18;ПОИСКПОЗ("Итого*";'3'!A:A;0)-9;0)
К сообщению приложен файл: 9696927.xlsx(14.0 Kb)


Сообщение отредактировал msi2102 - Вторник, 31.05.2022, 11:50
 
Ответить
СообщениеМожет так
Код
=ГПР(C5;'1'!B10:M18;ПОИСКПОЗ("Итого*";'1'!A:A;0)-9;0)+ГПР(C5;'2'!B10:M18;ПОИСКПОЗ("Итого*";'2'!A:A;0)-9;0)+ГПР(C5;'3'!B10:M18;ПОИСКПОЗ("Итого*";'3'!A:A;0)-9;0)

Автор - msi2102
Дата добавления - 31.05.2022 в 11:38
_Boroda_ Дата: Вторник, 31.05.2022, 11:41 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16510
Репутация: 6425 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Сергей, листы не все переименовал, всё в первом ищешь


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСергей, листы не все переименовал, всё в первом ищешь

Автор - _Boroda_
Дата добавления - 31.05.2022 в 11:41
remis8423 Дата: Вторник, 31.05.2022, 11:46 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, не подскажете, что означает СТРОКА(1:3)?
 
Ответить
Сообщение_Boroda_, не подскажете, что означает СТРОКА(1:3)?

Автор - remis8423
Дата добавления - 31.05.2022 в 11:46
msi2102 Дата: Вторник, 31.05.2022, 11:50 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 247
Репутация: 90 ±
Замечаний: 0% ±

Excel 2007
Сергей, листы не все переименовал, всё в первом ищешь
Спасибо поправил
 
Ответить
Сообщение
Сергей, листы не все переименовал, всё в первом ищешь
Спасибо поправил

Автор - msi2102
Дата добавления - 31.05.2022 в 11:50
_Boroda_ Дата: Вторник, 31.05.2022, 12:00 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16510
Репутация: 6425 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
СТРОКА(1:3) - это номера строк с первой по третью - массив 1:2:3. Так у Вас листы называются


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСТРОКА(1:3) - это номера строк с первой по третью - массив 1:2:3. Так у Вас листы называются

Автор - _Boroda_
Дата добавления - 31.05.2022 в 12:00
remis8423 Дата: Вторник, 31.05.2022, 12:31 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, если цеха с номерами 50, 60, 70, 71 - то как лучше сделать?
 
Ответить
Сообщение_Boroda_, если цеха с номерами 50, 60, 70, 71 - то как лучше сделать?

Автор - remis8423
Дата добавления - 31.05.2022 в 12:31
_Boroda_ Дата: Вторник, 31.05.2022, 13:00 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16510
Репутация: 6425 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так можно
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(СУММЕСЛИ(ДВССЫЛ("'"&СТРОКА(1:99)&"'!B10:M10");C5;ДВССЫЛ("'"&СТРОКА(1:99)&"'!B18:M18"));))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак можно
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(СУММЕСЛИ(ДВССЫЛ("'"&СТРОКА(1:99)&"'!B10:M10");C5;ДВССЫЛ("'"&СТРОКА(1:99)&"'!B18:M18"));))

Автор - _Boroda_
Дата добавления - 31.05.2022 в 13:00
remis8423 Дата: Вторник, 31.05.2022, 13:18 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, Спасибо!
 
Ответить
Сообщение_Boroda_, Спасибо!

Автор - remis8423
Дата добавления - 31.05.2022 в 13:18
remis8423 Дата: Вторник, 31.05.2022, 13:22 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, Еще такой вопрос. В случае, если в названии вкладок есть текст, к примеру, плата 5, плата 6 и т.д. - в этом уже по другому нужно делать?
 
Ответить
Сообщение_Boroda_, Еще такой вопрос. В случае, если в названии вкладок есть текст, к примеру, плата 5, плата 6 и т.д. - в этом уже по другому нужно делать?

Автор - remis8423
Дата добавления - 31.05.2022 в 13:22
_Boroda_ Дата: Вторник, 31.05.2022, 13:54 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16510
Репутация: 6425 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
в этом уже по другому нужно делать?
Ага. И начать следует с примера :D :D


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
в этом уже по другому нужно делать?
Ага. И начать следует с примера :D :D

Автор - _Boroda_
Дата добавления - 31.05.2022 в 13:54
remis8423 Дата: Вторник, 31.05.2022, 14:02 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, скинул пример
К сообщению приложен файл: 4651226.xlsx(14.5 Kb)
 
Ответить
Сообщение_Boroda_, скинул пример

Автор - remis8423
Дата добавления - 31.05.2022 в 14:02
Egyptian Дата: Вторник, 31.05.2022, 21:12 | Сообщение № 14
Группа: Проверенные
Ранг: Обитатель
Сообщений: 425
Репутация: 140 ±
Замечаний: 0% ±

Excel 2013/2016
remis8423, Если имена продолжаются в указанной в примере последовательности, то просто добавить имя.
Код
INDIRECT("'"&"плата "&ROW(1:3)&"'!B10:M10")

и
Код
INDIRECT("'"&"плата "&ROW(1:3)&"'!B18:M18")
 
Ответить
Сообщениеremis8423, Если имена продолжаются в указанной в примере последовательности, то просто добавить имя.
Код
INDIRECT("'"&"плата "&ROW(1:3)&"'!B10:M10")

и
Код
INDIRECT("'"&"плата "&ROW(1:3)&"'!B18:M18")

Автор - Egyptian
Дата добавления - 31.05.2022 в 21:12
remis8423 Дата: Среда, 01.06.2022, 08:03 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, а здесь по указанному месяцу не считает?
 
Ответить
СообщениеEgyptian, а здесь по указанному месяцу не считает?

Автор - remis8423
Дата добавления - 01.06.2022 в 08:03
Egyptian Дата: Среда, 01.06.2022, 09:42 | Сообщение № 16
Группа: Проверенные
Ранг: Обитатель
Сообщений: 425
Репутация: 140 ±
Замечаний: 0% ±

Excel 2013/2016
remis8423,
В смысле не считает? Я вам привел лишь те блоки из формулы Бороды, которые нужно дополнить именами)
К сообщению приложен файл: 2601591.xlsx(13.6 Kb)
 
Ответить
Сообщениеremis8423,
В смысле не считает? Я вам привел лишь те блоки из формулы Бороды, которые нужно дополнить именами)

Автор - Egyptian
Дата добавления - 01.06.2022 в 09:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для сбора значений по данному месяцу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!