Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Оптимизация формул в таблице - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Оптимизация формул в таблице (Формулы/Formulas)
Оптимизация формул в таблице
donskikhmaksim Дата: Воскресенье, 12.06.2022, 04:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, есть вот такая вот табличка с данными кассовых смен. Необходимо оптимизировать формулы, которые проверяет есть ли данные в ячейках и исходя из этого суммируют данные. Есть формулы типа СУММЕСЛИ, не могу сообразить как правильно применить. Мой вариант работает, но он слишком громоздкий и когда нужно отредактировать формулу по какой-то причине (например, при добавлении новых строк), то работать с такой портянкой не очень удобно.
К сообщению приложен файл: __Mood.xlsx(16.7 Kb)
 
Ответить
СообщениеДобрый день, есть вот такая вот табличка с данными кассовых смен. Необходимо оптимизировать формулы, которые проверяет есть ли данные в ячейках и исходя из этого суммируют данные. Есть формулы типа СУММЕСЛИ, не могу сообразить как правильно применить. Мой вариант работает, но он слишком громоздкий и когда нужно отредактировать формулу по какой-то причине (например, при добавлении новых строк), то работать с такой портянкой не очень удобно.

Автор - donskikhmaksim
Дата добавления - 12.06.2022 в 04:30
DrMini Дата: Воскресенье, 12.06.2022, 20:04 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 791
Репутация: 46 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Цитата donskikhmaksim, 12.06.2022 в 04:30, в сообщении № 1 ()
слишком громоздкий

Может так подойдёт?
Код
=ЕСЛИ(И(C18:C26<>"";C31:C41<>"";C46:C47<>"";C51:C56<>"");СУММ(C9;C12;C15;C19:C22);"")
 
Ответить
Сообщение
Цитата donskikhmaksim, 12.06.2022 в 04:30, в сообщении № 1 ()
слишком громоздкий

Может так подойдёт?
Код
=ЕСЛИ(И(C18:C26<>"";C31:C41<>"";C46:C47<>"";C51:C56<>"");СУММ(C9;C12;C15;C19:C22);"")

Автор - DrMini
Дата добавления - 12.06.2022 в 20:04
donskikhmaksim Дата: Вторник, 14.06.2022, 17:35 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Цитата
Может так подойдёт?


Да, так получше, спасибо.

Но я думал, что можно сделать это через формулу «СУММЕСЛИ» или «СУММЕСЛИМН», но не могу сообразить как.
 
Ответить
Сообщение
Цитата
Может так подойдёт?


Да, так получше, спасибо.

Но я думал, что можно сделать это через формулу «СУММЕСЛИ» или «СУММЕСЛИМН», но не могу сообразить как.

Автор - donskikhmaksim
Дата добавления - 14.06.2022 в 17:35
donskikhmaksim Дата: Вторник, 14.06.2022, 18:08 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Цитата
=ЕСЛИ(И(C18:C26<>"";C31:C41<>"";C46:C47<>"";C51:C56<>"");СУММ(C9;C12;C15;C19:C22);"")


Так и не работает, впрочем.
 
Ответить
Сообщение
Цитата
=ЕСЛИ(И(C18:C26<>"";C31:C41<>"";C46:C47<>"";C51:C56<>"");СУММ(C9;C12;C15;C19:C22);"")


Так и не работает, впрочем.

Автор - donskikhmaksim
Дата добавления - 14.06.2022 в 18:08
scriptapplications Дата: Среда, 15.06.2022, 05:47 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 4 ±
Замечаний: 0% ±

donskikhmaksim, попробуйте так формулой массива через Ctrl+Shift+Enter
Для ячейки C42
Код
=ЕСЛИ(СУММ((C34:C41<>"")*C34:C41)=0;"";СУММ(C34:C41))

Или так
Код
ЕСЛИ(СУММПРОИЗВ(--(C34:C41<>"");C34:C41)=0;"";СУММ(C34:C41)


Сообщение отредактировал scriptapplications - Среда, 15.06.2022, 09:05
 
Ответить
Сообщениеdonskikhmaksim, попробуйте так формулой массива через Ctrl+Shift+Enter
Для ячейки C42
Код
=ЕСЛИ(СУММ((C34:C41<>"")*C34:C41)=0;"";СУММ(C34:C41))

Или так
Код
ЕСЛИ(СУММПРОИЗВ(--(C34:C41<>"");C34:C41)=0;"";СУММ(C34:C41)

Автор - scriptapplications
Дата добавления - 15.06.2022 в 05:47
DrMini Дата: Среда, 15.06.2022, 08:16 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 791
Репутация: 46 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Цитата donskikhmaksim, 14.06.2022 в 18:08, в сообщении № 4 ()
не работает

Почему же не работает? Работает.
Это для ячейки С6 и протянуть вправо.
Для других ячеек не делал.
К сообщению приложен файл: _Mood-1.xlsx(24.3 Kb)
 
Ответить
Сообщение
Цитата donskikhmaksim, 14.06.2022 в 18:08, в сообщении № 4 ()
не работает

Почему же не работает? Работает.
Это для ячейки С6 и протянуть вправо.
Для других ячеек не делал.

Автор - DrMini
Дата добавления - 15.06.2022 в 08:16
bigor Дата: Среда, 15.06.2022, 09:27 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 625
Репутация: 123 ±
Замечаний: 0% ±

нет
Цитата donskikhmaksim, 14.06.2022 в 18:08, в сообщении № 4 ()
Так и не работает, впрочем.
работает. Она массивная вводится тремя кнопками Ctrl+Shift+Enter
Цитата donskikhmaksim, 14.06.2022 в 17:35, в сообщении № 3 ()
можно сделать это через формулу «СУММЕСЛИ» или «СУММЕСЛИМН»
с Вашей таблицей вряд ли. А для чего вообще проверка на пустые ячейки?
 
Ответить
Сообщение
Цитата donskikhmaksim, 14.06.2022 в 18:08, в сообщении № 4 ()
Так и не работает, впрочем.
работает. Она массивная вводится тремя кнопками Ctrl+Shift+Enter
Цитата donskikhmaksim, 14.06.2022 в 17:35, в сообщении № 3 ()
можно сделать это через формулу «СУММЕСЛИ» или «СУММЕСЛИМН»
с Вашей таблицей вряд ли. А для чего вообще проверка на пустые ячейки?

Автор - bigor
Дата добавления - 15.06.2022 в 09:27
donskikhmaksim Дата: Среда, 15.06.2022, 11:52 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

DrMini, ,

Цитата
с Вашей таблицей вряд ли. А для чего вообще проверка на пустые ячейки?


Чтобы заполняли все. Иногда пропускают ячейки.
Также можно что-то проставить на будущие даты и не будет кучи ненужных знаков в будущих периодах.
 
Ответить
СообщениеDrMini, ,

Цитата
с Вашей таблицей вряд ли. А для чего вообще проверка на пустые ячейки?


Чтобы заполняли все. Иногда пропускают ячейки.
Также можно что-то проставить на будущие даты и не будет кучи ненужных знаков в будущих периодах.

Автор - donskikhmaksim
Дата добавления - 15.06.2022 в 11:52
Nic70y Дата: Среда, 15.06.2022, 12:27 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 7567
Репутация: 1809 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(ИЛИ(СЧИТАТЬПУСТОТЫ(D18:D26);СЧИТАТЬПУСТОТЫ(D31:D41);СЧИТАТЬПУСТОТЫ(D46:D47);СЧИТАТЬПУСТОТЫ(D51:D56));"";СУММ(D9;D12;D15;D19:D22))


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(ИЛИ(СЧИТАТЬПУСТОТЫ(D18:D26);СЧИТАТЬПУСТОТЫ(D31:D41);СЧИТАТЬПУСТОТЫ(D46:D47);СЧИТАТЬПУСТОТЫ(D51:D56));"";СУММ(D9;D12;D15;D19:D22))

Автор - Nic70y
Дата добавления - 15.06.2022 в 12:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Оптимизация формул в таблице (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!