Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Последний дубль по условию без автофильтра и массива - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Последний дубль по условию без автофильтра и массива (Формулы/Formulas)
Последний дубль по условию без автофильтра и массива
nordri Дата: Понедельник, 13.06.2022, 20:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
В соседней теме http://www.excelworld.ru/forum/23-50065-327664-16-1655025747 поднимал похожий (на мой взгляд) вопрос, но недостаточно его описал...

Имею лист, с данными, в которых есть уникальная информация, но присутствует повтор по столбцу ИМЯ.





Словами сложно описать, пример прикладываю.

У САША три строки с баллом "5", мне нужно вывести только последнюю строку (или хотя бы номер строки, дальше я с ВПР справимся вместе!).
Отдаленно похожее на это уже было в этой теме

=СЧЁТЕСЛИ($C$3:$C$23;"<"&C3)+СЧЁТЕСЛИ($C$2:C3;C3)

Правда я так и не понял до конца, как это работает...
Имея количество повторов мне нужно получить номер строки с этим последним дублем.
Тоесть избавиться от повторяющихся строк выше в левой таблице.
Примерно вот так:


В Первом (зеленом) столбце то, что у меня получилось. А во втором (голубом) то что требуется.
Помогите с формулой, которая выдаст номер строки, что то похожее на это:
Код
=СЧЁТЕСЛИМН(J7:J17;МАКС(J7:J17);O7:O17;МАКС(O7:O17))


[offtop]Тема не в том разделе создана, изначально в Гугл Таблицах, но вопрос не о них, а об обычном экселе. Модераторы уведомлены...[/offtop]
К сообщению приложен файл: 7584755.jpg(19.5 Kb) · 4886485.jpg(54.7 Kb) · 4879340.xlsx(20.1 Kb)


Сообщение отредактировал nordri - Понедельник, 13.06.2022, 23:42
 
Ответить
СообщениеВ соседней теме http://www.excelworld.ru/forum/23-50065-327664-16-1655025747 поднимал похожий (на мой взгляд) вопрос, но недостаточно его описал...

Имею лист, с данными, в которых есть уникальная информация, но присутствует повтор по столбцу ИМЯ.





Словами сложно описать, пример прикладываю.

У САША три строки с баллом "5", мне нужно вывести только последнюю строку (или хотя бы номер строки, дальше я с ВПР справимся вместе!).
Отдаленно похожее на это уже было в этой теме

=СЧЁТЕСЛИ($C$3:$C$23;"<"&C3)+СЧЁТЕСЛИ($C$2:C3;C3)

Правда я так и не понял до конца, как это работает...
Имея количество повторов мне нужно получить номер строки с этим последним дублем.
Тоесть избавиться от повторяющихся строк выше в левой таблице.
Примерно вот так:


В Первом (зеленом) столбце то, что у меня получилось. А во втором (голубом) то что требуется.
Помогите с формулой, которая выдаст номер строки, что то похожее на это:
Код
=СЧЁТЕСЛИМН(J7:J17;МАКС(J7:J17);O7:O17;МАКС(O7:O17))


[offtop]Тема не в том разделе создана, изначально в Гугл Таблицах, но вопрос не о них, а об обычном экселе. Модераторы уведомлены...[/offtop]

Автор - nordri
Дата добавления - 13.06.2022 в 20:07
Gustav Дата: Понедельник, 13.06.2022, 20:51 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2029
Репутация: 812 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
В соседней теме http://www.excelworld.ru/forum/23-50065-327664-16-1655025747 поднимал похожий (на мой взгляд) вопрос, но недостаточно его описал...

Да не похожий, а именно этот вопрос вы и поднимали (ну, разве что с другим условием отбора). И ответ на него уже приведен в этой самой соседней теме - см. там вторую формулу (для H7) в моем последнем сообщении (№ 4). Вы, наверное, просто недостаточно изучили ответ. А там и определение номера максимальной строки у каждого уникального ученика внутри функции QUERY и далее получение полной информации для максимальной строки каждого ученика с помощью ВПР(VLOOKUP).

Впрочем, если в 2022 году вам нравится догонять Таблицы Гугл формулами Excel шестилетней давности - то тут я вам не попутчик. Ждите, может, откликнется кто-нибудь еще.


Мой tip box - яд 41001663842605
 
Ответить
Сообщение
В соседней теме http://www.excelworld.ru/forum/23-50065-327664-16-1655025747 поднимал похожий (на мой взгляд) вопрос, но недостаточно его описал...

Да не похожий, а именно этот вопрос вы и поднимали (ну, разве что с другим условием отбора). И ответ на него уже приведен в этой самой соседней теме - см. там вторую формулу (для H7) в моем последнем сообщении (№ 4). Вы, наверное, просто недостаточно изучили ответ. А там и определение номера максимальной строки у каждого уникального ученика внутри функции QUERY и далее получение полной информации для максимальной строки каждого ученика с помощью ВПР(VLOOKUP).

Впрочем, если в 2022 году вам нравится догонять Таблицы Гугл формулами Excel шестилетней давности - то тут я вам не попутчик. Ждите, может, откликнется кто-нибудь еще.

Автор - Gustav
Дата добавления - 13.06.2022 в 20:51
nordri Дата: Среда, 15.06.2022, 17:05 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Кое что получилось (файл):

Код
=ЕСЛИ(ЕСЛИ($E$4;C17;D17);МАКС($B$6:$B16)+1)

посчитал количество дублей, для каждой строки, зафиксировав $ нижнюю границу диапазона:
Код
=СЧЁТЕСЛИ(E7:$E$17;E7)=1

Но мне сильно не нравиться такой подход...
В добавок и это тоже вызывает сомнения:
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(M5;$B$5:$I$5;0));0;ПОИСКПОЗ(M5;$B$5:$I$5;0))

В правой таблице с готовыми данными ищу заголовок столбца из левой таблицы, по имени заголовка второй...
К сообщению приложен файл: ___.xlsx(21.7 Kb) · 1131853.jpg(63.4 Kb)


Сообщение отредактировал nordri - Среда, 15.06.2022, 23:45
 
Ответить
СообщениеКое что получилось (файл):

Код
=ЕСЛИ(ЕСЛИ($E$4;C17;D17);МАКС($B$6:$B16)+1)

посчитал количество дублей, для каждой строки, зафиксировав $ нижнюю границу диапазона:
Код
=СЧЁТЕСЛИ(E7:$E$17;E7)=1

Но мне сильно не нравиться такой подход...
В добавок и это тоже вызывает сомнения:
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(M5;$B$5:$I$5;0));0;ПОИСКПОЗ(M5;$B$5:$I$5;0))

В правой таблице с готовыми данными ищу заголовок столбца из левой таблицы, по имени заголовка второй...

Автор - nordri
Дата добавления - 15.06.2022 в 17:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Последний дубль по условию без автофильтра и массива (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!