Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подставление значений из таблицы при выполнении условий - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставление значений из таблицы при выполнении условий (Формулы/Formulas)
Подставление значений из таблицы при выполнении условий
shaurman Дата: Среда, 22.06.2022, 10:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Уважаемые, добрый день.
Файл excel во вложении.
Имеется таблица с данными зависящими от 2х условий (столбец Q и строка 1).
Необходимо при вводе значений "B1" и "B2" получать данные из этой таблицы в ячейку "B3"
Пример: Если OAT = -40 и Press. Alt. = 0, то N1 Target = 81,4
Пробовал долгий и возможно неправильный путь, используя функции
Код
=ЕСЛИ(И(B1=-40;B2=-1);R2;ЕСЛИ(И(B1=-40;B2=1);S2))
, но в этом случае "число уровней вложенности превышает 64".

Подскажите, пожалуйста, возможно ли снятие ограничения на формулу или более простое решение?
К сообщению приложен файл: trend_monitorin.xls(39.0 Kb)


Сообщение отредактировал shaurman - Среда, 22.06.2022, 10:22
 
Ответить
СообщениеУважаемые, добрый день.
Файл excel во вложении.
Имеется таблица с данными зависящими от 2х условий (столбец Q и строка 1).
Необходимо при вводе значений "B1" и "B2" получать данные из этой таблицы в ячейку "B3"
Пример: Если OAT = -40 и Press. Alt. = 0, то N1 Target = 81,4
Пробовал долгий и возможно неправильный путь, используя функции
Код
=ЕСЛИ(И(B1=-40;B2=-1);R2;ЕСЛИ(И(B1=-40;B2=1);S2))
, но в этом случае "число уровней вложенности превышает 64".

Подскажите, пожалуйста, возможно ли снятие ограничения на формулу или более простое решение?

Автор - shaurman
Дата добавления - 22.06.2022 в 10:12
китин Дата: Среда, 22.06.2022, 10:14 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6908
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2007;2010;2016
shaurman, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеshaurman, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 22.06.2022 в 10:14
китин Дата: Среда, 22.06.2022, 10:24 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6908
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2007;2010;2016
в ячейку В3
Код
=ИНДЕКС($R$2:$AA$92;ПОИСКПОЗ($B$1;$Q$2:$Q$92;0);ПОИСКПОЗ($B$2;--($R$1:$AA$1);0))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
массивная потому что данные в $R$1:$AA$1 являются текстом


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениев ячейку В3
Код
=ИНДЕКС($R$2:$AA$92;ПОИСКПОЗ($B$1;$Q$2:$Q$92;0);ПОИСКПОЗ($B$2;--($R$1:$AA$1);0))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
массивная потому что данные в $R$1:$AA$1 являются текстом

Автор - китин
Дата добавления - 22.06.2022 в 10:24
shaurman Дата: Среда, 22.06.2022, 10:29 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

китин, большое Вам спасибо, всё получилось!
 
Ответить
Сообщениекитин, большое Вам спасибо, всё получилось!

Автор - shaurman
Дата добавления - 22.06.2022 в 10:29
Serge_007 Дата: Среда, 22.06.2022, 10:29 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 15574
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Код
=ГПР(B2;--R1:AA92;ПОИСКПОЗ(B1;Q1:Q92;))
К сообщению приложен файл: 20220622_shaurm.xls(82.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ГПР(B2;--R1:AA92;ПОИСКПОЗ(B1;Q1:Q92;))

Автор - Serge_007
Дата добавления - 22.06.2022 в 10:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставление значений из таблицы при выполнении условий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!