Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Оптимизация таблицы с повторяющейся формулой? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Оптимизация таблицы с повторяющейся формулой? (Формулы/Formulas)
Оптимизация таблицы с повторяющейся формулой?
romanchenko Дата: Среда, 10.08.2022, 00:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Всем привет. Прикладываю проблемный файл. Сегодня заметил, что файл долго сохраняется... Глянул - он весит 10мб. Эмпирическим путем выяснил, что проблемы в столбце AE, там одна и та же формула с условием. В ячейке AE2 суммируются все ячейки ниже. Таких строк в большом файле пока около 150. Убрал скрытие строк, удалил формулу из пока пустых - размер уменьшился до 4мб, но это все равно много для такого скудного содержимого... Можно ли это как-то оптимизировать?
Так как тут максимальный размер 500кб - вырезал кусок из большого файла.
К сообщению приложен файл: 3818008.xlsx(12.9 Kb)


Сообщение отредактировал romanchenko - Среда, 10.08.2022, 00:12
 
Ответить
СообщениеВсем привет. Прикладываю проблемный файл. Сегодня заметил, что файл долго сохраняется... Глянул - он весит 10мб. Эмпирическим путем выяснил, что проблемы в столбце AE, там одна и та же формула с условием. В ячейке AE2 суммируются все ячейки ниже. Таких строк в большом файле пока около 150. Убрал скрытие строк, удалил формулу из пока пустых - размер уменьшился до 4мб, но это все равно много для такого скудного содержимого... Можно ли это как-то оптимизировать?
Так как тут максимальный размер 500кб - вырезал кусок из большого файла.

Автор - romanchenko
Дата добавления - 10.08.2022 в 00:10
Nic70y Дата: Среда, 10.08.2022, 07:54 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
romanchenko, Вас смутила
Код
=СУММ()
, а
Код
=СУММПРОИЗВ()
нет?
в данном случае массивно вводить ее не нужно (ну это так, для инфо)
Код
=СУММЕСЛИ($AD$3:$AD$201;"приход";D$3:D$201)-СУММЕСЛИ($AD$3:$AD$201;"расход";D$3:D$201)
+ условное форматирование + куча заливки.
К сообщению приложен файл: 8183149.xlsx(10.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеromanchenko, Вас смутила
Код
=СУММ()
, а
Код
=СУММПРОИЗВ()
нет?
в данном случае массивно вводить ее не нужно (ну это так, для инфо)
Код
=СУММЕСЛИ($AD$3:$AD$201;"приход";D$3:D$201)-СУММЕСЛИ($AD$3:$AD$201;"расход";D$3:D$201)
+ условное форматирование + куча заливки.

Автор - Nic70y
Дата добавления - 10.08.2022 в 07:54
romanchenko Дата: Воскресенье, 14.08.2022, 20:41 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Спасибо, помогло.
Вас смутила

По правде сказать, меня вообще почти ничего кроме размера файла не смутило, я с экселем на Вы. А данную конструкцию предложили здесь же на форуме :) и она выполняла задачу. Но ваш вариант гораздо приятнее. Еще раз спасибо.
 
Ответить
СообщениеСпасибо, помогло.
Вас смутила

По правде сказать, меня вообще почти ничего кроме размера файла не смутило, я с экселем на Вы. А данную конструкцию предложили здесь же на форуме :) и она выполняла задачу. Но ваш вариант гораздо приятнее. Еще раз спасибо.

Автор - romanchenko
Дата добавления - 14.08.2022 в 20:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Оптимизация таблицы с повторяющейся формулой? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!