Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как задать номер строки как переменную - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как задать номер строки как переменную (Формулы/Formulas)
Как задать номер строки как переменную
etupikin10 Дата: Пятница, 09.09.2022, 11:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Здравствуйте, подскажите. На листе есть ячейка с формулой
Код
=СЧЁТЕСЛИ(ВторойЛист!$EB$8:$EB$20000;"да")
- считается количество ячеек с другого листа по условию. Как можно в формуле номер последней строки в столбце (20000) заменить переменной, которая будет записана например в ячейке B2 первого листа? Пробую написать
Код
=СЧЁТЕСЛИ(ВторойЛист!$EB$8:$EB$&B2;"да")
, но выдает ошибку....


Сообщение отредактировал Serge_007 - Пятница, 09.09.2022, 13:01
 
Ответить
СообщениеЗдравствуйте, подскажите. На листе есть ячейка с формулой
Код
=СЧЁТЕСЛИ(ВторойЛист!$EB$8:$EB$20000;"да")
- считается количество ячеек с другого листа по условию. Как можно в формуле номер последней строки в столбце (20000) заменить переменной, которая будет записана например в ячейке B2 первого листа? Пробую написать
Код
=СЧЁТЕСЛИ(ВторойЛист!$EB$8:$EB$&B2;"да")
, но выдает ошибку....

Автор - etupikin10
Дата добавления - 09.09.2022 в 11:16
Serge_007 Дата: Пятница, 09.09.2022, 13:16 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15409
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Код
=СУММ(ДВССЫЛ("A1:A"&B1))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=СУММ(ДВССЫЛ("A1:A"&B1))

Автор - Serge_007
Дата добавления - 09.09.2022 в 13:16
etupikin10 Дата: Пятница, 09.09.2022, 14:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Спасибо большое, получилось.
 
Ответить
СообщениеСпасибо большое, получилось.

Автор - etupikin10
Дата добавления - 09.09.2022 в 14:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как задать номер строки как переменную (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!