Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для отображения последней цены товара - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для отображения последней цены товара (Формулы/Formulas)
Формула для отображения последней цены товара
Pooshok Дата: Понедельник, 10.10.2022, 17:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте. Помогите пожалуйста, нужна формула для отображения последней цены, согласно времени договора. Данная цена необходима для каждого отдельного инструмента, которых в приведенной таблице два. Изменение расположения столбцов нежелательна. Заранее спасибо!
К сообщению приложен файл: 5275168.xls(26.5 Kb)
 
Ответить
СообщениеЗдравствуйте. Помогите пожалуйста, нужна формула для отображения последней цены, согласно времени договора. Данная цена необходима для каждого отдельного инструмента, которых в приведенной таблице два. Изменение расположения столбцов нежелательна. Заранее спасибо!

Автор - Pooshok
Дата добавления - 10.10.2022 в 17:57
jakim Дата: Понедельник, 10.10.2022, 19:39 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1125
Репутация: 298 ±
Замечаний: 0% ±

Excel 2010
Смотрите приложение с тремя формулами. Выбирайте на вкус.
К сообщению приложен файл: 1427705.xls(28.0 Kb)
 
Ответить
Сообщение
Смотрите приложение с тремя формулами. Выбирайте на вкус.

Автор - jakim
Дата добавления - 10.10.2022 в 19:39
Pooshok Дата: Понедельник, 10.10.2022, 21:06 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

jakim, спасибо, но к сожалению не подходит, так как указанные формулы не учитывают "наименование инструмента", простыми словами не учитывается марка бензина 92й или 95й(столбец "B"). Так как важна последняя цена как первого инструмента так и второго.
 
Ответить
Сообщениеjakim, спасибо, но к сожалению не подходит, так как указанные формулы не учитывают "наименование инструмента", простыми словами не учитывается марка бензина 92й или 95й(столбец "B"). Так как важна последняя цена как первого инструмента так и второго.

Автор - Pooshok
Дата добавления - 10.10.2022 в 21:06
Egyptian Дата: Понедельник, 10.10.2022, 23:21 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 425
Репутация: 140 ±
Замечаний: 0% ±

Excel 2013/2016
Если правильно понял то как-то так:
Код
=INDEX($A$2:$A$10;MATCH(SMALL(IF((MATCH($B$2:$B$10;$B$2:$B$10;)=(ROW($B$2:$B$10)-ROW($B$2)+1));LARGE($C$2:$C$10;ROW($1:$9)));ROW(A1));$C$2:$C$10;))

Формула массива.
К сообщению приложен файл: 0472656.xls(30.0 Kb)
 
Ответить
СообщениеЕсли правильно понял то как-то так:
Код
=INDEX($A$2:$A$10;MATCH(SMALL(IF((MATCH($B$2:$B$10;$B$2:$B$10;)=(ROW($B$2:$B$10)-ROW($B$2)+1));LARGE($C$2:$C$10;ROW($1:$9)));ROW(A1));$C$2:$C$10;))

Формула массива.

Автор - Egyptian
Дата добавления - 10.10.2022 в 23:21
cmivadwot Дата: Вторник, 11.10.2022, 00:44 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 6 ±
Замечаний: 0% ±

Pooshok, колхозный вариант
К сообщению приложен файл: 7187746.xls(246.0 Kb)
 
Ответить
СообщениеPooshok, колхозный вариант

Автор - cmivadwot
Дата добавления - 11.10.2022 в 00:44
прохожий2019 Дата: Вторник, 11.10.2022, 00:59 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 955
Репутация: 262 ±
Замечаний: 0% ±

365 Beta Channel
365 - одной формулой и без протяжки )))
Код
=ИНДЕКС(A2:C10;ПОИСКПОЗ(МАКСЕСЛИ(C2:C10;B2:B10;УНИК(B2:B10));C2:C10;);{1;2;3})
К сообщению приложен файл: 0472656.xlsx(10.8 Kb)
 
Ответить
Сообщение365 - одной формулой и без протяжки )))
Код
=ИНДЕКС(A2:C10;ПОИСКПОЗ(МАКСЕСЛИ(C2:C10;B2:B10;УНИК(B2:B10));C2:C10;);{1;2;3})

Автор - прохожий2019
Дата добавления - 11.10.2022 в 00:59
jakim Дата: Вторник, 11.10.2022, 13:33 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1125
Репутация: 298 ±
Замечаний: 0% ±

Excel 2010
Извините. Не обратил внимание на разность марок. Представляю ршение для 10 и выше версии Excel.

Код
=INDEX(A$2:A$7;AGGREGATE(15;6;ROW($1:$100)/(C$2:C$7=AGGREGATE(14;6;C$2:C$7/(B$2:B$7=E2);1)/($B$2:$B$7=E2));1))
К сообщению приложен файл: 1427705.xlsx(9.8 Kb)
 
Ответить
Сообщение
Извините. Не обратил внимание на разность марок. Представляю ршение для 10 и выше версии Excel.

Код
=INDEX(A$2:A$7;AGGREGATE(15;6;ROW($1:$100)/(C$2:C$7=AGGREGATE(14;6;C$2:C$7/(B$2:B$7=E2);1)/($B$2:$B$7=E2));1))

Автор - jakim
Дата добавления - 11.10.2022 в 13:33
Pooshok Дата: Вторник, 11.10.2022, 19:09 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Большое спасибо, все заработало.Все как обычно, ответили оперативно, взял ваши примеры за основу и вывел свою подходящую формулу, что я бы без вас делал yes ?


Сообщение отредактировал Pooshok - Вторник, 11.10.2022, 20:47
 
Ответить
СообщениеБольшое спасибо, все заработало.Все как обычно, ответили оперативно, взял ваши примеры за основу и вывел свою подходящую формулу, что я бы без вас делал yes ?

Автор - Pooshok
Дата добавления - 11.10.2022 в 19:09
gling Дата: Вторник, 11.10.2022, 20:28 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2389
Репутация: 625 ±
Замечаний: 0% ±

2010
Все как обычно, взял ваши примеры за основу и вывел свою
А посмотреть на неё можно, чтобы понять, что остальные делали не так?


ЯД-41001506838083
 
Ответить
Сообщение
Все как обычно, взял ваши примеры за основу и вывел свою
А посмотреть на неё можно, чтобы понять, что остальные делали не так?

Автор - gling
Дата добавления - 11.10.2022 в 20:28
Pooshok Дата: Вторник, 11.10.2022, 21:23 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Я неправильно выразился, все так. Данные которые отражены на листе 2 мне необходимы, поэтому сделал так.
К сообщению приложен файл: 5951541.xls(33.0 Kb)
 
Ответить
СообщениеЯ неправильно выразился, все так. Данные которые отражены на листе 2 мне необходимы, поэтому сделал так.

Автор - Pooshok
Дата добавления - 11.10.2022 в 21:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для отображения последней цены товара (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!