Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычесть нерабочие часы по графику из промежутка времени - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычесть нерабочие часы по графику из промежутка времени (Формулы/Formulas)
Вычесть нерабочие часы по графику из промежутка времени
kris205205 Дата: Четверг, 10.11.2022, 09:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Всем привет!
Буду очень благодарна, если найдется человек который может мне помочь)
Не понимаю как из промежутка времени вычесть ночь и выходные дни, возможно ли вообще?
Задача - посчитать время затраченное на заявку в рамках рабочего графика с 9 до 18, 5/2, то есть не должна учитываться ночь и выходные.

Спасибо!
К сообщению приложен файл: 7906628.xlsx(14.7 Kb)
 
Ответить
СообщениеВсем привет!
Буду очень благодарна, если найдется человек который может мне помочь)
Не понимаю как из промежутка времени вычесть ночь и выходные дни, возможно ли вообще?
Задача - посчитать время затраченное на заявку в рамках рабочего графика с 9 до 18, 5/2, то есть не должна учитываться ночь и выходные.

Спасибо!

Автор - kris205205
Дата добавления - 10.11.2022 в 09:27
Nic70y Дата: Четверг, 10.11.2022, 09:54 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7878
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
вдруг правильно
Код
=ЧИСТРАБДНИ(B2;C2;)*8-(B2-ЦЕЛОЕ(B2)-9/24)-(ЦЕЛОЕ(C2)+18/24-C2)
К сообщению приложен файл: 11.xlsx(15.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевдруг правильно
Код
=ЧИСТРАБДНИ(B2;C2;)*8-(B2-ЦЕЛОЕ(B2)-9/24)-(ЦЕЛОЕ(C2)+18/24-C2)

Автор - Nic70y
Дата добавления - 10.11.2022 в 09:54
kris205205 Дата: Четверг, 10.11.2022, 10:20 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Спасибо!
Я пока еще пытаюсь осознать формулу, но видимо идет не очень)
У меня почему то не срабатывает на примере с датой закрытия заявки день вдень, форматы ячеек попробовала поменять, никак не меняется число.
То есть есть кейсы, когда будут минуты, а не часы.
Что может быть не так?)
К сообщению приложен файл: 2389322.png(93.1 Kb)


Сообщение отредактировал Serge_007 - Четверг, 10.11.2022, 13:03
 
Ответить
СообщениеСпасибо!
Я пока еще пытаюсь осознать формулу, но видимо идет не очень)
У меня почему то не срабатывает на примере с датой закрытия заявки день вдень, форматы ячеек попробовала поменять, никак не меняется число.
То есть есть кейсы, когда будут минуты, а не часы.
Что может быть не так?)

Автор - kris205205
Дата добавления - 10.11.2022 в 10:20
Nic70y Дата: Четверг, 10.11.2022, 10:38 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7878
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
да с 1 днем косячит
Код
=ЕСЛИ(ЧИСТРАБДНИ(B2;C2;)>1;ЧИСТРАБДНИ(B2;C2;)*8-(B2-ЦЕЛОЕ(B2)-9/24)-(ЦЕЛОЕ(C2)+18/24-C2);(МИН(ЦЕЛОЕ(C2)+18/24;C2)-МАКС(ЦЕЛОЕ(B2)+9/24;B2))*8)
К сообщению приложен файл: 11-2-.xlsx(14.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеда с 1 днем косячит
Код
=ЕСЛИ(ЧИСТРАБДНИ(B2;C2;)>1;ЧИСТРАБДНИ(B2;C2;)*8-(B2-ЦЕЛОЕ(B2)-9/24)-(ЦЕЛОЕ(C2)+18/24-C2);(МИН(ЦЕЛОЕ(C2)+18/24;C2)-МАКС(ЦЕЛОЕ(B2)+9/24;B2))*8)

Автор - Nic70y
Дата добавления - 10.11.2022 в 10:38
kris205205 Дата: Четверг, 10.11.2022, 11:18 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

А можете мне вкратце объяснить логику, почему образовалось 0,15 после применения формулы?
По моим подсчетам, на выполнение было затрачено 27 мин. исходя из вашего примера :)
Уточню что бы понять как сводить и преобразовывать данные после


Сообщение отредактировал Serge_007 - Четверг, 10.11.2022, 13:03
 
Ответить
СообщениеА можете мне вкратце объяснить логику, почему образовалось 0,15 после применения формулы?
По моим подсчетам, на выполнение было затрачено 27 мин. исходя из вашего примера :)
Уточню что бы понять как сводить и преобразовывать данные после

Автор - kris205205
Дата добавления - 10.11.2022 в 11:18
Nic70y Дата: Четверг, 10.11.2022, 11:57 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7878
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
*8) замените нв *24)
только в одном месте - в конце формулы


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Четверг, 10.11.2022, 11:58
 
Ответить
Сообщение*8) замените нв *24)
только в одном месте - в конце формулы

Автор - Nic70y
Дата добавления - 10.11.2022 в 11:57
NikitaDvorets Дата: Четверг, 10.11.2022, 14:47 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 387
Репутация: 78 ±
Замечаний: 0% ±

Excel 2019
kris205205, добрый день.

Вариант без
Код
ЧИСТРАБДНИ()
, таблица с последовательным расчетом.
К сообщению приложен файл: _____10-11-22--.xlsm(25.5 Kb)
 
Ответить
Сообщениеkris205205, добрый день.

Вариант без
Код
ЧИСТРАБДНИ()
, таблица с последовательным расчетом.

Автор - NikitaDvorets
Дата добавления - 10.11.2022 в 14:47
kris205205 Дата: Четверг, 10.11.2022, 19:48 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Nic70y, воспроизвести по данной рекомендации не получилось, но возможно я что то недопоняла.
Спасибо!
 
Ответить
СообщениеNic70y, воспроизвести по данной рекомендации не получилось, но возможно я что то недопоняла.
Спасибо!

Автор - kris205205
Дата добавления - 10.11.2022 в 19:48
kris205205 Дата: Четверг, 10.11.2022, 19:50 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

NikitaDvorets, я посмотрела файл, сделала расчет по аналогии и о чудо hands
Спасибо огромнейшее за то, что проделали такую работу, Вы меня здорово выручили!
 
Ответить
СообщениеNikitaDvorets, я посмотрела файл, сделала расчет по аналогии и о чудо hands
Спасибо огромнейшее за то, что проделали такую работу, Вы меня здорово выручили!

Автор - kris205205
Дата добавления - 10.11.2022 в 19:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычесть нерабочие часы по графику из промежутка времени (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!