Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счет одинаковых месяцев и годов - Мир MS Excel

Старая форма входа
  • Страница 1 из 3
  • 1
  • 2
  • 3
  • »
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет одинаковых месяцев и годов (Формулы/Formulas)
Счет одинаковых месяцев и годов
Zorro7604 Дата: Вторник, 22.11.2022, 10:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Добрый день.
Стоит задача посчитать сколько дат (месяц+год) в диапазоне равны дате (месяц+год)
Код
=СУММПРОИЗВ(МЕСЯЦ(K:K)=МЕСЯЦ(C30)*(ГОД(K:K)=ГОД(C30)))


Помогите, что не так пишу?
Если можно и через "СУММПРОИЗВ" и через "СЧЕТЕСЛИМН"
Спасибо.


Сообщение отредактировал Serge_007 - Вторник, 22.11.2022, 10:56
 
Ответить
СообщениеДобрый день.
Стоит задача посчитать сколько дат (месяц+год) в диапазоне равны дате (месяц+год)
Код
=СУММПРОИЗВ(МЕСЯЦ(K:K)=МЕСЯЦ(C30)*(ГОД(K:K)=ГОД(C30)))


Помогите, что не так пишу?
Если можно и через "СУММПРОИЗВ" и через "СЧЕТЕСЛИМН"
Спасибо.

Автор - Zorro7604
Дата добавления - 22.11.2022 в 10:54
Serge_007 Дата: Вторник, 22.11.2022, 10:57 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Здравствуйте

Код
=СУММПРОИЗВ((МЕСЯЦ(K:K)=МЕСЯЦ(C30))*(ГОД(K:K)=ГОД(C30)))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=СУММПРОИЗВ((МЕСЯЦ(K:K)=МЕСЯЦ(C30))*(ГОД(K:K)=ГОД(C30)))

Автор - Serge_007
Дата добавления - 22.11.2022 в 10:57
Nic70y Дата: Вторник, 22.11.2022, 11:03 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 7875
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
и через "СЧЕТЕСЛИМН"
Код
=СЧЁТЕСЛИМН(K:K;">"&КОНМЕСЯЦА(C30;-1);K:K;"<="&КОНМЕСЯЦА(C30;0))


ЮMoney 41001841029809
 
Ответить
Сообщение
и через "СЧЕТЕСЛИМН"
Код
=СЧЁТЕСЛИМН(K:K;">"&КОНМЕСЯЦА(C30;-1);K:K;"<="&КОНМЕСЯЦА(C30;0))

Автор - Nic70y
Дата добавления - 22.11.2022 в 11:03
Zorro7604 Дата: Вторник, 22.11.2022, 11:32 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Спасибо за оперативную помощь.
Но,
если пишу через СУМПРОИЗВ, то ошибка "ЗНАЧ"
если пишу через СЧЕТЕСЛИМН, то 0, хотя в диапазоне совпадающие значение есть
 
Ответить
СообщениеСпасибо за оперативную помощь.
Но,
если пишу через СУМПРОИЗВ, то ошибка "ЗНАЧ"
если пишу через СЧЕТЕСЛИМН, то 0, хотя в диапазоне совпадающие значение есть

Автор - Zorro7604
Дата добавления - 22.11.2022 в 11:32
Serge_007 Дата: Вторник, 22.11.2022, 11:40 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
через СУМПРОИЗВ, то ошибка "ЗНАЧ"
У меня работает
Что-то делаете неправильно


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
через СУМПРОИЗВ, то ошибка "ЗНАЧ"
У меня работает
Что-то делаете неправильно

Автор - Serge_007
Дата добавления - 22.11.2022 в 11:40
Zorro7604 Дата: Вторник, 22.11.2022, 11:58 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

=СУММПРОИЗВ((МЕСЯЦ(K:K)=МЕСЯЦ(C30))*(ГОД(K:K)=ГОД(C30)))

Спасибо, нашёл у себя ошибку в форматах ячеек
 
Ответить
Сообщение
=СУММПРОИЗВ((МЕСЯЦ(K:K)=МЕСЯЦ(C30))*(ГОД(K:K)=ГОД(C30)))

Спасибо, нашёл у себя ошибку в форматах ячеек

Автор - Zorro7604
Дата добавления - 22.11.2022 в 11:58
Zorro7604 Дата: Понедельник, 28.11.2022, 11:58 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Здравствуйте.
Не знаю, как правильнее сделать, создать новую тему или можно дополнить эту, попробую дополнить, не обессудьте.
Первоначально помощи просил по задаче в сжатом виде, но в последствии все же столкнулся с проблемой.
нужно сделать счет значений по нескольким условиям:
1. Сравнить месяц и год в столбцах (с этим разобрались выше, еще раз спасибо). Прописал эту формулу во вкладке "сводная" в А2 и т.д.
2. Во вкладке "Исх. данные" в строке должна быть "1"
Т.е., как пример:
мы видим, что во вкладке "сводная" в апреле 2021 года с учетом выполнения только условия №2 значение получилось "2", а с учетом условия №2, должно получиться "0", потому что, во вкладке "исх. данные" в строках 7 и 11 (которые попали в расчет по условию 1) нет "1" в столбцах D:O
Вопрос, как прописать целиком формулу.
Спасибо.
К сообщению приложен файл: 7072579.xlsx(14.6 Kb)
 
Ответить
СообщениеЗдравствуйте.
Не знаю, как правильнее сделать, создать новую тему или можно дополнить эту, попробую дополнить, не обессудьте.
Первоначально помощи просил по задаче в сжатом виде, но в последствии все же столкнулся с проблемой.
нужно сделать счет значений по нескольким условиям:
1. Сравнить месяц и год в столбцах (с этим разобрались выше, еще раз спасибо). Прописал эту формулу во вкладке "сводная" в А2 и т.д.
2. Во вкладке "Исх. данные" в строке должна быть "1"
Т.е., как пример:
мы видим, что во вкладке "сводная" в апреле 2021 года с учетом выполнения только условия №2 значение получилось "2", а с учетом условия №2, должно получиться "0", потому что, во вкладке "исх. данные" в строках 7 и 11 (которые попали в расчет по условию 1) нет "1" в столбцах D:O
Вопрос, как прописать целиком формулу.
Спасибо.

Автор - Zorro7604
Дата добавления - 28.11.2022 в 11:58
Serge_007 Дата: Понедельник, 28.11.2022, 12:27 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Код
=СУММПРОИЗВ((МЕСЯЦ('Исх данные'!$B$2:$B$13)=МЕСЯЦ(A1))*(ГОД('Исх данные'!$B$2:$B$13)=ГОД(A1))*'Исх данные'!D$2:D$13)
К сообщению приложен файл: 20221128_Zorro7.xls(76.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((МЕСЯЦ('Исх данные'!$B$2:$B$13)=МЕСЯЦ(A1))*(ГОД('Исх данные'!$B$2:$B$13)=ГОД(A1))*'Исх данные'!D$2:D$13)

Автор - Serge_007
Дата добавления - 28.11.2022 в 12:27
Zorro7604 Дата: Понедельник, 28.11.2022, 12:42 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Спасибо, но не совсем так, Вы дополнили формулу поиском "1" в конкретном столбце, но мы не знаем в каком столбце "1" и есть ли они вообще
 
Ответить
СообщениеСпасибо, но не совсем так, Вы дополнили формулу поиском "1" в конкретном столбце, но мы не знаем в каком столбце "1" и есть ли они вообще

Автор - Zorro7604
Дата добавления - 28.11.2022 в 12:42
Serge_007 Дата: Понедельник, 28.11.2022, 13:03 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
поиском "1" в конкретном столбце
В столбце с соответствующим месяцем
А надо как?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
поиском "1" в конкретном столбце
В столбце с соответствующим месяцем
А надо как?

Автор - Serge_007
Дата добавления - 28.11.2022 в 13:03
Zorro7604 Дата: Понедельник, 28.11.2022, 13:07 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Serge_007, нужно, чтобы поиск "1" происходил во всех столбцах D:O, без привязки к месяцу, в котором стоит "1".
Я так понимаю, тогда верная формула будет:
Код
=СУММПРОИЗВ((МЕСЯЦ('Исх данные'!$B$2:$B$13)=МЕСЯЦ(A1))*(ГОД('Исх данные'!$B$2:$B$13)=ГОД(A1))*'Исх данные'!D$2:O$9999)

9999 - потому что, значение строк в таблице будет постоянно обновляться.


Сообщение отредактировал Zorro7604 - Понедельник, 28.11.2022, 13:37
 
Ответить
СообщениеSerge_007, нужно, чтобы поиск "1" происходил во всех столбцах D:O, без привязки к месяцу, в котором стоит "1".
Я так понимаю, тогда верная формула будет:
Код
=СУММПРОИЗВ((МЕСЯЦ('Исх данные'!$B$2:$B$13)=МЕСЯЦ(A1))*(ГОД('Исх данные'!$B$2:$B$13)=ГОД(A1))*'Исх данные'!D$2:O$9999)

9999 - потому что, значение строк в таблице будет постоянно обновляться.

Автор - Zorro7604
Дата добавления - 28.11.2022 в 13:07
Zorro7604 Дата: Понедельник, 28.11.2022, 13:38 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

В таком виде не работает, видимо из-за "9999"
 
Ответить
СообщениеВ таком виде не работает, видимо из-за "9999"

Автор - Zorro7604
Дата добавления - 28.11.2022 в 13:38
Serge_007 Дата: Понедельник, 28.11.2022, 13:44 | Сообщение № 13
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
верная формула будет
Да


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
верная формула будет
Да

Автор - Serge_007
Дата добавления - 28.11.2022 в 13:44
Serge_007 Дата: Понедельник, 28.11.2022, 13:45 | Сообщение № 14
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
В таком виде не работает
Так будет работать:
Код
=СУММПРОИЗВ((МЕСЯЦ('Исх данные'!$B$2:$B$9999)=МЕСЯЦ(A1))*(ГОД('Исх данные'!$B$2:$B$9999)=ГОД(A1))*'Исх данные'!D$2:O$9999)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
В таком виде не работает
Так будет работать:
Код
=СУММПРОИЗВ((МЕСЯЦ('Исх данные'!$B$2:$B$9999)=МЕСЯЦ(A1))*(ГОД('Исх данные'!$B$2:$B$9999)=ГОД(A1))*'Исх данные'!D$2:O$9999)

Автор - Serge_007
Дата добавления - 28.11.2022 в 13:45
Zorro7604 Дата: Понедельник, 28.11.2022, 13:52 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Понял, почему "9999" не работали, спасибо.
И в целом за помощь, большое спасибо.
 
Ответить
СообщениеПонял, почему "9999" не работали, спасибо.
И в целом за помощь, большое спасибо.

Автор - Zorro7604
Дата добавления - 28.11.2022 в 13:52
Zorro7604 Дата: Понедельник, 28.11.2022, 15:59 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Снова прошу помощи, последний раз по этому вопросу...
Появились доп. вводные и нужно добавить еще 2 условия. В интернете и на форуме усердно искал, но не нашёл ответа. Получаются следующие условия:
1. Сравнить месяц и год в столбцах (с этим разобрались).
2. Во вкладке "Исх. данные" в строке должна быть "1" (с этим тоже разобрались)
3. D2:D9999="*ГШ*". Я так и прописал бы, но массив, как я понимаю, символы вроде * не понимает.
4. E2:E9999="*ЕКБ*"
Как пример, при всех описанных условиях должна таблица во вкладке "сводная" посчитаться должны июнь 2021 и ноябрь 2021
Сейчас по 1 и 2 условиям формула такая
Код
=СУММПРОИЗВ((МЕСЯЦ('Исх данные'!$B$2:$B$9999)=МЕСЯЦ(A1))*(ГОД('Исх данные'!$B$2:$B$9999)=ГОД(A1)*'Исх данные'!$F$2:$Q$9999))


Заранее благодарю.
К сообщению приложен файл: 3594349.xlsx(15.5 Kb)
 
Ответить
СообщениеСнова прошу помощи, последний раз по этому вопросу...
Появились доп. вводные и нужно добавить еще 2 условия. В интернете и на форуме усердно искал, но не нашёл ответа. Получаются следующие условия:
1. Сравнить месяц и год в столбцах (с этим разобрались).
2. Во вкладке "Исх. данные" в строке должна быть "1" (с этим тоже разобрались)
3. D2:D9999="*ГШ*". Я так и прописал бы, но массив, как я понимаю, символы вроде * не понимает.
4. E2:E9999="*ЕКБ*"
Как пример, при всех описанных условиях должна таблица во вкладке "сводная" посчитаться должны июнь 2021 и ноябрь 2021
Сейчас по 1 и 2 условиям формула такая
Код
=СУММПРОИЗВ((МЕСЯЦ('Исх данные'!$B$2:$B$9999)=МЕСЯЦ(A1))*(ГОД('Исх данные'!$B$2:$B$9999)=ГОД(A1)*'Исх данные'!$F$2:$Q$9999))


Заранее благодарю.

Автор - Zorro7604
Дата добавления - 28.11.2022 в 15:59
Serge_007 Дата: Понедельник, 28.11.2022, 16:56 | Сообщение № 17
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Код
=СУММПРОИЗВ((МЕСЯЦ('Исх данные'!$B$2:$B$13)=МЕСЯЦ(A1))*(ГОД('Исх данные'!$B$2:$B$13)=ГОД(A1)*'Исх данные'!$F$2:$Q$13)*ЕЧИСЛО(ПОИСК("*ГШ*";'Исх данные'!$D$2:$D$13))*ЕЧИСЛО(ПОИСК("ЕКБ*";'Исх данные'!$E$2:$E$13)))
Формулу не надо вводить как массивную

[p.s.]"Тормозить" будет очень сильно)[/p.s.]


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((МЕСЯЦ('Исх данные'!$B$2:$B$13)=МЕСЯЦ(A1))*(ГОД('Исх данные'!$B$2:$B$13)=ГОД(A1)*'Исх данные'!$F$2:$Q$13)*ЕЧИСЛО(ПОИСК("*ГШ*";'Исх данные'!$D$2:$D$13))*ЕЧИСЛО(ПОИСК("ЕКБ*";'Исх данные'!$E$2:$E$13)))
Формулу не надо вводить как массивную

[p.s.]"Тормозить" будет очень сильно)[/p.s.]

Автор - Serge_007
Дата добавления - 28.11.2022 в 16:56
_Boroda_ Дата: Понедельник, 28.11.2022, 17:16 | Сообщение № 18
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16499
Репутация: 6422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не факт, но, возможно, так побыстрее будет
Код
=СУММПРОИЗВ(('Исх данные'!$B$2:$B$13>=A1)*('Исх данные'!$B$2:$B$13<ДАТАМЕС(A1;1))*'Исх данные'!$F$2:$Q$13*ЕЧИСЛО(ПОИСК("*ГШ*\*ЕКБ*";'Исх данные'!$D$2:$D$13&"\"&'Исх данные'!$E$2:$E$13)))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе факт, но, возможно, так побыстрее будет
Код
=СУММПРОИЗВ(('Исх данные'!$B$2:$B$13>=A1)*('Исх данные'!$B$2:$B$13<ДАТАМЕС(A1;1))*'Исх данные'!$F$2:$Q$13*ЕЧИСЛО(ПОИСК("*ГШ*\*ЕКБ*";'Исх данные'!$D$2:$D$13&"\"&'Исх данные'!$E$2:$E$13)))

Автор - _Boroda_
Дата добавления - 28.11.2022 в 17:16
Zorro7604 Дата: Вторник, 29.11.2022, 08:12 | Сообщение № 19
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Доброе утро.
Попробовал оба варианта, ругается #ПЕРЕНОС!
Формулу ввожу не как массивную.
В исходном файле во вкладке "сводная", таблица большая, со смежными ячейками и столбцами.
На сколько я понимаю, это ошибка означает попытку заменить данные в других ячейках, но не понимаю почему, ведь мы прописываем сумму по ряду условий в конкретную ячейку
 
Ответить
СообщениеДоброе утро.
Попробовал оба варианта, ругается #ПЕРЕНОС!
Формулу ввожу не как массивную.
В исходном файле во вкладке "сводная", таблица большая, со смежными ячейками и столбцами.
На сколько я понимаю, это ошибка означает попытку заменить данные в других ячейках, но не понимаю почему, ведь мы прописываем сумму по ряду условий в конкретную ячейку

Автор - Zorro7604
Дата добавления - 29.11.2022 в 08:12
_Boroda_ Дата: Вторник, 29.11.2022, 09:03 | Сообщение № 20
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16499
Репутация: 6422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Пример вставки и ругани будет?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПример вставки и ругани будет?

Автор - _Boroda_
Дата добавления - 29.11.2022 в 09:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет одинаковых месяцев и годов (Формулы/Formulas)
  • Страница 1 из 3
  • 1
  • 2
  • 3
  • »
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!