Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных на разные листы в одном файле - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных на разные листы в одном файле (Формулы/Formulas)
Перенос данных на разные листы в одном файле
boy1999 Дата: Четверг, 08.12.2022, 12:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!
Обыскал весь интернет но так и не нашел верно ответа...

Задача: в одном файле выставить оценки ученикам из общей ведомости (все оценки прописаны горизонтально, по предметам) в индивидуальную ведомость (оценки должны идти вертикально, каждая на своём месте).
Возможен ли такой фокус?

Файл с примером прикрепил.
К сообщению приложен файл: 2047786.xlsx(18.7 Kb)


Сообщение отредактировал boy1999 - Четверг, 08.12.2022, 12:52
 
Ответить
СообщениеЗдравствуйте!
Обыскал весь интернет но так и не нашел верно ответа...

Задача: в одном файле выставить оценки ученикам из общей ведомости (все оценки прописаны горизонтально, по предметам) в индивидуальную ведомость (оценки должны идти вертикально, каждая на своём месте).
Возможен ли такой фокус?

Файл с примером прикрепил.

Автор - boy1999
Дата добавления - 08.12.2022 в 12:39
_Boroda_ Дата: Четверг, 08.12.2022, 13:08 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16550
Репутация: 6441 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Курс и семестр не указаны. Поэтому вставил в Итог

Код
=ИНДЕКС('сводная ведомость'!$E$3:$AV$9;ПОИСКПОЗ(ПРОСМОТР(;-1/ДЛСТР($A$1:I$1);$A$1:I$1);'сводная ведомость'!$B$3:$B$9;);ЛЕВБ($A4;ПОИСК(".";$A4)-1))
К сообщению приложен файл: 2047786_1.xlsx(19.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеКурс и семестр не указаны. Поэтому вставил в Итог

Код
=ИНДЕКС('сводная ведомость'!$E$3:$AV$9;ПОИСКПОЗ(ПРОСМОТР(;-1/ДЛСТР($A$1:I$1);$A$1:I$1);'сводная ведомость'!$B$3:$B$9;);ЛЕВБ($A4;ПОИСК(".";$A4)-1))

Автор - _Boroda_
Дата добавления - 08.12.2022 в 13:08
msi2102 Дата: Четверг, 08.12.2022, 13:15 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 263
Репутация: 94 ±
Замечаний: 0% ±

Excel 2007
Или так
для количества часов:
Код

=ИНДЕКС('сводная ведомость'!$E$1:$AV$1;ПОИСКПОЗ(B4;'сводная ведомость'!$E$2:$AV$2;0))

для значений:
Код
=ИНДЕКС('сводная ведомость'!$E$3:$AV$4;ПОИСКПОЗ($C$1;'сводная ведомость'!$B$3:$B$4;0);ПОИСКПОЗ(B4;'сводная ведомость'!$E$2:$AV$2;0))

Результат на "Лист3"
Нужно выбрать из списка ФИО
К сообщению приложен файл: 2487610.xlsx(22.0 Kb)
 
Ответить
СообщениеИли так
для количества часов:
Код

=ИНДЕКС('сводная ведомость'!$E$1:$AV$1;ПОИСКПОЗ(B4;'сводная ведомость'!$E$2:$AV$2;0))

для значений:
Код
=ИНДЕКС('сводная ведомость'!$E$3:$AV$4;ПОИСКПОЗ($C$1;'сводная ведомость'!$B$3:$B$4;0);ПОИСКПОЗ(B4;'сводная ведомость'!$E$2:$AV$2;0))

Результат на "Лист3"
Нужно выбрать из списка ФИО

Автор - msi2102
Дата добавления - 08.12.2022 в 13:15
boy1999 Дата: Четверг, 08.12.2022, 14:09 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

msi2102, всё хорошо, но можно ли как-то настроить или вставить в таблицу на 2 листе (индивидуальная ведомость) оценки по определенным предметам в определенное место? и есть ли возможность разработать одну общую формулу для оценок, а потом просто выбирать фамилию из выпадающего списка?


Сообщение отредактировал boy1999 - Четверг, 08.12.2022, 14:14
 
Ответить
Сообщениеmsi2102, всё хорошо, но можно ли как-то настроить или вставить в таблицу на 2 листе (индивидуальная ведомость) оценки по определенным предметам в определенное место? и есть ли возможность разработать одну общую формулу для оценок, а потом просто выбирать фамилию из выпадающего списка?

Автор - boy1999
Дата добавления - 08.12.2022 в 14:09
msi2102 Дата: Четверг, 08.12.2022, 22:28 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 263
Репутация: 94 ±
Замечаний: 0% ±

Excel 2007
Как Вам уже писал _Boroda_, у Вас в сводной ведомости не хватает номера семестра, если его добавить, то можно так
Сумма количества часов по плану:
Код
=СУММЕСЛИ('сводная ведомость'!$E$2:$AV$2;Лист3!B4;'сводная ведомость'!$E$1:$AV$1)

для оценок (массивная):
Код
=ЕСЛИОШИБКА(ИНДЕКС('сводная ведомость'!$E$4:$AV$5;ПОИСКПОЗ($C$1;'сводная ведомость'!$B$4:$B$5;0);ПОИСКПОЗ($B4&D$3;('сводная ведомость'!$E$2:$AV$2)&('сводная ведомость'!$E$3:$AV$3);0));"")

пример на "Лист3"
PS: только нужно дубли предметов удалить
К сообщению приложен файл: 7125201.xlsx(22.9 Kb)


Сообщение отредактировал msi2102 - Четверг, 08.12.2022, 22:30
 
Ответить
СообщениеКак Вам уже писал _Boroda_, у Вас в сводной ведомости не хватает номера семестра, если его добавить, то можно так
Сумма количества часов по плану:
Код
=СУММЕСЛИ('сводная ведомость'!$E$2:$AV$2;Лист3!B4;'сводная ведомость'!$E$1:$AV$1)

для оценок (массивная):
Код
=ЕСЛИОШИБКА(ИНДЕКС('сводная ведомость'!$E$4:$AV$5;ПОИСКПОЗ($C$1;'сводная ведомость'!$B$4:$B$5;0);ПОИСКПОЗ($B4&D$3;('сводная ведомость'!$E$2:$AV$2)&('сводная ведомость'!$E$3:$AV$3);0));"")

пример на "Лист3"
PS: только нужно дубли предметов удалить

Автор - msi2102
Дата добавления - 08.12.2022 в 22:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных на разные листы в одном файле (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!