Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка значений из таблицы по нескольким параметрам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений из таблицы по нескольким параметрам (Формулы/Formulas)
Выборка значений из таблицы по нескольким параметрам
Smile Дата: Четверг, 15.12.2022, 22:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня всем профессионалам эксель!
Прошу помощи, сломал всю голову, второй день не складывается формула :(

Есть выгрузка из 1С (порядка 500-700 строк). Из выгрузки надо в Список 1 (ячейки G-I) подтянуть все строки, которые не относятся к командировочным расходам (без сортировки, группировки, суммирования и пр.) и в Список 2 (ячейки K-L) подтянуть только те строки из выгрузки (колонки А-Е), статья ДДС которых соответствует приведенным в колонке P (так же без сортировки, суммирования и пр.). При этом в колонке Р может быть от 1 до 100 значений
Список 2 даже более критичен, чем Список 1 (сократить-то всегда можно).

Все остальное уже написал, а тут прямо ступор какой-то :(

Заранее благодарю за помощь!
К сообщению приложен файл: ___.xlsx(12.2 Kb)
 
Ответить
СообщениеДоброго дня всем профессионалам эксель!
Прошу помощи, сломал всю голову, второй день не складывается формула :(

Есть выгрузка из 1С (порядка 500-700 строк). Из выгрузки надо в Список 1 (ячейки G-I) подтянуть все строки, которые не относятся к командировочным расходам (без сортировки, группировки, суммирования и пр.) и в Список 2 (ячейки K-L) подтянуть только те строки из выгрузки (колонки А-Е), статья ДДС которых соответствует приведенным в колонке P (так же без сортировки, суммирования и пр.). При этом в колонке Р может быть от 1 до 100 значений
Список 2 даже более критичен, чем Список 1 (сократить-то всегда можно).

Все остальное уже написал, а тут прямо ступор какой-то :(

Заранее благодарю за помощь!

Автор - Smile
Дата добавления - 15.12.2022 в 22:06
gling Дата: Четверг, 15.12.2022, 23:04 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Здравствуйте.
Посмотрите вариант в файле. Формулы массива для табл1
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$B$28;НАИМЕНЬШИЙ(ЕСЛИ($C$1:$C$28<>"Командировочные расходы";СТРОКА($C$1:$C$28);"");СТРОКА(G1)));"")
Для табл2
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$B$28;НАИМЕНЬШИЙ(ЕСЛИ($C$1:$C$28=ТРАНСП($P$3:$P$6);СТРОКА($C$1:$C$28);"");СТРОКА(G1)));"")
ИНДЕКС(... -выбираете нужный диапазон отображения.
К сообщению приложен файл: 2445742.xlsx(15.7 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Четверг, 15.12.2022, 23:29
 
Ответить
СообщениеЗдравствуйте.
Посмотрите вариант в файле. Формулы массива для табл1
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$B$28;НАИМЕНЬШИЙ(ЕСЛИ($C$1:$C$28<>"Командировочные расходы";СТРОКА($C$1:$C$28);"");СТРОКА(G1)));"")
Для табл2
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$B$28;НАИМЕНЬШИЙ(ЕСЛИ($C$1:$C$28=ТРАНСП($P$3:$P$6);СТРОКА($C$1:$C$28);"");СТРОКА(G1)));"")
ИНДЕКС(... -выбираете нужный диапазон отображения.

Автор - gling
Дата добавления - 15.12.2022 в 23:04
Egyptian Дата: Четверг, 15.12.2022, 23:09 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 442
Репутация: 146 ±
Замечаний: 0% ±

Excel 2013/2016
Еще варианты:
Код
=INDEX(B:B;AGGREGATE(15;6;ROW($B$3:$B$500)/($C$3:$C$500<>"Командировочные расходы");ROW(A1)))

Код
=INDEX(B:B;AGGREGATE(15;6;ROW($B$3:$B$500)/(ISNUMBER(MATCH($C$3:$C$500;$P$3:$P$100;)));ROW(A1)))
К сообщению приложен файл: 0266521.xlsx(13.7 Kb)
 
Ответить
СообщениеЕще варианты:
Код
=INDEX(B:B;AGGREGATE(15;6;ROW($B$3:$B$500)/($C$3:$C$500<>"Командировочные расходы");ROW(A1)))

Код
=INDEX(B:B;AGGREGATE(15;6;ROW($B$3:$B$500)/(ISNUMBER(MATCH($C$3:$C$500;$P$3:$P$100;)));ROW(A1)))

Автор - Egyptian
Дата добавления - 15.12.2022 в 23:09
Smile Дата: Пятница, 16.12.2022, 10:46 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Спасибо, добрые люди!
Все заработало!
 
Ответить
СообщениеСпасибо, добрые люди!
Все заработало!

Автор - Smile
Дата добавления - 16.12.2022 в 10:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений из таблицы по нескольким параметрам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!