Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт пустых ячеек , находящихся между заполненными - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт пустых ячеек , находящихся между заполненными (Формулы/Formulas)
Подсчёт пустых ячеек , находящихся между заполненными
artemmaks Дата: Среда, 21.12.2022, 15:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

День добрый , нужна помощь с формулой. B)
Необходимо подсчитать количество пропусков, в промежутках между заполненными ячейками,не в общем количестве за строку, а сколько ячеек были пустыми до того как ячейка стала заполненной, пример прикрепил ниже.
К сообщению приложен файл: 0135422.xlsx (10.1 Kb)
 
Ответить
СообщениеДень добрый , нужна помощь с формулой. B)
Необходимо подсчитать количество пропусков, в промежутках между заполненными ячейками,не в общем количестве за строку, а сколько ячеек были пустыми до того как ячейка стала заполненной, пример прикрепил ниже.

Автор - artemmaks
Дата добавления - 21.12.2022 в 15:19
Nic70y Дата: Среда, 21.12.2022, 15:27 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8026
Репутация: 1952 ±
Замечаний: 0% ±

Excel 2010
artemmaks, у Вас "все" ячейки заполнены, 0 это не пустота.
или пример неверный или вопрос.
как правильно?


ЮMoney 41001841029809
 
Ответить
Сообщениеartemmaks, у Вас "все" ячейки заполнены, 0 это не пустота.
или пример неверный или вопрос.
как правильно?

Автор - Nic70y
Дата добавления - 21.12.2022 в 15:27
artemmaks Дата: Среда, 21.12.2022, 15:32 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, вы правы , некорректно написал скорее всего, 0 я беру "в качестве" пустой клетки.
В принципе не важно будет там 0 или пусто, как удобнее будет сделать формулу в итоге
 
Ответить
СообщениеNic70y, вы правы , некорректно написал скорее всего, 0 я беру "в качестве" пустой клетки.
В принципе не важно будет там 0 или пусто, как удобнее будет сделать формулу в итоге

Автор - artemmaks
Дата добавления - 21.12.2022 в 15:32
Nic70y Дата: Среда, 21.12.2022, 16:32 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8026
Репутация: 1952 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(($A9:$AB9=0)*($B9:$AC9<>0);СТОЛБЕЦ($B9:$AC9));СТОЛБЕЦ(B1));СТОЛБЕЦ($AC9))-НАИМЕНЬШИЙ(ЕСЛИ(($A9:$AB9<>0)*($B9:$AC9=0);СТОЛБЕЦ($B9:$AC9));СТОЛБЕЦ(A1));"")
К сообщению приложен файл: 111444.xlsx (10.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеформула массива
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(($A9:$AB9=0)*($B9:$AC9<>0);СТОЛБЕЦ($B9:$AC9));СТОЛБЕЦ(B1));СТОЛБЕЦ($AC9))-НАИМЕНЬШИЙ(ЕСЛИ(($A9:$AB9<>0)*($B9:$AC9=0);СТОЛБЕЦ($B9:$AC9));СТОЛБЕЦ(A1));"")

Автор - Nic70y
Дата добавления - 21.12.2022 в 16:32
artemmaks Дата: Среда, 21.12.2022, 17:33 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо большое! Перенес формулу к себе на основные данные, в большинстве случаев формула работает верно, но в некоторых (выделил красным) , она выдает почему-то не те числа. Можете посмотреть в чем дело? :)
Спасибо еще раз
К сообщению приложен файл: 111111111111111.xlsx (319.6 Kb)
 
Ответить
СообщениеNic70y, спасибо большое! Перенес формулу к себе на основные данные, в большинстве случаев формула работает верно, но в некоторых (выделил красным) , она выдает почему-то не те числа. Можете посмотреть в чем дело? :)
Спасибо еще раз

Автор - artemmaks
Дата добавления - 21.12.2022 в 17:33
Nic70y Дата: Четверг, 22.12.2022, 08:25 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 8026
Репутация: 1952 ±
Замечаний: 0% ±

Excel 2010
artemmaks, посмотрите, так надо?
К сообщению приложен файл: 9837863.xlsx (327.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеartemmaks, посмотрите, так надо?

Автор - Nic70y
Дата добавления - 22.12.2022 в 08:25
artemmaks Дата: Четверг, 22.12.2022, 10:52 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, да, спасибо большое! yes
 
Ответить
СообщениеNic70y, да, спасибо большое! yes

Автор - artemmaks
Дата добавления - 22.12.2022 в 10:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт пустых ячеек , находящихся между заполненными (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!