Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ИНДЕКС подтягивает пустые строки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ИНДЕКС подтягивает пустые строки (Формулы/Formulas)
ИНДЕКС подтягивает пустые строки
bosika Дата: Среда, 04.01.2023, 08:42 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
Приветствую Вас ГУРУ экселя!
При использовании функции ИНДЕКС подтягиваются пустые строки. Со столбцов S и Т листа СписокСИ в столбцы А и В лист ЖурналВыданныхСвидетельств подтягиваются значения вместе с пустыми строками. Как нужно изменить формулу, чтобы подтягивались только значения без пустых строк? Спасибо заранее за помощь.
К сообщению приложен файл: __11.xls(391.0 Kb)


Начинающий. Много и долго не пинать. Больно однако.
 
Ответить
СообщениеПриветствую Вас ГУРУ экселя!
При использовании функции ИНДЕКС подтягиваются пустые строки. Со столбцов S и Т листа СписокСИ в столбцы А и В лист ЖурналВыданныхСвидетельств подтягиваются значения вместе с пустыми строками. Как нужно изменить формулу, чтобы подтягивались только значения без пустых строк? Спасибо заранее за помощь.

Автор - bosika
Дата добавления - 04.01.2023 в 08:42
DrMini Дата: Среда, 04.01.2023, 09:11 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 912
Репутация: 79 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
bosika, Доброго времени суток.
Может через ЕСЛИ подойдёт?
Код
=@ЕСЛИ(СписокСИ!S3<>0;ИНДЕКС(СписокСИ!$S$3:$S$8;НАИМЕНЬШИЙ(ЕСЛИ((@СписокСИ!$R$3:$R$8<>"Годен")*(@СписокСИ!$R$3:$R$8<>"Не годен");@СТРОКА($A$3:$A$10000));СТРОКА($A$1)));"")
К сообщению приложен файл: _11.xls(384.5 Kb)


Сообщение отредактировал DrMini - Среда, 04.01.2023, 09:11
 
Ответить
Сообщениеbosika, Доброго времени суток.
Может через ЕСЛИ подойдёт?
Код
=@ЕСЛИ(СписокСИ!S3<>0;ИНДЕКС(СписокСИ!$S$3:$S$8;НАИМЕНЬШИЙ(ЕСЛИ((@СписокСИ!$R$3:$R$8<>"Годен")*(@СписокСИ!$R$3:$R$8<>"Не годен");@СТРОКА($A$3:$A$10000));СТРОКА($A$1)));"")

Автор - DrMini
Дата добавления - 04.01.2023 в 09:11
bosika Дата: Среда, 04.01.2023, 09:23 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
DrMini, Спасибо, но не то, все равно 5 пустых дает.


Начинающий. Много и долго не пинать. Больно однако.
 
Ответить
СообщениеDrMini, Спасибо, но не то, все равно 5 пустых дает.

Автор - bosika
Дата добавления - 04.01.2023 в 09:23
DrMini Дата: Среда, 04.01.2023, 09:26 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 912
Репутация: 79 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
все равно 5 пустых дает.

А, что там должно быть?
Не понял.
 
Ответить
Сообщение
все равно 5 пустых дает.

А, что там должно быть?
Не понял.

Автор - DrMini
Дата добавления - 04.01.2023 в 09:26
bosika Дата: Среда, 04.01.2023, 09:42 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
DrMini, Немного расширил данные.
К сообщению приложен файл: 0646243.xls(405.5 Kb)


Начинающий. Много и долго не пинать. Больно однако.
 
Ответить
СообщениеDrMini, Немного расширил данные.

Автор - bosika
Дата добавления - 04.01.2023 в 09:42
gling Дата: Среда, 04.01.2023, 12:54 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Если правильно понял. Попробуйте формулу массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(СписокСИ!$S$1:$S$100;НАИМЕНЬШИЙ(ЕСЛИ((СписокСИ!$R$3:$R$100="Годен");СТРОКА($B$3:$B$100));СТРОКА(A1)));"")
К сообщению приложен файл: 8650840.xls(406.5 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЕсли правильно понял. Попробуйте формулу массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(СписокСИ!$S$1:$S$100;НАИМЕНЬШИЙ(ЕСЛИ((СписокСИ!$R$3:$R$100="Годен");СТРОКА($B$3:$B$100));СТРОКА(A1)));"")

Автор - gling
Дата добавления - 04.01.2023 в 12:54
bosika Дата: Среда, 04.01.2023, 13:20 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
gling, Большое человеческое спасибо. то что нужно. Тему можно закрывать.


Начинающий. Много и долго не пинать. Больно однако.
 
Ответить
Сообщение gling, Большое человеческое спасибо. то что нужно. Тему можно закрывать.

Автор - bosika
Дата добавления - 04.01.2023 в 13:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ИНДЕКС подтягивает пустые строки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!