Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ячейка вычисляет значение "" от этого график ломается - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ячейка вычисляет значение "" от этого график ломается (Формулы/Formulas)
Ячейка вычисляет значение "" от этого график ломается
Cold_666 Дата: Пятница, 13.01.2023, 06:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

День добрый.
В зависимости от исходных данных начиная с последней строки (120 строка) ячейки таблицы могут возвращать значение "", что приводит к изменению вида графика.
График 1 имеет искомый вид. В его источник данных C20:C52 и F20:F52 не попала ячейка со значением "". По вертикали откладываются значения С20:С52, а по горизонтали откладываются значения F20:52.
График 2 имеет искаженный вид. В его источник данных F20:F120 и C20:C120 попала ячейка со значением "". По вертикали откладываются значения С20:C52, в вот по горизонтали вместо значений откладывается количество определений.
Как сделать так что бы не обращая внимание на то что в источнике данных присутствуют ячейки со значением "", график продолжал откладывать по горизонтали значения, а сами "" воспринимал абсолютно как пустые значения.

Тут нашел решение на словах похожей проблемы http://www.excelworld.ru/forum/2-46862-1 но мне это решение применить не удалось, можете подсказать как его использовать ?
К сообщению приложен файл: 5301349.xlsx(35.0 Kb)


Сообщение отредактировал Cold_666 - Пятница, 13.01.2023, 06:58
 
Ответить
СообщениеДень добрый.
В зависимости от исходных данных начиная с последней строки (120 строка) ячейки таблицы могут возвращать значение "", что приводит к изменению вида графика.
График 1 имеет искомый вид. В его источник данных C20:C52 и F20:F52 не попала ячейка со значением "". По вертикали откладываются значения С20:С52, а по горизонтали откладываются значения F20:52.
График 2 имеет искаженный вид. В его источник данных F20:F120 и C20:C120 попала ячейка со значением "". По вертикали откладываются значения С20:C52, в вот по горизонтали вместо значений откладывается количество определений.
Как сделать так что бы не обращая внимание на то что в источнике данных присутствуют ячейки со значением "", график продолжал откладывать по горизонтали значения, а сами "" воспринимал абсолютно как пустые значения.

Тут нашел решение на словах похожей проблемы http://www.excelworld.ru/forum/2-46862-1 но мне это решение применить не удалось, можете подсказать как его использовать ?

Автор - Cold_666
Дата добавления - 13.01.2023 в 06:57
Nic70y Дата: Пятница, 13.01.2023, 07:57 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8005
Репутация: 1949 ±
Замечаний: 0% ±

Excel 2010
так?
Код
=ЕСЛИ(C20=h;НД();
К сообщению приложен файл: 18.xlsx(41.0 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениетак?
Код
=ЕСЛИ(C20=h;НД();

Автор - Nic70y
Дата добавления - 13.01.2023 в 07:57
Cold_666 Дата: Пятница, 13.01.2023, 08:15 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

так?
да спасибо большое !
 
Ответить
Сообщение
так?
да спасибо большое !

Автор - Cold_666
Дата добавления - 13.01.2023 в 08:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ячейка вычисляет значение "" от этого график ломается (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!