Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединить данные двух строк массива в одну - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединить данные двух строк массива в одну (Формулы/Formulas)
Объединить данные двух строк массива в одну
ki5real5ki Дата: Суббота, 21.01.2023, 21:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Приветствую! Подскажите, пожалуйста, не могу никак сообразить как составить формулу. Нужно схлопнуть две строки в одну, т.е 4 строки в две. Танцевал вокруг ИНДЕКС, СТРОКА, ЕНЕЧЕТ, ДВССЫЛ. Везде лазил - решения проблемы не нашел. Желательно формулой, а не макросом.

Дано:
1 3 5 7
2 4 6 8
9 10 11 12
13 14 15 16

Результат - 1 2 3 4 5 6 7 8
9 10 11 12 13 14 15 16

Заранее благодарю за помощь!
К сообщению приложен файл: 3898496.xlsx (9.1 Kb)
 
Ответить
СообщениеПриветствую! Подскажите, пожалуйста, не могу никак сообразить как составить формулу. Нужно схлопнуть две строки в одну, т.е 4 строки в две. Танцевал вокруг ИНДЕКС, СТРОКА, ЕНЕЧЕТ, ДВССЫЛ. Везде лазил - решения проблемы не нашел. Желательно формулой, а не макросом.

Дано:
1 3 5 7
2 4 6 8
9 10 11 12
13 14 15 16

Результат - 1 2 3 4 5 6 7 8
9 10 11 12 13 14 15 16

Заранее благодарю за помощь!

Автор - ki5real5ki
Дата добавления - 21.01.2023 в 21:02
gling Дата: Суббота, 21.01.2023, 21:30 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2456
Репутация: 654 ±
Замечаний: 0% ±

2010
Здравствуйте.
ТОлько для ваших данных. Для первой строки результата.
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$28:$D$29;ОСТАТ(СТОЛБЕЦ(B28);2)+1;СТОЛБЕЦ(B28)/2);"")
и для второй
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$30:$D$31;СТОЛБЕЦ(D30)/4;ОСТАТ(СТОЛБЕЦ(D30);4)+1);"")


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
ТОлько для ваших данных. Для первой строки результата.
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$28:$D$29;ОСТАТ(СТОЛБЕЦ(B28);2)+1;СТОЛБЕЦ(B28)/2);"")
и для второй
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$30:$D$31;СТОЛБЕЦ(D30)/4;ОСТАТ(СТОЛБЕЦ(D30);4)+1);"")

Автор - gling
Дата добавления - 21.01.2023 в 21:30
ki5real5ki Дата: Суббота, 21.01.2023, 22:33 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

gling, Спасибо! Но я ошибся в условии, там будет вот так(т.е всю таблицу первой формулой):
1 3 5 7
2 4 6 8
9 11 13 15
10 12 14 16

Получается используя вашу формулу на мой массив 4 x 4 ( =ЕСЛИОШИБКА(ИНДЕКС($A$28:$D$29;ОСТАТ(СТОЛБЕЦ(B28);2)+1;СТОЛБЕЦ(B28)/2);"") на 3 и 4 строку таблицы, я просто накрутил счетчик и работает так: =ЕСЛИОШИБКА(ИНДЕКС($A$28:$D$31;ОСТАТ(СТОЛБЕЦ(B28);2)+3;СТОЛБЕЦ(B28)/2);""). Верно или можно "красивее"?
К сообщению приложен файл: 1627504.xlsx (10.3 Kb)
 
Ответить
Сообщениеgling, Спасибо! Но я ошибся в условии, там будет вот так(т.е всю таблицу первой формулой):
1 3 5 7
2 4 6 8
9 11 13 15
10 12 14 16

Получается используя вашу формулу на мой массив 4 x 4 ( =ЕСЛИОШИБКА(ИНДЕКС($A$28:$D$29;ОСТАТ(СТОЛБЕЦ(B28);2)+1;СТОЛБЕЦ(B28)/2);"") на 3 и 4 строку таблицы, я просто накрутил счетчик и работает так: =ЕСЛИОШИБКА(ИНДЕКС($A$28:$D$31;ОСТАТ(СТОЛБЕЦ(B28);2)+3;СТОЛБЕЦ(B28)/2);""). Верно или можно "красивее"?

Автор - ki5real5ki
Дата добавления - 21.01.2023 в 22:33
gling Дата: Суббота, 21.01.2023, 23:43 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2456
Репутация: 654 ±
Замечаний: 0% ±

2010
Можно так
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС($A$28:$A$31;СТРОКА(A1)*2-1):ИНДЕКС($D$28:$D$31;СТРОКА(A1)*2);ОСТАТ(СТОЛБЕЦ(B1);2)+1;СТОЛБЕЦ(B1)/2);"")
или с диапазоном в диспетчере имен
Код
=ЕСЛИОШИБКА(ИНДЕКС(Диа;ОСТАТ(СТОЛБЕЦ(B1);2)+1;СТОЛБЕЦ(B1)/2)1;"")
К сообщению приложен файл: 0258691.xlsx (11.1 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Суббота, 21.01.2023, 23:47
 
Ответить
СообщениеМожно так
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС($A$28:$A$31;СТРОКА(A1)*2-1):ИНДЕКС($D$28:$D$31;СТРОКА(A1)*2);ОСТАТ(СТОЛБЕЦ(B1);2)+1;СТОЛБЕЦ(B1)/2);"")
или с диапазоном в диспетчере имен
Код
=ЕСЛИОШИБКА(ИНДЕКС(Диа;ОСТАТ(СТОЛБЕЦ(B1);2)+1;СТОЛБЕЦ(B1)/2)1;"")

Автор - gling
Дата добавления - 21.01.2023 в 23:43
ki5real5ki Дата: Воскресенье, 22.01.2023, 06:50 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

gling, второй вариант понравился, благодарю)
 
Ответить
Сообщениеgling, второй вариант понравился, благодарю)

Автор - ki5real5ki
Дата добавления - 22.01.2023 в 06:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединить данные двух строк массива в одну (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!