Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как вычислить значение при нескольких условия? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как вычислить значение при нескольких условия? (Формулы/Formulas)
Как вычислить значение при нескольких условия?
irinasuhoveewa Дата: Воскресенье, 22.01.2023, 01:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте! Нужно определить стоимость доставки за указанное количество паллет, в зависимости от города и стоимости доставки за каждый паллет. Помогите с формулой, чтоб вычисляла значение.
К сообщению приложен файл: Book2.xlsx(10.8 Kb)
 
Ответить
СообщениеЗдравствуйте! Нужно определить стоимость доставки за указанное количество паллет, в зависимости от города и стоимости доставки за каждый паллет. Помогите с формулой, чтоб вычисляла значение.

Автор - irinasuhoveewa
Дата добавления - 22.01.2023 в 01:44
OlehandR Дата: Воскресенье, 22.01.2023, 02:32 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 2 ±
Замечаний: 0% ±

Здравствуйте, так?
Код
=ЕСЛИОШИБКА(ИНДЕКС(тариф!$B$3:$P$9;ПОИСКПОЗ(A2;тариф!$A$3:$A$9;0);ПОИСКПОЗ(ТЕКСТ(B2;B2);тариф!$B$2:$P$2;0));"")
К сообщению приложен файл: 7575218.xlsx(11.4 Kb)
 
Ответить
СообщениеЗдравствуйте, так?
Код
=ЕСЛИОШИБКА(ИНДЕКС(тариф!$B$3:$P$9;ПОИСКПОЗ(A2;тариф!$A$3:$A$9;0);ПОИСКПОЗ(ТЕКСТ(B2;B2);тариф!$B$2:$P$2;0));"")

Автор - OlehandR
Дата добавления - 22.01.2023 в 02:32
bmv98rus Дата: Воскресенье, 22.01.2023, 10:02 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3974
Репутация: 747 ±
Замечаний: 0% ±

Excel 2013/2016
А что с 16, 17 ... палетами?
Если таковых не может быть то
Код
=IF(OR(A2="";B2=0);"";INDEX(тариф!$B$3:$P$9;MATCH(расчет!A2;тариф!$A$3:$A$9;);B2))

А если тариф как за 15, то модифицируем вариант OlehandR,
Код
=IFERROR(INDEX(тариф!$B$3:$P$9;MATCH(A2;тариф!$A$3:$A$9;0);MATCH(B2&"";тариф!$B$2:$P$2));"")


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеА что с 16, 17 ... палетами?
Если таковых не может быть то
Код
=IF(OR(A2="";B2=0);"";INDEX(тариф!$B$3:$P$9;MATCH(расчет!A2;тариф!$A$3:$A$9;);B2))

А если тариф как за 15, то модифицируем вариант OlehandR,
Код
=IFERROR(INDEX(тариф!$B$3:$P$9;MATCH(A2;тариф!$A$3:$A$9;0);MATCH(B2&"";тариф!$B$2:$P$2));"")

Автор - bmv98rus
Дата добавления - 22.01.2023 в 10:02
irinasuhoveewa Дата: Воскресенье, 22.01.2023, 11:57 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

OlehandR, находит значение стоимости в таблице, нужно, чтоб еще это значение умножалось на это количество паллет.
Т.е. нашлась стоимость за доставку от 4 пал* эту стоимость на 4. В Краснодар доставка от 4 пал будет стоить 437 руб за каждый, общая стоимость за доставку будет 4*437=1748
К сообщению приложен файл: 9817942.xlsx(11.8 Kb)
 
Ответить
СообщениеOlehandR, находит значение стоимости в таблице, нужно, чтоб еще это значение умножалось на это количество паллет.
Т.е. нашлась стоимость за доставку от 4 пал* эту стоимость на 4. В Краснодар доставка от 4 пал будет стоить 437 руб за каждый, общая стоимость за доставку будет 4*437=1748

Автор - irinasuhoveewa
Дата добавления - 22.01.2023 в 11:57
irinasuhoveewa Дата: Воскресенье, 22.01.2023, 12:06 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

bmv98rus, количество паллет до 27 и список город может пополняться. Какая формула будет более практично? и также нужно чтобы полученное число, умножалось на указанное количество паллет.
 
Ответить
Сообщениеbmv98rus, количество паллет до 27 и список город может пополняться. Какая формула будет более практично? и также нужно чтобы полученное число, умножалось на указанное количество паллет.

Автор - irinasuhoveewa
Дата добавления - 22.01.2023 в 12:06
Egyptian Дата: Воскресенье, 22.01.2023, 15:04 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 442
Репутация: 146 ±
Замечаний: 0% ±

Excel 2013/2016
irinasuhoveewa,
Так пойдет?
Код
=IFERROR(B2*VLOOKUP(A2;тариф!$A$3:$AB$9;MATCH(B2&"";тариф!$A$2:$AB$2;0););"")
К сообщению приложен файл: 1946847.xlsx(11.3 Kb)
 
Ответить
Сообщениеirinasuhoveewa,
Так пойдет?
Код
=IFERROR(B2*VLOOKUP(A2;тариф!$A$3:$AB$9;MATCH(B2&"";тариф!$A$2:$AB$2;0););"")

Автор - Egyptian
Дата добавления - 22.01.2023 в 15:04
irinasuhoveewa Дата: Воскресенье, 22.01.2023, 15:33 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, да, все работает отлично! спасибо большое! :D


Сообщение отредактировал irinasuhoveewa - Воскресенье, 22.01.2023, 15:34
 
Ответить
СообщениеEgyptian, да, все работает отлично! спасибо большое! :D

Автор - irinasuhoveewa
Дата добавления - 22.01.2023 в 15:33
bmv98rus Дата: Воскресенье, 22.01.2023, 15:48 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3974
Репутация: 747 ±
Замечаний: 0% ±

Excel 2013/2016
Цитата irinasuhoveewa, 22.01.2023 в 11:57, в сообщении № 4 ()
Т.е. нашлась стоимость за доставку от 4 пал* эту стоимость на 4. В Краснодар доставка от 4 пал будет стоить 437 руб за каждый, общая стоимость за доставку будет 4*437=1748
Уверены? в вашей таблице идет цена с учетом скидки за количество палет и не за 1 палету.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Цитата irinasuhoveewa, 22.01.2023 в 11:57, в сообщении № 4 ()
Т.е. нашлась стоимость за доставку от 4 пал* эту стоимость на 4. В Краснодар доставка от 4 пал будет стоить 437 руб за каждый, общая стоимость за доставку будет 4*437=1748
Уверены? в вашей таблице идет цена с учетом скидки за количество палет и не за 1 палету.

Автор - bmv98rus
Дата добавления - 22.01.2023 в 15:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как вычислить значение при нескольких условия? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!