Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнять автоматически значение из соседней таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнять автоматически значение из соседней таблицы (Формулы/Formulas)
Заполнять автоматически значение из соседней таблицы
Oh_Nick Дата: Понедельник, 13.03.2023, 22:41 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
Доброго времени суток!

Подскажите, пожалуйста, формулу, чтобы из соседней таблицы брался HS CODE и % Пошлины (вставлялось в колонки F и G из колонок B и C)
К сообщению приложен файл: 111.xlsx (15.0 Kb)
 
Ответить
СообщениеДоброго времени суток!

Подскажите, пожалуйста, формулу, чтобы из соседней таблицы брался HS CODE и % Пошлины (вставлялось в колонки F и G из колонок B и C)

Автор - Oh_Nick
Дата добавления - 13.03.2023 в 22:41
bigor Дата: Понедельник, 13.03.2023, 22:54 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1029
Репутация: 195 ±
Замечаний: 0% ±

нет
Доброго

в Е2 и протянуть вправо
Код
=INDEX($A$2:$C$689;MATCH($I2;$A$2:$A$689;0);COLUMN(A1))
 
Ответить
СообщениеДоброго

в Е2 и протянуть вправо
Код
=INDEX($A$2:$C$689;MATCH($I2;$A$2:$A$689;0);COLUMN(A1))

Автор - bigor
Дата добавления - 13.03.2023 в 22:54
Oh_Nick Дата: Понедельник, 13.03.2023, 22:58 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
bigor, тогда собьется выпадающий список в I2, нельзя будет писать слово и чтобы список получался в колонке E
 
Ответить
Сообщениеbigor, тогда собьется выпадающий список в I2, нельзя будет писать слово и чтобы список получался в колонке E

Автор - Oh_Nick
Дата добавления - 13.03.2023 в 22:58
Oh_Nick Дата: Понедельник, 13.03.2023, 23:08 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
bigor, сейчас в E подтягиваются по любому слову из I2. Условно вводишь Bubble и дает все варианты, вводишь Болт и тоже все. Осталось только , чтобы еще подтягивались HS CODE и пошлина...
 
Ответить
Сообщениеbigor, сейчас в E подтягиваются по любому слову из I2. Условно вводишь Bubble и дает все варианты, вводишь Болт и тоже все. Осталось только , чтобы еще подтягивались HS CODE и пошлина...

Автор - Oh_Nick
Дата добавления - 13.03.2023 в 23:08
DrMini Дата: Вторник, 14.03.2023, 07:16 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1575
Репутация: 180 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
чтобы еще подтягивались HS CODE и пошлина...

Вроде так
в столбец F:
Код
=ЕСЛИОШИБКА(ВПР($E2;$A$2:$C$38;2;0);"")

в столбец G:
Код
=ЕСЛИОШИБКА(ВПР($E2;$A$2:$C$38;3;0);"")
К сообщению приложен файл: 8709496.xlsx (15.4 Kb)
 
Ответить
Сообщение
чтобы еще подтягивались HS CODE и пошлина...

Вроде так
в столбец F:
Код
=ЕСЛИОШИБКА(ВПР($E2;$A$2:$C$38;2;0);"")

в столбец G:
Код
=ЕСЛИОШИБКА(ВПР($E2;$A$2:$C$38;3;0);"")

Автор - DrMini
Дата добавления - 14.03.2023 в 07:16
Oh_Nick Дата: Вторник, 14.03.2023, 08:18 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
DrMini, спасибо огромное, супер, работает)
 
Ответить
СообщениеDrMini, спасибо огромное, супер, работает)

Автор - Oh_Nick
Дата добавления - 14.03.2023 в 08:18
Oh_Nick Дата: Вторник, 25.07.2023, 11:35 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
Всем добрый день!

Поставил другую версию эксель и на ней не поддерживается формула FILTER. Подскажите, пожалуйста, как поправить, чтобы формулы в колонке Е ,в ячейке I2 работали и в выпадающем списке I2 работали?
К сообщению приложен файл: kod_tn_vehd.xlsx (83.3 Kb)
 
Ответить
СообщениеВсем добрый день!

Поставил другую версию эксель и на ней не поддерживается формула FILTER. Подскажите, пожалуйста, как поправить, чтобы формулы в колонке Е ,в ячейке I2 работали и в выпадающем списке I2 работали?

Автор - Oh_Nick
Дата добавления - 25.07.2023 в 11:35
Serge_007 Дата: Вторник, 25.07.2023, 12:26 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 16455
Репутация: 2746 ±
Замечаний: ±

Excel 2016
Код
=ИНДЕКС(A$2:A$321;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(I$2;A$2:A$321));СТРОКА($1:$320));СТРОКА(A1)))
К сообщению приложен файл: 20230725_oh_nick.xls (466.5 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ИНДЕКС(A$2:A$321;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(I$2;A$2:A$321));СТРОКА($1:$320));СТРОКА(A1)))

Автор - Serge_007
Дата добавления - 25.07.2023 в 12:26
Oh_Nick Дата: Вторник, 25.07.2023, 12:43 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
Serge_007, спасибо большое!
 
Ответить
СообщениеSerge_007, спасибо большое!

Автор - Oh_Nick
Дата добавления - 25.07.2023 в 12:43
Oh_Nick Дата: Вторник, 25.07.2023, 13:38 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
Serge_007, а как скорректировать, чтобы можно было строчки добавлять ниже?

Меняю диапазон например
Код
=IFERROR(INDEX(A$2:A$400;SMALL(IF(ISNUMBER(SEARCH(H$2;A$2:A$400));ROW($1:$400));ROW(A1)));" ")


и все пропадает..
 
Ответить
СообщениеSerge_007, а как скорректировать, чтобы можно было строчки добавлять ниже?

Меняю диапазон например
Код
=IFERROR(INDEX(A$2:A$400;SMALL(IF(ISNUMBER(SEARCH(H$2;A$2:A$400));ROW($1:$400));ROW(A1)));" ")


и все пропадает..

Автор - Oh_Nick
Дата добавления - 25.07.2023 в 13:38
Serge_007 Дата: Вторник, 25.07.2023, 13:53 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 16455
Репутация: 2746 ±
Замечаний: ±

Excel 2016
Если в ИНДЕКС и в ПОИСК диапазон A$2:A$400, то в СТРОКА - $1:$399


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЕсли в ИНДЕКС и в ПОИСК диапазон A$2:A$400, то в СТРОКА - $1:$399

Автор - Serge_007
Дата добавления - 25.07.2023 в 13:53
Oh_Nick Дата: Вторник, 25.07.2023, 14:01 | Сообщение № 12
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
Serge_007,

Поправил, но все равно все ушло...
К сообщению приложен файл: 6417147.xls (472.0 Kb)
 
Ответить
СообщениеSerge_007,

Поправил, но все равно все ушло...

Автор - Oh_Nick
Дата добавления - 25.07.2023 в 14:01
Serge_007 Дата: Вторник, 25.07.2023, 14:15 | Сообщение № 13
Группа: Админы
Ранг: Местный житель
Сообщений: 16455
Репутация: 2746 ±
Замечаний: ±

Excel 2016
Формулы массива вводятся нажатием Ctrl+Shift+Enter


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеФормулы массива вводятся нажатием Ctrl+Shift+Enter

Автор - Serge_007
Дата добавления - 25.07.2023 в 14:15
Oh_Nick Дата: Вторник, 25.07.2023, 14:22 | Сообщение № 14
Группа: Проверенные
Ранг: Обитатель
Сообщений: 445
Репутация: 8 ±
Замечаний: 20% ±

Excel 2019
Serge_007, все понял, спасибо!
 
Ответить
СообщениеSerge_007, все понял, спасибо!

Автор - Oh_Nick
Дата добавления - 25.07.2023 в 14:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнять автоматически значение из соседней таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!