Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вытащить все данные по строчно из таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вытащить все данные по строчно из таблицы (Формулы/Formulas)
Вытащить все данные по строчно из таблицы
Alexxx4177 Дата: Пятница, 05.01.2024, 10:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Понадобилось Вытащить на отдельный лист, данные с другого листа, по строчно, по поиску определенного значения.
То есть в таблице допустим Имя дата рождения город прописка. Мне надо на другой лист вытащить допустим всех Александров и чтоб подтянулись все их значения со столбцов дата рождения, город, прописка и тп и тд.
То есть я в выборке должен вписывать формулы по поиску имени в таблице на другом листе, а данные выцепляться должны со всех столбцов поочередно. Через ИНДЕКС или ПОИСКПОЗ выцепляет только первого александра и все.
Файл для примера во вложении. Помогите пожалуйста.
К сообщению приложен файл: imena.xlsx (9.7 Kb)
 
Ответить
СообщениеДобрый день. Понадобилось Вытащить на отдельный лист, данные с другого листа, по строчно, по поиску определенного значения.
То есть в таблице допустим Имя дата рождения город прописка. Мне надо на другой лист вытащить допустим всех Александров и чтоб подтянулись все их значения со столбцов дата рождения, город, прописка и тп и тд.
То есть я в выборке должен вписывать формулы по поиску имени в таблице на другом листе, а данные выцепляться должны со всех столбцов поочередно. Через ИНДЕКС или ПОИСКПОЗ выцепляет только первого александра и все.
Файл для примера во вложении. Помогите пожалуйста.

Автор - Alexxx4177
Дата добавления - 05.01.2024 в 10:57
AlexM Дата: Пятница, 05.01.2024, 11:48 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4379
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
В В1 выпадающий список имен.
Формулы массива
К сообщению приложен файл: imena_1.xlsx (10.6 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 05.01.2024, 11:51
 
Ответить
СообщениеВ В1 выпадающий список имен.
Формулы массива

Автор - AlexM
Дата добавления - 05.01.2024 в 11:48
i691198 Дата: Пятница, 05.01.2024, 12:36 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 82 ±
Замечаний: 0% ±

Добрый день. Еще один вариант. Формула обычная, немассивная. Имя поиска для выборки в H2.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица!B$3:B$200;АГРЕГАТ(15;6;СТРОКА($A$1:$A$200)/($H$2=Таблица!$B$3:$B$200);СТРОКА(A1)));"")
К сообщению приложен файл: imena2.xlsx (12.0 Kb)
 
Ответить
СообщениеДобрый день. Еще один вариант. Формула обычная, немассивная. Имя поиска для выборки в H2.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица!B$3:B$200;АГРЕГАТ(15;6;СТРОКА($A$1:$A$200)/($H$2=Таблица!$B$3:$B$200);СТРОКА(A1)));"")

Автор - i691198
Дата добавления - 05.01.2024 в 12:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вытащить все данные по строчно из таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!