Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как отсортировать разные значения в заданном порядке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как отсортировать разные значения в заданном порядке (Формулы/Formulas)
как отсортировать разные значения в заданном порядке
smallermaloy Дата: Четверг, 28.03.2024, 15:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

19
Добрый день, подскажите как отсортировать разные значения в нужном порядке? надеюсь образец понятен, пытался через ИНДЕКС и ПОИСКПОЗ, но увы не получается
К сообщению приложен файл: sortirovka_v_nuzhnom_porjadke.xlsx (11.1 Kb)


Csy

Сообщение отредактировал smallermaloy - Четверг, 28.03.2024, 15:34
 
Ответить
СообщениеДобрый день, подскажите как отсортировать разные значения в нужном порядке? надеюсь образец понятен, пытался через ИНДЕКС и ПОИСКПОЗ, но увы не получается

Автор - smallermaloy
Дата добавления - 28.03.2024 в 15:34
and_evg Дата: Четверг, 28.03.2024, 15:42 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 78 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
Если правильно понял то через
Код
=ГПР(R5;$B$6:$P$8;2;ЛОЖЬ)
К сообщению приложен файл: 1715298.xlsx (11.2 Kb)
 
Ответить
СообщениеДобрый день.
Если правильно понял то через
Код
=ГПР(R5;$B$6:$P$8;2;ЛОЖЬ)

Автор - and_evg
Дата добавления - 28.03.2024 в 15:42
smallermaloy Дата: Четверг, 28.03.2024, 15:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

19
and_evg, нет справа в блоках должны быть цифры с 1-5 потом 6-10 и 11-15, но в порядке как в исходнике


Csy
 
Ответить
Сообщениеand_evg, нет справа в блоках должны быть цифры с 1-5 потом 6-10 и 11-15, но в порядке как в исходнике

Автор - smallermaloy
Дата добавления - 28.03.2024 в 15:46
DrMini Дата: Четверг, 28.03.2024, 16:34 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте and_evg,
А если так:
Код
=СУММПРОИЗВ(($B$6:$P$6=R$5)*$B7:$P7)
К сообщению приложен файл: 3230213.xlsx (12.2 Kb)


Сообщение отредактировал DrMini - Пятница, 29.03.2024, 06:34
 
Ответить
СообщениеЗдравствуйте and_evg,
А если так:
Код
=СУММПРОИЗВ(($B$6:$P$6=R$5)*$B7:$P7)

Автор - DrMini
Дата добавления - 28.03.2024 в 16:34
Nic70y Дата: Четверг, 28.03.2024, 16:46 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$P$8;НАИМЕНЬШИЙ(ЕСЛИ(($B$6:$P$8<=$V$5)*($B$6:$P$8>=$R$5);СТРОКА($B$6:$P$8));СТОЛБЕЦ(A1)+(СТРОКА(A1)-1)*5);ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(($B$6:$P$8<=$V$5)*($B$6:$P$8>=$R$5);СТРОКА($B$6:$P$8)+СТОЛБЕЦ($B$6:$P$8)/1000);СТОЛБЕЦ(A1)+(СТРОКА(A1)-1)*5);1)*1000;));"")
К сообщению приложен файл: 48.xlsx (13.1 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Четверг, 28.03.2024, 17:07
 
Ответить
Сообщениеформула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$P$8;НАИМЕНЬШИЙ(ЕСЛИ(($B$6:$P$8<=$V$5)*($B$6:$P$8>=$R$5);СТРОКА($B$6:$P$8));СТОЛБЕЦ(A1)+(СТРОКА(A1)-1)*5);ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(($B$6:$P$8<=$V$5)*($B$6:$P$8>=$R$5);СТРОКА($B$6:$P$8)+СТОЛБЕЦ($B$6:$P$8)/1000);СТОЛБЕЦ(A1)+(СТРОКА(A1)-1)*5);1)*1000;));"")

Автор - Nic70y
Дата добавления - 28.03.2024 в 16:46
smallermaloy Дата: Четверг, 28.03.2024, 17:46 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

19
Nic70y, огромное спасибо, Ваш вариант то что нужно!


Csy
 
Ответить
СообщениеNic70y, огромное спасибо, Ваш вариант то что нужно!

Автор - smallermaloy
Дата добавления - 28.03.2024 в 17:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как отсортировать разные значения в заданном порядке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!