Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Свод в одну таблицу из других таблиц с сортировкой - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Свод в одну таблицу из других таблиц с сортировкой (Формулы/Formulas)
Свод в одну таблицу из других таблиц с сортировкой
AlKo Дата: Понедельник, 01.04.2024, 11:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2021
Здравствуйте!
Помогите, пожалуйста, разобраться.
Есть массив данных (в примере, чтобы было проще, - три таблицы по 10 строк в 3 столбца, не все строки
заполнены, но периодичность 10 строк сохраняется. На самом деле исходных таблиц больше и периодичность другая).
Нужно создать сводную таблицу, в которой данные трёх таблиц будут отсортированы по
значению в их первых столбцах (в примере - это дата).
Как делаю:
1. С помощью НАИМЕНЬШИЙ(...) заполняю в итоговой таблице все даты в порядке возрастания.
2. С помощью ПОИСКПОЗ(...) по дате из исходного массива выбираю значения остальных столбцов.
Проблема: если дата одинаковая, то ПОИСКПОЗ(...) берет первое попавшееся
(верхнее) значение и для всех строк с такой датой его дублирует.
В примере есть исходные таблицы, желаемый результат и то, что у меня получается.
Буду признателен за помощь!
К сообщению приложен файл: sortirovka.xlsx (12.4 Kb)


Я только спросить

Сообщение отредактировал AlKo - Понедельник, 01.04.2024, 11:44
 
Ответить
СообщениеЗдравствуйте!
Помогите, пожалуйста, разобраться.
Есть массив данных (в примере, чтобы было проще, - три таблицы по 10 строк в 3 столбца, не все строки
заполнены, но периодичность 10 строк сохраняется. На самом деле исходных таблиц больше и периодичность другая).
Нужно создать сводную таблицу, в которой данные трёх таблиц будут отсортированы по
значению в их первых столбцах (в примере - это дата).
Как делаю:
1. С помощью НАИМЕНЬШИЙ(...) заполняю в итоговой таблице все даты в порядке возрастания.
2. С помощью ПОИСКПОЗ(...) по дате из исходного массива выбираю значения остальных столбцов.
Проблема: если дата одинаковая, то ПОИСКПОЗ(...) берет первое попавшееся
(верхнее) значение и для всех строк с такой датой его дублирует.
В примере есть исходные таблицы, желаемый результат и то, что у меня получается.
Буду признателен за помощь!

Автор - AlKo
Дата добавления - 01.04.2024 в 11:28
Nic70y Дата: Понедельник, 01.04.2024, 11:51 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
del
не верно, надо доработать


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 01.04.2024, 11:56
 
Ответить
Сообщениеdel
не верно, надо доработать

Автор - Nic70y
Дата добавления - 01.04.2024 в 11:51
AlKo Дата: Понедельник, 01.04.2024, 12:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2021
На сколько я понимаю, в формуле 10 - это периодичность повторения моих исходных таблиц, а 3 - количество строк до начала первой из них.
Благодарю!

P.S. Жду доработки :D


Я только спросить

Сообщение отредактировал AlKo - Понедельник, 01.04.2024, 12:06
 
Ответить
СообщениеНа сколько я понимаю, в формуле 10 - это периодичность повторения моих исходных таблиц, а 3 - количество строк до начала первой из них.
Благодарю!

P.S. Жду доработки :D

Автор - AlKo
Дата добавления - 01.04.2024 в 12:05
Nic70y Дата: Понедельник, 01.04.2024, 12:08 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=ЕСЛИ($F3<>"";ИНДЕКС(B$1:B$29;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$A$29=$F3;СТРОКА($A$3:$A$29));СТРОКА(A1)-ПОИСКПОЗ($F3;$F$3:$F3;)+1));"")

[p.s.]хотя я бы не использовал формулы, а просто отсортировал таблицу по дате[/p.s.]
К сообщению приложен файл: 146_1.xlsx (12.5 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 01.04.2024, 12:11
 
Ответить
Сообщениеформула массива
Код
=ЕСЛИ($F3<>"";ИНДЕКС(B$1:B$29;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$A$29=$F3;СТРОКА($A$3:$A$29));СТРОКА(A1)-ПОИСКПОЗ($F3;$F$3:$F3;)+1));"")

[p.s.]хотя я бы не использовал формулы, а просто отсортировал таблицу по дате[/p.s.]

Автор - Nic70y
Дата добавления - 01.04.2024 в 12:08
AlKo Дата: Понедельник, 01.04.2024, 12:20 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2021
Благодарю! Буду сейчас разбираться.
На P.S. - Исходные таблицы подтягиваются с других листов, где они могут добавляться/удаляться или изменяться. А при переключении на лист со сводной таблицей всё должно автоматом уже свестись и отсортироваться в такой вот календарь без лишних нажатий (лень нажимать ещё что-то :) )


Я только спросить
 
Ответить
СообщениеБлагодарю! Буду сейчас разбираться.
На P.S. - Исходные таблицы подтягиваются с других листов, где они могут добавляться/удаляться или изменяться. А при переключении на лист со сводной таблицей всё должно автоматом уже свестись и отсортироваться в такой вот календарь без лишних нажатий (лень нажимать ещё что-то :) )

Автор - AlKo
Дата добавления - 01.04.2024 в 12:20
Gustav Дата: Понедельник, 01.04.2024, 18:36 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2742
Репутация: 1137 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
AlKo, у Вас в профиле указана версия Excel - 2021. Вроде как в ней уже должна быть доступна функция СОРТ. Проверьте! С ней всё будет попроще, без выкрутасов через более древние функции поиска и ранжирования. И полегче для понимания.


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеAlKo, у Вас в профиле указана версия Excel - 2021. Вроде как в ней уже должна быть доступна функция СОРТ. Проверьте! С ней всё будет попроще, без выкрутасов через более древние функции поиска и ранжирования. И полегче для понимания.

Автор - Gustav
Дата добавления - 01.04.2024 в 18:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Свод в одну таблицу из других таблиц с сортировкой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!