Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор в зависимости от месяца без учёта числа месяца - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор в зависимости от месяца без учёта числа месяца (Формулы/Formulas)
Выбор в зависимости от месяца без учёта числа месяца
DrMini Дата: Суббота, 04.05.2024, 12:21 | Сообщение № 1
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте форумчане и гости форума.
Нужно подставить фамилию в зависимости от названия листа и даты вступления в должность.
Использую вот такую формулу:
Код
=ИНДЕКС(ФИО!D2:D7;ПОИСКПОЗ(--(ПСТР(ЯЧЕЙКА("имяфайла";A1);НАЙТИ("]";ЯЧЕЙКА("имяфайла";A1))+1;20)&ФИО!A1);ФИО!C2:C7))

Надо чтобы при выборе не учитывалось число вступления в должность. Здесь же привязка к 1 числу каждого месяца.
В файле сделал, как есть и как надо.
К сообщению приложен файл: familija.xlsx (14.3 Kb)
 
Ответить
СообщениеЗдравствуйте форумчане и гости форума.
Нужно подставить фамилию в зависимости от названия листа и даты вступления в должность.
Использую вот такую формулу:
Код
=ИНДЕКС(ФИО!D2:D7;ПОИСКПОЗ(--(ПСТР(ЯЧЕЙКА("имяфайла";A1);НАЙТИ("]";ЯЧЕЙКА("имяфайла";A1))+1;20)&ФИО!A1);ФИО!C2:C7))

Надо чтобы при выборе не учитывалось число вступления в должность. Здесь же привязка к 1 числу каждого месяца.
В файле сделал, как есть и как надо.

Автор - DrMini
Дата добавления - 04.05.2024 в 12:21
AlexM Дата: Суббота, 04.05.2024, 12:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4512
Репутация: 1128 ±
Замечаний: 0% ±

Excel 2003
Код
=ВПР(КОНМЕСЯЦА(1&ПСТР(ЯЧЕЙКА("имяфайла";A1);ПОИСК("]";ЯЧЕЙКА("имяфайла";A1))+1;9);0);ФИО!C2:D13;2)
К сообщению приложен файл: familija_1.xlsx (13.6 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Суббота, 04.05.2024, 12:46
 
Ответить
Сообщение
Код
=ВПР(КОНМЕСЯЦА(1&ПСТР(ЯЧЕЙКА("имяфайла";A1);ПОИСК("]";ЯЧЕЙКА("имяфайла";A1))+1;9);0);ФИО!C2:D13;2)

Автор - AlexM
Дата добавления - 04.05.2024 в 12:44
DrMini Дата: Суббота, 04.05.2024, 12:50 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Алексей, большое спасибо. То, что нужно.
 
Ответить
СообщениеАлексей, большое спасибо. То, что нужно.

Автор - DrMini
Дата добавления - 04.05.2024 в 12:50
AlexM Дата: Суббота, 04.05.2024, 12:53 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4512
Репутация: 1128 ±
Замечаний: 0% ±

Excel 2003
Если год брать с первого листа
Код
=ВПР(КОНМЕСЯЦА(1&ПСТР(ЯЧЕЙКА("имяфайла";A1);ПОИСК("]";ЯЧЕЙКА("имяфайла";A1))+1;9)&ФИО!A1;0);ФИО!C2:D13;2)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕсли год брать с первого листа
Код
=ВПР(КОНМЕСЯЦА(1&ПСТР(ЯЧЕЙКА("имяфайла";A1);ПОИСК("]";ЯЧЕЙКА("имяфайла";A1))+1;9)&ФИО!A1;0);ФИО!C2:D13;2)

Автор - AlexM
Дата добавления - 04.05.2024 в 12:53
DrMini Дата: Суббота, 04.05.2024, 13:03 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
год брать с первого листа

Спасибо за второй вариант. Так даже лучше.
 
Ответить
Сообщение
год брать с первого листа

Спасибо за второй вариант. Так даже лучше.

Автор - DrMini
Дата добавления - 04.05.2024 в 13:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор в зависимости от месяца без учёта числа месяца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!