Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Фомирование нескольких списков из общего списка по критериям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Фомирование нескольких списков из общего списка по критериям
illyxa Дата: Пятница, 17.05.2024, 12:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2013
Всем доброго времени суток! Помогите с формулой или макросом. Прикладываю пример:
1) копирование из общего списка в списки (Мира, Республики) по адресу: Мира в Мира; Республики в республики;
2) если в общем списке стоит - посещён, то с листов Мира или Республики удалить, но в общем списке должно остаться.
К сообщению приложен файл: 2840875.xlsx (12.1 Kb)
 
Ответить
СообщениеВсем доброго времени суток! Помогите с формулой или макросом. Прикладываю пример:
1) копирование из общего списка в списки (Мира, Республики) по адресу: Мира в Мира; Республики в республики;
2) если в общем списке стоит - посещён, то с листов Мира или Республики удалить, но в общем списке должно остаться.

Автор - illyxa
Дата добавления - 17.05.2024 в 12:06
Pelena Дата: Пятница, 17.05.2024, 17:47 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19242
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
Здравствуйте.
Вариант формулами в файле. Но если листов много, то лучше макросом
К сообщению приложен файл: 1277473.xlsx (15.5 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вариант формулами в файле. Но если листов много, то лучше макросом

Автор - Pelena
Дата добавления - 17.05.2024 в 17:47
illyxa Дата: Вторник, 21.05.2024, 18:33 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2013
Приветствую Pelena, ! Вроде разобрался малость, но идет привязка к порядковому номеру (я так понимаю) как оставить его тоже не изменным? листов будет около 5, но массив обрабатывать они будут из общего списка более 10к позиций.
 
Ответить
СообщениеПриветствую Pelena, ! Вроде разобрался малость, но идет привязка к порядковому номеру (я так понимаю) как оставить его тоже не изменным? листов будет около 5, но массив обрабатывать они будут из общего списка более 10к позиций.

Автор - illyxa
Дата добавления - 21.05.2024 в 18:33
i691198 Дата: Вторник, 21.05.2024, 21:46 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 237
Репутация: 88 ±
Замечаний: 0% ±

Вариант с другой формулой.
К сообщению приложен файл: sample1.xlsx (13.7 Kb)
 
Ответить
СообщениеВариант с другой формулой.

Автор - i691198
Дата добавления - 21.05.2024 в 21:46
gling Дата: Вторник, 21.05.2024, 22:03 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2527
Репутация: 679 ±
Замечаний: 0% ±

2010
Вариант формулой массива в файле
Код
=ЕСЛИОШИБКА(ИНДЕКС('Общий список'!$A$1:$D$324;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК(ПСТР(ЯЧЕЙКА("имяфайла";$A$1);ПОИСК("]";ЯЧЕЙКА("имяфайла";$A$1))+1;99);'Общий список'!$C$2:$C$16);СТРОКА('Общий список'!$C$2:$C$16););"");СТРОКА(A1));СТОЛБЕЦ());"")
К сообщению приложен файл: 4860313.xlsx (15.2 Kb)


ЯД-41001506838083
 
Ответить
СообщениеВариант формулой массива в файле
Код
=ЕСЛИОШИБКА(ИНДЕКС('Общий список'!$A$1:$D$324;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК(ПСТР(ЯЧЕЙКА("имяфайла";$A$1);ПОИСК("]";ЯЧЕЙКА("имяфайла";$A$1))+1;99);'Общий список'!$C$2:$C$16);СТРОКА('Общий список'!$C$2:$C$16););"");СТРОКА(A1));СТОЛБЕЦ());"")

Автор - gling
Дата добавления - 21.05.2024 в 22:03
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!