Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ИНДЕКС ПОИСКПОЗ учет смен - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
ИНДЕКС ПОИСКПОЗ учет смен
Sharpelbow2508 Дата: Понедельник, 27.05.2024, 16:03 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2016
Добрый день! Подскажите пожалуйста где ошибка в формуле ? или она не до конца составлена, не совсем понимаю.

На лист 2 представлены фамилии сотрудников и даты когда работали. Ячейки O и Q. Одной датой может отмечаться несколько заданий. Условия для листа "табели" если, есть хоть одно совпадение по дате и Фамилии - то ставиться 1, если нет то "-".

Но почему-то не по всем датам на листе "табели" отмечается, что сотрудник работал, а на листе 2 и дата и фамилия есть. И в файле 11.01.24 показывает 1 по сотруднику. А 01.05.2024 - нет
К сообщению приложен файл: grafiki_prosmotr.xlsx (15.2 Kb)
 
Ответить
СообщениеДобрый день! Подскажите пожалуйста где ошибка в формуле ? или она не до конца составлена, не совсем понимаю.

На лист 2 представлены фамилии сотрудников и даты когда работали. Ячейки O и Q. Одной датой может отмечаться несколько заданий. Условия для листа "табели" если, есть хоть одно совпадение по дате и Фамилии - то ставиться 1, если нет то "-".

Но почему-то не по всем датам на листе "табели" отмечается, что сотрудник работал, а на листе 2 и дата и фамилия есть. И в файле 11.01.24 показывает 1 по сотруднику. А 01.05.2024 - нет

Автор - Sharpelbow2508
Дата добавления - 27.05.2024 в 16:03
Nic70y Дата: Понедельник, 27.05.2024, 16:11 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8832
Репутация: 2301 ±
Замечаний: 0% ±

Excel 2010
ПОИСКПОЗ ищет первое вхождение
Код
=ЕСЛИ(СЧЁТЕСЛИМН('Лист 2'!$B$11:$B$9999;$B3;'Лист 2'!$D$11:$D$9999;C$2);1;"-")
К сообщению приложен файл: 543.xlsx (15.1 Kb)


ЮMoney 41001841029809
 
Ответить
СообщениеПОИСКПОЗ ищет первое вхождение
Код
=ЕСЛИ(СЧЁТЕСЛИМН('Лист 2'!$B$11:$B$9999;$B3;'Лист 2'!$D$11:$D$9999;C$2);1;"-")

Автор - Nic70y
Дата добавления - 27.05.2024 в 16:11
bigor Дата: Понедельник, 27.05.2024, 16:18 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1138
Репутация: 216 ±
Замечаний: 0% ±

нет
Sharpelbow2508, пробуйте
Код
=TEXT(MIN(COUNTIFS('Лист 2'!$D$11:$D$39;C$2;'Лист 2'!$B$11:$B$39;$B3);1);"0; 0; ")
 
Ответить
СообщениеSharpelbow2508, пробуйте
Код
=TEXT(MIN(COUNTIFS('Лист 2'!$D$11:$D$39;C$2;'Лист 2'!$B$11:$B$39;$B3);1);"0; 0; ")

Автор - bigor
Дата добавления - 27.05.2024 в 16:18
DrMini Дата: Понедельник, 27.05.2024, 16:32 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1736
Репутация: 238 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте Sharpelbow2508,
Как вариант:
Код
=ЕСЛИ(СУММПРОИЗВ(('Лист 2'!$B$11:$B$1000=$B3)*('Лист 2'!$D$11:$D$1000=C$2));1;"-")
К сообщению приложен файл: 1786056.xlsx (18.2 Kb)
 
Ответить
СообщениеЗдравствуйте Sharpelbow2508,
Как вариант:
Код
=ЕСЛИ(СУММПРОИЗВ(('Лист 2'!$B$11:$B$1000=$B3)*('Лист 2'!$D$11:$D$1000=C$2));1;"-")

Автор - DrMini
Дата добавления - 27.05.2024 в 16:32
Sharpelbow2508 Дата: Понедельник, 27.05.2024, 16:58 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2016
Nic70y, Спасибо, работает. Понял, что можно было проще )
 
Ответить
СообщениеNic70y, Спасибо, работает. Понял, что можно было проще )

Автор - Sharpelbow2508
Дата добавления - 27.05.2024 в 16:58
Sharpelbow2508 Дата: Понедельник, 27.05.2024, 16:59 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2016
DrMini, спасибо большое
 
Ответить
СообщениеDrMini, спасибо большое

Автор - Sharpelbow2508
Дата добавления - 27.05.2024 в 16:59
Sharpelbow2508 Дата: Понедельник, 27.05.2024, 17:42 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2016
DrMini, Спасибо! Так еще лучше)
 
Ответить
СообщениеDrMini, Спасибо! Так еще лучше)

Автор - Sharpelbow2508
Дата добавления - 27.05.2024 в 17:42
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!