Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка столбца с формулой - Страница 2 - Мир MS Excel

Старая форма входа
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: китин, _Boroda_  
Сортировка столбца с формулой
Юрий_Ф Дата: Понедельник, 10.06.2024, 14:49 | Сообщение № 21
Группа: Проверенные
Ранг: Ветеран
Сообщений: 811
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
DrMini,

Всё-всё-всё! Вы - гений! Огромное спасибо! В крайнем, приложенном вами файле 1й вариант работает, как надо!
Нижайший поклон!
hands


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Понедельник, 10.06.2024, 15:12
 
Ответить
СообщениеDrMini,

Всё-всё-всё! Вы - гений! Огромное спасибо! В крайнем, приложенном вами файле 1й вариант работает, как надо!
Нижайший поклон!
hands

Автор - Юрий_Ф
Дата добавления - 10.06.2024 в 14:49
Юрий_Ф Дата: Понедельник, 10.06.2024, 15:54 | Сообщение № 22
Группа: Проверенные
Ранг: Ветеран
Сообщений: 811
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
DrMini,

Но появилась проблемка! Если я продлеваю формулы списка вниз, ниже 61й строки, данные таблички в столбцах F-H (Именинники за Июнь) исчезают!
Не подскажите в чём дело?
Я уже в формулах изменил $99 на $200 (до 200й строки продлил формулы). Ничего не помогло!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеDrMini,

Но появилась проблемка! Если я продлеваю формулы списка вниз, ниже 61й строки, данные таблички в столбцах F-H (Именинники за Июнь) исчезают!
Не подскажите в чём дело?
Я уже в формулах изменил $99 на $200 (до 200й строки продлил формулы). Ничего не помогло!

Автор - Юрий_Ф
Дата добавления - 10.06.2024 в 15:54
DrMini Дата: Понедельник, 10.06.2024, 19:29 | Сообщение № 23
Группа: Друзья
Ранг: Старожил
Сообщений: 1736
Репутация: 238 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Но появилась проблемка!

На работе сегодня беготня. Вот до дому добрался и посмотрел. На ум пришло только такое. Добавил при ошибке дату на 13 месяцев больше текущей и добавил в УФ 2 правила что бы скрыть даты больше текущего года.
По топорному конечно вышло но на большее мозгов не хватает.
Может, кто поумнее поможет.
К сообщению приложен файл: 633641777.xlsx (29.0 Kb)
 
Ответить
Сообщение
Но появилась проблемка!

На работе сегодня беготня. Вот до дому добрался и посмотрел. На ум пришло только такое. Добавил при ошибке дату на 13 месяцев больше текущей и добавил в УФ 2 правила что бы скрыть даты больше текущего года.
По топорному конечно вышло но на большее мозгов не хватает.
Может, кто поумнее поможет.

Автор - DrMini
Дата добавления - 10.06.2024 в 19:29
Юрий_Ф Дата: Понедельник, 10.06.2024, 23:01 | Сообщение № 24
Группа: Проверенные
Ранг: Ветеран
Сообщений: 811
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
DrMini,
В Вашем сообщении № 20 приложена табличка с примерами: вариант 1й и 2й.
Сейчас вы добавили в формулу ограничения 13 месяцев от даты:
Код
=ЕСЛИОШИБКА(ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ($O$2:$O$99<>"";МЕСЯЦ($O$2:$O$99)+$O$2:$O$99%%%);СТРОКА(U1));1)*10^6;);ДАТАМЕС(K$2;13))

С ней при внесении в пустые (дежурные) ячейки снизу, Именинники в июне не пропадают.
Может, добавить в 1й вариант вашей таблицы (сообщения № 20) такое же добавление.
Код
ДАТАМЕС(K$2;13))

Но я не соображу, куда его вставить.
Код
=ЕСЛИОШИБКА(ИНДЕКС($O$2:$O$99;ПОИСКПОЗ(НАИМЕНЬШИЙ(ОСТАТ($O$2:$O$99;365,25)+($O$2:$O$99="")*10000;СТРОКА(M1));ОСТАТ($O$2:$O$99;365,25);0));"")

Не посмотрите?


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеDrMini,
В Вашем сообщении № 20 приложена табличка с примерами: вариант 1й и 2й.
Сейчас вы добавили в формулу ограничения 13 месяцев от даты:
Код
=ЕСЛИОШИБКА(ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ($O$2:$O$99<>"";МЕСЯЦ($O$2:$O$99)+$O$2:$O$99%%%);СТРОКА(U1));1)*10^6;);ДАТАМЕС(K$2;13))

С ней при внесении в пустые (дежурные) ячейки снизу, Именинники в июне не пропадают.
Может, добавить в 1й вариант вашей таблицы (сообщения № 20) такое же добавление.
Код
ДАТАМЕС(K$2;13))

Но я не соображу, куда его вставить.
Код
=ЕСЛИОШИБКА(ИНДЕКС($O$2:$O$99;ПОИСКПОЗ(НАИМЕНЬШИЙ(ОСТАТ($O$2:$O$99;365,25)+($O$2:$O$99="")*10000;СТРОКА(M1));ОСТАТ($O$2:$O$99;365,25);0));"")

Не посмотрите?

Автор - Юрий_Ф
Дата добавления - 10.06.2024 в 23:01
DrMini Дата: Вторник, 11.06.2024, 04:01 | Сообщение № 25
Группа: Друзья
Ранг: Старожил
Сообщений: 1736
Репутация: 238 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
куда его вставить

Вместо кавычек в конце:
Код
=ЕСЛИОШИБКА(ИНДЕКС($O$2:$O$99;ПОИСКПОЗ(НАИМЕНЬШИЙ(ОСТАТ($O$2:$O$99;365,25)+($O$2:$O$99="")*10000;СТРОКА(M1));ОСТАТ($O$2:$O$99;365,25);0));ДАТАМЕС(K$2;13))

Я в приложенном примере
Код
ДАТАМЕС(K$2;13)
заменил на:
Код
ДАТАМЕС(СЕГОДНЯ();13)

Это для того, что бы не использовать ячейку K2 с сегодняшней датой. Если текущая дата нужна то в ячейку K2 вбиваете
Код
=СЕГОДНЯ()
К сообщению приложен файл: 9803685.xlsx (20.4 Kb)
 
Ответить
Сообщение
куда его вставить

Вместо кавычек в конце:
Код
=ЕСЛИОШИБКА(ИНДЕКС($O$2:$O$99;ПОИСКПОЗ(НАИМЕНЬШИЙ(ОСТАТ($O$2:$O$99;365,25)+($O$2:$O$99="")*10000;СТРОКА(M1));ОСТАТ($O$2:$O$99;365,25);0));ДАТАМЕС(K$2;13))

Я в приложенном примере
Код
ДАТАМЕС(K$2;13)
заменил на:
Код
ДАТАМЕС(СЕГОДНЯ();13)

Это для того, что бы не использовать ячейку K2 с сегодняшней датой. Если текущая дата нужна то в ячейку K2 вбиваете
Код
=СЕГОДНЯ()

Автор - DrMini
Дата добавления - 11.06.2024 в 04:01
DrMini Дата: Вторник, 11.06.2024, 04:45 | Сообщение № 26
Группа: Друзья
Ранг: Старожил
Сообщений: 1736
Репутация: 238 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
А может, ну их все эти заморочки.
Добавляем новый лист (назовём его например Ввод). К нему люди будут иметь полный доступ. На остальные листы ставим пароль.
И все данные без дополнительных перерасчётов сразу попадают на лист Данные в таблицу где все сортируются по месяцам и в таблицу именинников в текущем месяце. И ненужны никакие дополнительные "костыли".
Лист Данные для примера защитил без пароля.
Мне кажется так будет лучше.
ИМХО
yes
К сообщению приложен файл: 1949780.xlsx (30.5 Kb)


Сообщение отредактировал DrMini - Вторник, 11.06.2024, 04:49
 
Ответить
СообщениеА может, ну их все эти заморочки.
Добавляем новый лист (назовём его например Ввод). К нему люди будут иметь полный доступ. На остальные листы ставим пароль.
И все данные без дополнительных перерасчётов сразу попадают на лист Данные в таблицу где все сортируются по месяцам и в таблицу именинников в текущем месяце. И ненужны никакие дополнительные "костыли".
Лист Данные для примера защитил без пароля.
Мне кажется так будет лучше.
ИМХО
yes

Автор - DrMini
Дата добавления - 11.06.2024 в 04:45
Юрий_Ф Дата: Среда, 12.06.2024, 09:31 | Сообщение № 27
Группа: Проверенные
Ранг: Ветеран
Сообщений: 811
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
DrMini,

Ну и отлично! Так это то, что нужно! Ну и что, что на другом листе! Пусть будет так, как проще!
Только на листе Данные (Столбцы A-D) сортировка должна быть, как у Бороды - по числу месяца, а не по году! Как это вышло в табличке Именинники за Июнь.


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Среда, 12.06.2024, 10:49
 
Ответить
СообщениеDrMini,

Ну и отлично! Так это то, что нужно! Ну и что, что на другом листе! Пусть будет так, как проще!
Только на листе Данные (Столбцы A-D) сортировка должна быть, как у Бороды - по числу месяца, а не по году! Как это вышло в табличке Именинники за Июнь.

Автор - Юрий_Ф
Дата добавления - 12.06.2024 в 09:31
DrMini Дата: Среда, 12.06.2024, 12:30 | Сообщение № 28
Группа: Друзья
Ранг: Старожил
Сообщений: 1736
Репутация: 238 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
сортировка должна быть, как у Бороды

Ловите:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Ввод!$B$2:$B$199;ПОИСКПОЗ(НАИМЕНЬШИЙ(ОСТАТ(Ввод!$B$2:$B$199;365,25)+(Ввод!$B$2:$B$199="")*10000;СТРОКА(A1));ОСТАТ(Ввод!$B$2:$B$199;365,25);0));"")
К сообщению приложен файл: 8097245.xlsx (30.6 Kb)
 
Ответить
Сообщение
сортировка должна быть, как у Бороды

Ловите:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Ввод!$B$2:$B$199;ПОИСКПОЗ(НАИМЕНЬШИЙ(ОСТАТ(Ввод!$B$2:$B$199;365,25)+(Ввод!$B$2:$B$199="")*10000;СТРОКА(A1));ОСТАТ(Ввод!$B$2:$B$199;365,25);0));"")

Автор - DrMini
Дата добавления - 12.06.2024 в 12:30
Юрий_Ф Дата: Среда, 12.06.2024, 20:41 | Сообщение № 29
Группа: Проверенные
Ранг: Ветеран
Сообщений: 811
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
DrMini,

Умничка! Спасибо за помощь! Думаю, табличка поможет многим, это удобно!
hands


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеDrMini,

Умничка! Спасибо за помощь! Думаю, табличка поможет многим, это удобно!
hands

Автор - Юрий_Ф
Дата добавления - 12.06.2024 в 20:41
DrMini Дата: Среда, 12.06.2024, 21:26 | Сообщение № 30
Группа: Друзья
Ранг: Старожил
Сообщений: 1736
Репутация: 238 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Думаю, табличка поможет многим

Надеюсь, что так и будет.
 
Ответить
Сообщение
Думаю, табличка поможет многим

Надеюсь, что так и будет.

Автор - DrMini
Дата добавления - 12.06.2024 в 21:26
Юрий_Ф Дата: Суббота, 15.06.2024, 21:34 | Сообщение № 31
Группа: Проверенные
Ранг: Ветеран
Сообщений: 811
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
DrMini,

Гляньте ещё раз свою табличку, пожалуйста!
Строки 40 и 41, 42 и 43 дублируют друг друга. Странность в том, что на вкладке ВВОД ничего такого нет!
К сообщению приложен файл: 4209316.xlsx (30.6 Kb)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеDrMini,

Гляньте ещё раз свою табличку, пожалуйста!
Строки 40 и 41, 42 и 43 дублируют друг друга. Странность в том, что на вкладке ВВОД ничего такого нет!

Автор - Юрий_Ф
Дата добавления - 15.06.2024 в 21:34
DrMini Дата: Воскресенье, 16.06.2024, 09:33 | Сообщение № 32
Группа: Друзья
Ранг: Старожил
Сообщений: 1736
Репутация: 238 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Строки 40 и 41, 42 и 43 дублируют друг друга.

Да. Точняк. Это видимо из-за округления даты и месяца без учёта года.
Если у Вас офис поддерживает функцию
Код
=СОРТПО
тогда можно вот так попробовать.
На листе Данные в ячейку C2:
Код
=ЕСЛИОШИБКА(СОРТПО(Ввод!$B$2:$B$63;ТЕКСТ(ДР;"ММДД"));"")

На листе Ввод преобразовать в умную таблицу и создать именованный диапазон (я назвал его ДР).
Для удаления ненужных дат - просто удаляете ненужную строку из таблицы на листе Ввод.

Посмотрите. Вдруг подойдёт.
К сообщению приложен файл: 8471459.xlsx (30.2 Kb)
 
Ответить
Сообщение
Строки 40 и 41, 42 и 43 дублируют друг друга.

Да. Точняк. Это видимо из-за округления даты и месяца без учёта года.
Если у Вас офис поддерживает функцию
Код
=СОРТПО
тогда можно вот так попробовать.
На листе Данные в ячейку C2:
Код
=ЕСЛИОШИБКА(СОРТПО(Ввод!$B$2:$B$63;ТЕКСТ(ДР;"ММДД"));"")

На листе Ввод преобразовать в умную таблицу и создать именованный диапазон (я назвал его ДР).
Для удаления ненужных дат - просто удаляете ненужную строку из таблицы на листе Ввод.

Посмотрите. Вдруг подойдёт.

Автор - DrMini
Дата добавления - 16.06.2024 в 09:33
Юрий_Ф Дата: Воскресенье, 16.06.2024, 10:13 | Сообщение № 33
Группа: Проверенные
Ранг: Ветеран
Сообщений: 811
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
DrMini,

Нет, не поддерживает эту функцию: при наведении курсора на ячейку формула затенена и при попытке её копировать - исчезает.
И ещё! Сегодня обнаружил. При вводе нового имени с точно такой же датой, как у Николая (Например, Точка Петровна, 16.6.1983 г.) в маленькой таблице ИМЕНИННИКИ ЗА ИЮНЬ всё работает, как надо (появляется новое лицо Точка Петровна, 16.6.1983), а в общей таблице вместо Точки Петровны пишет ещё раз Николай, как и на предыдущей строке. Вероятно, это по той же причине. Потому что стоит только у нашей Точки Петровны поменять дату, как тут же Николай превращается в искомую Точку Петровну (я уже её ненавижу! ;) )


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Воскресенье, 16.06.2024, 11:05
 
Ответить
СообщениеDrMini,

Нет, не поддерживает эту функцию: при наведении курсора на ячейку формула затенена и при попытке её копировать - исчезает.
И ещё! Сегодня обнаружил. При вводе нового имени с точно такой же датой, как у Николая (Например, Точка Петровна, 16.6.1983 г.) в маленькой таблице ИМЕНИННИКИ ЗА ИЮНЬ всё работает, как надо (появляется новое лицо Точка Петровна, 16.6.1983), а в общей таблице вместо Точки Петровны пишет ещё раз Николай, как и на предыдущей строке. Вероятно, это по той же причине. Потому что стоит только у нашей Точки Петровны поменять дату, как тут же Николай превращается в искомую Точку Петровну (я уже её ненавижу! ;) )

Автор - Юрий_Ф
Дата добавления - 16.06.2024 в 10:13
DrMini Дата: Воскресенье, 16.06.2024, 11:04 | Сообщение № 34
Группа: Друзья
Ранг: Старожил
Сообщений: 1736
Репутация: 238 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
я уже её ненавижу!

:D
Может Вам создать новую тему и вдруг, кто-то да сделает.
И вообще наверное надо делать сводной (но мне они почему-то не нравятся) или макрос.
Я бы на макросе остановился если формулами не получится.
 
Ответить
Сообщение
я уже её ненавижу!

:D
Может Вам создать новую тему и вдруг, кто-то да сделает.
И вообще наверное надо делать сводной (но мне они почему-то не нравятся) или макрос.
Я бы на макросе остановился если формулами не получится.

Автор - DrMini
Дата добавления - 16.06.2024 в 11:04
Юрий_Ф Дата: Воскресенье, 16.06.2024, 11:10 | Сообщение № 35
Группа: Проверенные
Ранг: Ветеран
Сообщений: 811
Репутация: 1 ±
Замечаний: 60% ±

Excel 2010
DrMini,

Ну, насчёт "ненавижу", я пошутил. Ненавижу не таблицу, а Точку Петровну.
Если по формулам и УФ я уже что-то смыслю (и базовым знаниям по самоучителям, и благодаря таким знатокам, как вы на этом сайте, то в отношении макросов я - полный ноль!
По новой теме - подумаю. Вероятно, нужен какой-то новый интерес, вопрос тоже...


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеDrMini,

Ну, насчёт "ненавижу", я пошутил. Ненавижу не таблицу, а Точку Петровну.
Если по формулам и УФ я уже что-то смыслю (и базовым знаниям по самоучителям, и благодаря таким знатокам, как вы на этом сайте, то в отношении макросов я - полный ноль!
По новой теме - подумаю. Вероятно, нужен какой-то новый интерес, вопрос тоже...

Автор - Юрий_Ф
Дата добавления - 16.06.2024 в 11:10
DrMini Дата: Понедельник, 17.06.2024, 10:38 | Сообщение № 36
Группа: Друзья
Ранг: Старожил
Сообщений: 1736
Репутация: 238 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Может так подойдёт?
Парни с "Планеты" помогли.
К сообщению приложен файл: dr.xlsx (32.5 Kb)
 
Ответить
СообщениеМожет так подойдёт?
Парни с "Планеты" помогли.

Автор - DrMini
Дата добавления - 17.06.2024 в 10:38
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!