Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти предпоследнее значение в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти предпоследнее значение в столбце (Формулы/Formulas)
Найти предпоследнее значение в столбце
StewArt Дата: Среда, 25.12.2013, 13:27 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Доброго времени суток!
Помогите пожалуйста.
Как найти предпоследнее значение в столбце с фамилиями? И за два до последнего? И за три до последнего?
Как найти последнее я знаю:
Код
=ПРОСМОТР("ЯЯЯ";D2:D49)

Пример в приложении.
К сообщению приложен файл: _0003.xls(35.5 Kb)
 
Ответить
СообщениеДоброго времени суток!
Помогите пожалуйста.
Как найти предпоследнее значение в столбце с фамилиями? И за два до последнего? И за три до последнего?
Как найти последнее я знаю:
Код
=ПРОСМОТР("ЯЯЯ";D2:D49)

Пример в приложении.

Автор - StewArt
Дата добавления - 25.12.2013 в 13:27
gling Дата: Среда, 25.12.2013, 13:32 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2022
Репутация: 512 ±
Замечаний: 0% ±

2010
Думаю Индекс(поиспоз(просмотор(яяя))-1)=предпоследнее значение. сам не пробовал может я не прав.


ЯД-41001506838083

Сообщение отредактировал gling - Среда, 25.12.2013, 13:33
 
Ответить
СообщениеДумаю Индекс(поиспоз(просмотор(яяя))-1)=предпоследнее значение. сам не пробовал может я не прав.

Автор - gling
Дата добавления - 25.12.2013 в 13:32
dadmarat Дата: Среда, 25.12.2013, 13:32 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 3 ±
Замечаний: 0% ±

Excel 2010
Один из множества вариантов.
К сообщению приложен файл: 7887454.xls(34.5 Kb)


----------------
I can do it!
----------------
 
Ответить
СообщениеОдин из множества вариантов.

Автор - dadmarat
Дата добавления - 25.12.2013 в 13:32
Rustem Дата: Среда, 25.12.2013, 13:34 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 281
Репутация: 48 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(D:D;ПОИСКПОЗ("ЯЯЯЯ";D:D))


Код
=ИНДЕКС(D:D;ПОИСКПОЗ("ЯЯЯЯ";D:D)-1)

и т.д.


WMR: R183220163895

Сообщение отредактировал Rustem - Среда, 25.12.2013, 13:35
 
Ответить
Сообщение
Код
=ИНДЕКС(D:D;ПОИСКПОЗ("ЯЯЯЯ";D:D))


Код
=ИНДЕКС(D:D;ПОИСКПОЗ("ЯЯЯЯ";D:D)-1)

и т.д.

Автор - Rustem
Дата добавления - 25.12.2013 в 13:34
Pelena Дата: Среда, 25.12.2013, 13:36 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 15405
Репутация: 3370 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Ещё пара вариантов
К сообщению приложен файл: 4929468.xls(35.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё пара вариантов

Автор - Pelena
Дата добавления - 25.12.2013 в 13:36
StewArt Дата: Среда, 25.12.2013, 13:59 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Спасибо вам, Dadmarat, Rustem, Pelena и Gling!
Работает!
Я хотел повысить вам репутацию , но у меня пишет что Форма заполнена неправильно :o
 
Ответить
СообщениеСпасибо вам, Dadmarat, Rustem, Pelena и Gling!
Работает!
Я хотел повысить вам репутацию , но у меня пишет что Форма заполнена неправильно :o

Автор - StewArt
Дата добавления - 25.12.2013 в 13:59
_Boroda_ Дата: Среда, 25.12.2013, 14:11 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15768
Репутация: 6152 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
и еще
Код
=ИНДЕКС(D$2:D$25;СЧЁТЗ(D2:D$25))

в F4 и тянем вниз


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеи еще
Код
=ИНДЕКС(D$2:D$25;СЧЁТЗ(D2:D$25))

в F4 и тянем вниз

Автор - _Boroda_
Дата добавления - 25.12.2013 в 14:11
StewArt Дата: Среда, 25.12.2013, 15:29 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Спасибо Знатокам! :)
 
Ответить
СообщениеСпасибо Знатокам! :)

Автор - StewArt
Дата добавления - 25.12.2013 в 15:29
AleksFin Дата: Пятница, 13.09.2019, 10:05 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!

Пытаюсь применить вышеуказанные формулы, но выдает ошибку, помогите пжл.

В колонку G должна попасть разница цен (колонка F) между Последней "Обрядкой 1" в списке и предпоследней "Обрядкой 1" в списке. Т.е. 230-235= -5
К сообщению приложен файл: 13.09.xlsx(10.0 Kb)
 
Ответить
СообщениеЗдравствуйте!

Пытаюсь применить вышеуказанные формулы, но выдает ошибку, помогите пжл.

В колонку G должна попасть разница цен (колонка F) между Последней "Обрядкой 1" в списке и предпоследней "Обрядкой 1" в списке. Т.е. 230-235= -5

Автор - AleksFin
Дата добавления - 13.09.2019 в 10:05
AleksFin Дата: Пятница, 13.09.2019, 10:46 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Мне нужно найти значение именно точно такого же предпоследнего наименования
 
Ответить
СообщениеМне нужно найти значение именно точно такого же предпоследнего наименования

Автор - AleksFin
Дата добавления - 13.09.2019 в 10:46
Светлый Дата: Пятница, 13.09.2019, 11:35 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 1441
Репутация: 380 ±
Замечаний: 0% ±

Excel 2010, 2013
Формула массива (вводится одновременным нажатием Ctrl+Shift+Enter):
Код
=F7-ИНДЕКС(F:F;МАКС((E$3:E6=E7)*СТРОКА($3:6)))
*Или простая:
Код
=F7-ПРОСМОТР(E7;E$3:E6;F$3:F6)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 13.09.2019, 11:39
 
Ответить
СообщениеФормула массива (вводится одновременным нажатием Ctrl+Shift+Enter):
Код
=F7-ИНДЕКС(F:F;МАКС((E$3:E6=E7)*СТРОКА($3:6)))
*Или простая:
Код
=F7-ПРОСМОТР(E7;E$3:E6;F$3:F6)

Автор - Светлый
Дата добавления - 13.09.2019 в 11:35
AleksFin Дата: Пятница, 13.09.2019, 14:02 | Сообщение № 12
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Светлый, спасибо за Ваш ответ.

Но почему-то оба варианта не отрабатывают.

В простой формуле отнимает не от предпоследнего значения а за 3 до него.

Во второй формуле появляется #знач
 
Ответить
СообщениеСветлый, спасибо за Ваш ответ.

Но почему-то оба варианта не отрабатывают.

В простой формуле отнимает не от предпоследнего значения а за 3 до него.

Во второй формуле появляется #знач

Автор - AleksFin
Дата добавления - 13.09.2019 в 14:02
китин Дата: Пятница, 13.09.2019, 14:39 | Сообщение № 13
Группа: Модераторы
Ранг: Экселист
Сообщений: 6153
Репутация: 950 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
AleksFin, а вы в какую ячейку вставляете формулу?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеAleksFin, а вы в какую ячейку вставляете формулу?

Автор - китин
Дата добавления - 13.09.2019 в 14:39
AleksFin Дата: Пятница, 13.09.2019, 16:10 | Сообщение № 14
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, в несколько подряд пробовал
 
Ответить
Сообщениекитин, в несколько подряд пробовал

Автор - AleksFin
Дата добавления - 13.09.2019 в 16:10
AleksFin Дата: Пятница, 13.09.2019, 16:10 | Сообщение № 15
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
извините, фот файл где пробовал
К сообщению приложен файл: 2983874.xlsx(10.0 Kb)
 
Ответить
Сообщениеизвините, фот файл где пробовал

Автор - AleksFin
Дата добавления - 13.09.2019 в 16:10
Светлый Дата: Пятница, 13.09.2019, 16:43 | Сообщение № 16
Группа: Друзья
Ранг: Старожил
Сообщений: 1441
Репутация: 380 ±
Замечаний: 0% ±

Excel 2010, 2013
Да. С ПРОСМОТРом погорячился. Исправил.
Код
=F7-ЕСЛИОШИБКА(ПРОСМОТР(;-1/(E7=E$3:E6);F$3:F6);)
К сообщению приложен файл: 13.09-1.xlsx(10.7 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДа. С ПРОСМОТРом погорячился. Исправил.
Код
=F7-ЕСЛИОШИБКА(ПРОСМОТР(;-1/(E7=E$3:E6);F$3:F6);)

Автор - Светлый
Дата добавления - 13.09.2019 в 16:43
AleksFin Дата: Воскресенье, 15.09.2019, 08:59 | Сообщение № 17
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 117
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Светлый, товарищ "Светлый" большое Вам спасибо.
 
Ответить
СообщениеСветлый, товарищ "Светлый" большое Вам спасибо.

Автор - AleksFin
Дата добавления - 15.09.2019 в 08:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти предпоследнее значение в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!