Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Искать по части слова и выписать соседнее значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Open Office » Искать по части слова и выписать соседнее значение (Формулы/Formulas)
Искать по части слова и выписать соседнее значение
Фомулист Дата: Среда, 17.08.2016, 17:44 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 2 ±
Замечаний: 60% ±

Excel 2003
Ну никак я не перестану Вам надоедать. :D
В приложенном файле нужно, сделать подобие ВПР - выписать цифру возле соответствующего слова (в файле всё наглядно). Но Если в ячейке слов больше одного, то искать нужно первое слово, так как в других также присутствуют заглавные буквы, что делает невозможным прямое сравнение. Без макросов. Помогите, пожалуйста.
К сообщению приложен файл: ___.xls(7Kb)


Терпение и труд всё перетрут!
 
Ответить
СообщениеНу никак я не перестану Вам надоедать. :D
В приложенном файле нужно, сделать подобие ВПР - выписать цифру возле соответствующего слова (в файле всё наглядно). Но Если в ячейке слов больше одного, то искать нужно первое слово, так как в других также присутствуют заглавные буквы, что делает невозможным прямое сравнение. Без макросов. Помогите, пожалуйста.

Автор - Фомулист
Дата добавления - 17.08.2016 в 17:44
sboy Дата: Среда, 17.08.2016, 17:56 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 577
Репутация: 153 ±
Замечаний: 0% ±

Excel 2010
Добрый день, если проблема только в заглавных буквах, то вместо ВПР можно Индекс+Поискпоз с типом сопоставления 1(меньше).
Но возможны ошибки, если такого ФИО не будет, то цифра подтянется по ближайшему похожему ФИО
 
Ответить
СообщениеДобрый день, если проблема только в заглавных буквах, то вместо ВПР можно Индекс+Поискпоз с типом сопоставления 1(меньше).
Но возможны ошибки, если такого ФИО не будет, то цифра подтянется по ближайшему похожему ФИО

Автор - sboy
Дата добавления - 17.08.2016 в 17:56
Фомулист Дата: Среда, 17.08.2016, 18:01 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 2 ±
Замечаний: 60% ±

Excel 2003
Но возможны ошибки

Поэтому, мне надо иначе.


Терпение и труд всё перетрут!
 
Ответить
Сообщение
Но возможны ошибки

Поэтому, мне надо иначе.

Автор - Фомулист
Дата добавления - 17.08.2016 в 18:01
_Boroda_ Дата: Среда, 17.08.2016, 18:05 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А в чем проблема-то? ВПР не реагирует на заглавность букв
Код
=ВПР(F2;B$2:C$5;2;)

Ну если очень хочется по первому слову, то так можно
Код
=ВПР(ЛЕВБ(F2;ПОИСК(" ";F2&" ")-1)&"*";B$2:C$5;2;)
К сообщению приложен файл: 4562684652.xls(31Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА в чем проблема-то? ВПР не реагирует на заглавность букв
Код
=ВПР(F2;B$2:C$5;2;)

Ну если очень хочется по первому слову, то так можно
Код
=ВПР(ЛЕВБ(F2;ПОИСК(" ";F2&" ")-1)&"*";B$2:C$5;2;)

Автор - _Boroda_
Дата добавления - 17.08.2016 в 18:05
Фомулист Дата: Среда, 17.08.2016, 18:20 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 2 ±
Замечаний: 60% ±

Excel 2003
ВПР не реагирует на заглавность букв

У меня при ФИО Александров Кирилл Михайлович в одной ячейке и Александров кирилл михайлович в другой Н/Д выдаёт, хотя это один и тот же человек, и цифра у него имеется.
то так можно

К сожалению, теперь смогу проверить только завтра.


Терпение и труд всё перетрут!

Сообщение отредактировал Фомулист - Среда, 17.08.2016, 18:22
 
Ответить
Сообщение
ВПР не реагирует на заглавность букв

У меня при ФИО Александров Кирилл Михайлович в одной ячейке и Александров кирилл михайлович в другой Н/Д выдаёт, хотя это один и тот же человек, и цифра у него имеется.
то так можно

К сожалению, теперь смогу проверить только завтра.

Автор - Фомулист
Дата добавления - 17.08.2016 в 18:20
Фомулист Дата: Среда, 17.08.2016, 18:24 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 2 ±
Замечаний: 60% ±

Excel 2003
1)&"*";B$2:C$5;2;)

А если и в последнем аргументе ВПР поставить 0, а не оставить его пустым, - будет искать?
2&" ")-1)&"*";B$

Я составил формулу со звёздочкой:
Код
ВПР(ЕСЛИ(ЕЧИСЛО(ПОИСК(" ";F2));ЛЕВСИМВ(F2;ПОИСК(" ";F2))&"*";F2);B$2:C$5;2;0)
, и получил Н/Д. Когда стал смотреть этапы вычисления, то увидел, что ЛЕВСИМВ(F2;ПОИСК(" ";F2))&"*" даёт Александров* %) . Как я уже сказал, Вашу формулу, к сожалению, смогу проверить теперь только завтра.


Терпение и труд всё перетрут!

Сообщение отредактировал Фомулист - Среда, 17.08.2016, 18:40
 
Ответить
Сообщение
1)&"*";B$2:C$5;2;)

А если и в последнем аргументе ВПР поставить 0, а не оставить его пустым, - будет искать?
2&" ")-1)&"*";B$

Я составил формулу со звёздочкой:
Код
ВПР(ЕСЛИ(ЕЧИСЛО(ПОИСК(" ";F2));ЛЕВСИМВ(F2;ПОИСК(" ";F2))&"*";F2);B$2:C$5;2;0)
, и получил Н/Д. Когда стал смотреть этапы вычисления, то увидел, что ЛЕВСИМВ(F2;ПОИСК(" ";F2))&"*" даёт Александров* %) . Как я уже сказал, Вашу формулу, к сожалению, смогу проверить теперь только завтра.

Автор - Фомулист
Дата добавления - 17.08.2016 в 18:24
Serge_007 Дата: Среда, 17.08.2016, 19:58 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13121
Репутация: ±
Замечаний: ±

Excel 2010
при ФИО Александров Кирилл Михайлович в одной ячейке и Александров кирилл михайлович в другой Н/Д выдаёт
Не надо тратить буквы :)
Покажите

К сообщению приложен файл: 0025677.gif(26Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
при ФИО Александров Кирилл Михайлович в одной ячейке и Александров кирилл михайлович в другой Н/Д выдаёт
Не надо тратить буквы :)
Покажите


Автор - Serge_007
Дата добавления - 17.08.2016 в 19:58
Фомулист Дата: Среда, 17.08.2016, 21:25 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 2 ±
Замечаний: 60% ±

Excel 2003
Так мне так надо:
Код
=ВПР(F2;B$2:C$5;2;0)
- ноль в конце формулы. А при этом нуле уже Н/Д даёт. Файл, увы, смогу показать только завтра.


Терпение и труд всё перетрут!

Сообщение отредактировал Фомулист - Среда, 17.08.2016, 21:26
 
Ответить
СообщениеТак мне так надо:
Код
=ВПР(F2;B$2:C$5;2;0)
- ноль в конце формулы. А при этом нуле уже Н/Д даёт. Файл, увы, смогу показать только завтра.

Автор - Фомулист
Дата добавления - 17.08.2016 в 21:25
Serge_007 Дата: Четверг, 18.08.2016, 06:23 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 13121
Репутация: ±
Замечаний: ±

Excel 2010
Код
=ВПР(F2;B$2:C$5;2;ЛОЖЬ)
,
Код
=ВПР(F2;B$2:C$5;2;0)
и
Код
=ВПР(F2;B$2:C$5;2;)
-это одно и тоже и результат будет одинаковый (просто разные формы записи 4-го аргумента функции). Вы путаете с
Код
=ВПР(F2;B$2:C$5;2)
- вот это действительно другая формула


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ВПР(F2;B$2:C$5;2;ЛОЖЬ)
,
Код
=ВПР(F2;B$2:C$5;2;0)
и
Код
=ВПР(F2;B$2:C$5;2;)
-это одно и тоже и результат будет одинаковый (просто разные формы записи 4-го аргумента функции). Вы путаете с
Код
=ВПР(F2;B$2:C$5;2)
- вот это действительно другая формула

Автор - Serge_007
Дата добавления - 18.08.2016 в 06:23
Фомулист Дата: Четверг, 18.08.2016, 10:33 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 2 ±
Замечаний: 60% ±

Excel 2003
Выкладываю новый файл. Пробовал вторую формулу из поста 4 - не ищет. Как ещё можно найти?
К сообщению приложен файл: ___-1.xls(8Kb)


Терпение и труд всё перетрут!
 
Ответить
СообщениеВыкладываю новый файл. Пробовал вторую формулу из поста 4 - не ищет. Как ещё можно найти?

Автор - Фомулист
Дата добавления - 18.08.2016 в 10:33
Pelena Дата: Четверг, 18.08.2016, 10:48 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 2454 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
В Excel всё ищет. А если Вы опять про OpenOffice, то и тему надо было создавать в соответствующем разделе


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВ Excel всё ищет. А если Вы опять про OpenOffice, то и тему надо было создавать в соответствующем разделе

Автор - Pelena
Дата добавления - 18.08.2016 в 10:48
Фомулист Дата: Четверг, 18.08.2016, 11:11 | Сообщение № 12
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 2 ±
Замечаний: 60% ±

Excel 2003
Pelena,
Тогда, перенесите, пожалуйста, и помогите настроить формулу, пожалуйста.


Терпение и труд всё перетрут!
 
Ответить
СообщениеPelena,
Тогда, перенесите, пожалуйста, и помогите настроить формулу, пожалуйста.

Автор - Фомулист
Дата добавления - 18.08.2016 в 11:11
Фомулист Дата: Пятница, 19.08.2016, 14:07 | Сообщение № 13
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 2 ±
Замечаний: 60% ±

Excel 2003
Ещё актуально


Терпение и труд всё перетрут!
 
Ответить
СообщениеЕщё актуально

Автор - Фомулист
Дата добавления - 19.08.2016 в 14:07
Manyasha Дата: Пятница, 19.08.2016, 17:15 | Сообщение № 14
Группа: Модераторы
Ранг: Старожил
Сообщений: 1818
Репутация: 751 ±
Замечаний: 0% ±

Excel 2007, 2010
Фомулист, вот эти варианты в ОО работают:
1 - возвращает результат в текстовом формате
Код
=VLOOKUP(LEFT(F2;SEARCH(" ";F2&" ")-1);MID(B$2:C$6;1;SEARCH(" ";B$2:C$6&" ")-1);2;0)

2 - возвращает данные в том же формате, что и исходные в столбце С
Код
=INDEX($C$2:$C$6;MATCH(LEFT(F2;SEARCH(" ";F2&" ")-1);MID(B$2:B$6;1;SEARCH(" ";B$2:B$6&" ")-1);0))

Обе формулы массивные! (почитайте, как ими пользоваться)
К сообщению приложен файл: -1-1.ods(10Kb) · 2593982.xls(22Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеФомулист, вот эти варианты в ОО работают:
1 - возвращает результат в текстовом формате
Код
=VLOOKUP(LEFT(F2;SEARCH(" ";F2&" ")-1);MID(B$2:C$6;1;SEARCH(" ";B$2:C$6&" ")-1);2;0)

2 - возвращает данные в том же формате, что и исходные в столбце С
Код
=INDEX($C$2:$C$6;MATCH(LEFT(F2;SEARCH(" ";F2&" ")-1);MID(B$2:B$6;1;SEARCH(" ";B$2:B$6&" ")-1);0))

Обе формулы массивные! (почитайте, как ими пользоваться)

Автор - Manyasha
Дата добавления - 19.08.2016 в 17:15
Фомулист Дата: Понедельник, 22.08.2016, 12:05 | Сообщение № 15
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 2 ±
Замечаний: 60% ±

Excel 2003
массивные! (почитайте, как ими пользоваться)

Большое спасибо. Я знаю, как ими пользоваться.


Терпение и труд всё перетрут!

Сообщение отредактировал Фомулист - Понедельник, 22.08.2016, 12:09
 
Ответить
Сообщение
массивные! (почитайте, как ими пользоваться)

Большое спасибо. Я знаю, как ими пользоваться.

Автор - Фомулист
Дата добавления - 22.08.2016 в 12:05
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Open Office » Искать по части слова и выписать соседнее значение (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!