Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копирование строк в n-раз с помощью VBA или формулы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Копирование строк в n-раз с помощью VBA или формулы (Макросы/Sub)
Копирование строк в n-раз с помощью VBA или формулы
n-ergash Дата: Пятница, 08.01.2016, 10:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Уважаемые знатоки VBA прошу вашей помощи и поддержку в решении задачи
ест таблица "отчет склада" (расход материалов) и на другом листе готовится "сводный акт" этих материалов
в отчете склада ежедневно вводятся данные расхода материалов более 1000 строк и затем в конце месяца
данные собравшиеся за месяц вводятся в сводный акт (вручную) Возможно ли автоматизировать этот процесс с помощью макроса
я только начал изучать VBA поэтому пока не смогу сделать такое , пробовал с формулами реализовать но пака желаемого результата не достиг
Привожу при мер отчета
Заранее БЛАГОДАРЮ за ваше внимание и поддержку
К сообщению приложен файл: 5565166.xlsx(14Kb)


Сообщение отредактировал n-ergash - Пятница, 08.01.2016, 10:05
 
Ответить
СообщениеУважаемые знатоки VBA прошу вашей помощи и поддержку в решении задачи
ест таблица "отчет склада" (расход материалов) и на другом листе готовится "сводный акт" этих материалов
в отчете склада ежедневно вводятся данные расхода материалов более 1000 строк и затем в конце месяца
данные собравшиеся за месяц вводятся в сводный акт (вручную) Возможно ли автоматизировать этот процесс с помощью макроса
я только начал изучать VBA поэтому пока не смогу сделать такое , пробовал с формулами реализовать но пака желаемого результата не достиг
Привожу при мер отчета
Заранее БЛАГОДАРЮ за ваше внимание и поддержку

Автор - n-ergash
Дата добавления - 08.01.2016 в 10:02
Nic70y Дата: Пятница, 08.01.2016, 10:48 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3667
Репутация: 760 ±
Замечаний: 0% ±

Excel 2013
пробовал с формулами
тож попробовал.
в столбце ИМЯ САЙТА/SITE NAME массивные
К сообщению приложен файл: 7520424.xlsx(17Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
пробовал с формулами
тож попробовал.
в столбце ИМЯ САЙТА/SITE NAME массивные

Автор - Nic70y
Дата добавления - 08.01.2016 в 10:48
buchlotnik Дата: Пятница, 08.01.2016, 11:21 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2204
Репутация: 659 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
у меня аналогично вышло (формулами) B)
Оборудование
Код
=ЕСЛИ(СЧЁТЕСЛИ($I$2:I2;I2)=ИНДЕКС('отчет склада'!$D$2:$J$2;ПОИСКПОЗ(I2;'отчет склада'!$D$1:$J$1;0));ИНДЕКС('отчет склада'!$D$1:$J$1;ПОИСКПОЗ(I2;'отчет склада'!$D$1:$J$1;0)+1);I2)

Сайт (массивка):
Код
=ИНДЕКС('отчет склада'!$A$3:$A$10;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ИНДЕКС('отчет склада'!$D$3:$J$10;;ПОИСКПОЗ(I3;'отчет склада'!$D$1:$J$1;0)));СТРОКА($D$1:$D$8);"");СЧЁТЕСЛИ($I$2:I2;I3)+1))

Количество:
Код
=ИНДЕКС('отчет склада'!$D$3:$J$10;ПОИСКПОЗ(H3;'отчет склада'!$A$3:$A$10;0);ПОИСКПОЗ(I3;'отчет склада'!$D$1:$J$1;0))
К сообщению приложен файл: 4825369.xlsx(17Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 08.01.2016, 11:23
 
Ответить
Сообщениеу меня аналогично вышло (формулами) B)
Оборудование
Код
=ЕСЛИ(СЧЁТЕСЛИ($I$2:I2;I2)=ИНДЕКС('отчет склада'!$D$2:$J$2;ПОИСКПОЗ(I2;'отчет склада'!$D$1:$J$1;0));ИНДЕКС('отчет склада'!$D$1:$J$1;ПОИСКПОЗ(I2;'отчет склада'!$D$1:$J$1;0)+1);I2)

Сайт (массивка):
Код
=ИНДЕКС('отчет склада'!$A$3:$A$10;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ИНДЕКС('отчет склада'!$D$3:$J$10;;ПОИСКПОЗ(I3;'отчет склада'!$D$1:$J$1;0)));СТРОКА($D$1:$D$8);"");СЧЁТЕСЛИ($I$2:I2;I3)+1))

Количество:
Код
=ИНДЕКС('отчет склада'!$D$3:$J$10;ПОИСКПОЗ(H3;'отчет склада'!$A$3:$A$10;0);ПОИСКПОЗ(I3;'отчет склада'!$D$1:$J$1;0))

Автор - buchlotnik
Дата добавления - 08.01.2016 в 11:21
Nic70y Дата: Пятница, 08.01.2016, 11:28 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3667
Репутация: 760 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, сотрите d3:d10 на листе отчет склада


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеbuchlotnik, сотрите d3:d10 на листе отчет склада

Автор - Nic70y
Дата добавления - 08.01.2016 в 11:28
n-ergash Дата: Пятница, 08.01.2016, 12:37 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y, Спасибо огромное
 
Ответить
СообщениеNic70y, Спасибо огромное

Автор - n-ergash
Дата добавления - 08.01.2016 в 12:37
n-ergash Дата: Пятница, 08.01.2016, 12:38 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
buchlotnik, Спасибо за ваш ответ
вариант с макросом был бы к стати и за тоже Спасибо
 
Ответить
Сообщениеbuchlotnik, Спасибо за ваш ответ
вариант с макросом был бы к стати и за тоже Спасибо

Автор - n-ergash
Дата добавления - 08.01.2016 в 12:38
Hugo Дата: Пятница, 08.01.2016, 17:24 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2662
Репутация: 599 ±
Замечаний: 0% ±

Вариант с макросом есть на планете:
http://planetaexcel.ru/forum....f_fid=1
Но если кто желает разнообразия/оптимизации (там ещё с форматами возможно нужно поработать) - может написать что-то своё. Кстати и профиль ветки призывает :)


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069
 
Ответить
СообщениеВариант с макросом есть на планете:
http://planetaexcel.ru/forum....f_fid=1
Но если кто желает разнообразия/оптимизации (там ещё с форматами возможно нужно поработать) - может написать что-то своё. Кстати и профиль ветки призывает :)

Автор - Hugo
Дата добавления - 08.01.2016 в 17:24
n-ergash Дата: Понедельник, 18.01.2016, 15:02 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Hugo, Посмотрите можно ли ускорить работу кода
Ато при больших обьемах данных скорость замедляется
или я ошибаюсь
К сообщению приложен файл: _-huawei-2016-2.rar(99Kb)
 
Ответить
СообщениеHugo, Посмотрите можно ли ускорить работу кода
Ато при больших обьемах данных скорость замедляется
или я ошибаюсь

Автор - n-ergash
Дата добавления - 18.01.2016 в 15:02
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Копирование строк в n-раз с помощью VBA или формулы (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!