Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Размещение даных в строку. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Размещение даных в строку. (Формулы/Formulas)
Размещение даных в строку.
Shtein Дата: Понедельник, 11.01.2016, 16:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Привет всем.

Возник такой вопрос, во вложении файл, проблема на вкладке 1. Показал слева, как есть, справа - как надо. Я делаю ручками, вставкой через транспонирование, но массив большой, достаточно трудоемко.

На вкладке 2 показываю, что мне посоветовали ранее на форуме, по похожей проблеме, там надо было из строк расположить под данным. Пытался как-то передаеать формулу, но не смог(
К сообщению приложен файл: 3010931.xlsx(12Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.


Сообщение отредактировал Shtein - Понедельник, 11.01.2016, 16:23
 
Ответить
СообщениеПривет всем.

Возник такой вопрос, во вложении файл, проблема на вкладке 1. Показал слева, как есть, справа - как надо. Я делаю ручками, вставкой через транспонирование, но массив большой, достаточно трудоемко.

На вкладке 2 показываю, что мне посоветовали ранее на форуме, по похожей проблеме, там надо было из строк расположить под данным. Пытался как-то передаеать формулу, но не смог(

Автор - Shtein
Дата добавления - 11.01.2016 в 16:19
krosav4ig Дата: Понедельник, 11.01.2016, 16:29 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1420
Репутация: 585 ±
Замечаний: 0% ±

Excel 2007, 2013
Добрый день, посмотрите решение с доп. столбцом и сводной

upd.
заменил файл...
К сообщению приложен файл: 5633301.xlsx(17Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Понедельник, 11.01.2016, 16:33
 
Ответить
СообщениеДобрый день, посмотрите решение с доп. столбцом и сводной

upd.
заменил файл...

Автор - krosav4ig
Дата добавления - 11.01.2016 в 16:29
Russel Дата: Понедельник, 11.01.2016, 16:30 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1252
Репутация: 284 ±
Замечаний: 0% ±

Excel 2010
С доп.столбцом и сводной ;)
К сообщению приложен файл: 2270906.xlsx(16Kb)


QIWI 9173973973
 
Ответить
СообщениеС доп.столбцом и сводной ;)

Автор - Russel
Дата добавления - 11.01.2016 в 16:30
_Boroda_ Дата: Понедельник, 11.01.2016, 16:34 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9818
Репутация: 4145 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Значений всегда по 2 или произвольное количество? Если у одного города в двух строках цифры одинаковые, то что делать?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЗначений всегда по 2 или произвольное количество? Если у одного города в двух строках цифры одинаковые, то что делать?

Автор - _Boroda_
Дата добавления - 11.01.2016 в 16:34
Shtein Дата: Понедельник, 11.01.2016, 16:50 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Значений всегда по 2 или произвольное количество? Если у одного города в двух строках цифры одинаковые, то что делать?


Бывает также по 1 и по 3 значения. Если цифры одинаковые, то располагать все равно рядом.
Прикрепил обновленный исходник, учитывающий эти моменты.
К сообщению приложен файл: __-2.xlsx(12Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
Сообщение
Значений всегда по 2 или произвольное количество? Если у одного города в двух строках цифры одинаковые, то что делать?


Бывает также по 1 и по 3 значения. Если цифры одинаковые, то располагать все равно рядом.
Прикрепил обновленный исходник, учитывающий эти моменты.

Автор - Shtein
Дата добавления - 11.01.2016 в 16:50
_Boroda_ Дата: Понедельник, 11.01.2016, 16:58 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9818
Репутация: 4145 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вариант формулами

Города (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$5:$A$99;ПОИСКПОЗ(;СЧЁТЕСЛИ(D$4:D4;$A$5:$A$99);))&"";"")

числа (обычная формула)
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$5:$B$99;ПОИСКПОЗ($D5;$A$5:$A$99;)+СЧЁТ($D5:D5)+99*(СЧЁТ($D5:D5)>=СЧЁТЕСЛИ($A$5:$A$99;$D5)));"")
К сообщению приложен файл: 3010931_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВариант формулами

Города (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$5:$A$99;ПОИСКПОЗ(;СЧЁТЕСЛИ(D$4:D4;$A$5:$A$99);))&"";"")

числа (обычная формула)
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$5:$B$99;ПОИСКПОЗ($D5;$A$5:$A$99;)+СЧЁТ($D5:D5)+99*(СЧЁТ($D5:D5)>=СЧЁТЕСЛИ($A$5:$A$99;$D5)));"")

Автор - _Boroda_
Дата добавления - 11.01.2016 в 16:58
Shtein Дата: Понедельник, 11.01.2016, 17:07 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Ребята, спасибо большое, столько вариантов в кратчайший срок beer , буду пробовать сейчас


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
СообщениеРебята, спасибо большое, столько вариантов в кратчайший срок beer , буду пробовать сейчас

Автор - Shtein
Дата добавления - 11.01.2016 в 17:07
buchlotnik Дата: Понедельник, 11.01.2016, 17:13 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2198
Репутация: 647 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$5:$A$20;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A$5:$A$20;$A$5:$A$20;0)=СТРОКА($1:$16);ПОИСКПОЗ($A$5:$A$20;$A$5:$A$20;0);"");СТРОКА()-3);1);"")

Код
=ЕСЛИОШИБКА(ИНДЕКС($B$5:$B$20;НАИМЕНЬШИЙ(ЕСЛИ($K4=$A$5:$A$20;СТРОКА($A$1:$A$16);"");L$3));"")
К сообщению приложен файл: -2.xlsx(13Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 11.01.2016, 17:15
 
Ответить
Сообщениетак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$5:$A$20;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A$5:$A$20;$A$5:$A$20;0)=СТРОКА($1:$16);ПОИСКПОЗ($A$5:$A$20;$A$5:$A$20;0);"");СТРОКА()-3);1);"")

Код
=ЕСЛИОШИБКА(ИНДЕКС($B$5:$B$20;НАИМЕНЬШИЙ(ЕСЛИ($K4=$A$5:$A$20;СТРОКА($A$1:$A$16);"");L$3));"")

Автор - buchlotnik
Дата добавления - 11.01.2016 в 17:13
Shtein Дата: Понедельник, 11.01.2016, 17:54 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
:) вы просто гуру, спасибо всем большое.


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
Сообщение:) вы просто гуру, спасибо всем большое.

Автор - Shtein
Дата добавления - 11.01.2016 в 17:54
jakim Дата: Понедельник, 11.01.2016, 18:02 | Сообщение № 10
Группа: Друзья
Ранг: Ветеран
Сообщений: 710
Репутация: 182 ±
Замечаний: 0% ±

Протестируйте и такую формулу

Код
=IFERROR(INDEX($B$5:$B$20;AGGREGATE(15;6;ROW(A$1:A$20)/($A$5:$A$20=$F5);LEFT(G$4)));"")
 
Ответить
Сообщение
Протестируйте и такую формулу

Код
=IFERROR(INDEX($B$5:$B$20;AGGREGATE(15;6;ROW(A$1:A$20)/($A$5:$A$20=$F5);LEFT(G$4)));"")

Автор - jakim
Дата добавления - 11.01.2016 в 18:02
Shtein Дата: Понедельник, 11.01.2016, 22:47 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Все новые и новые для меня функции) Эксель такой многогранный, попробую.


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
СообщениеВсе новые и новые для меня функции) Эксель такой многогранный, попробую.

Автор - Shtein
Дата добавления - 11.01.2016 в 22:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Размещение даных в строку. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!