Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить кол-во лет, месяцев и дней - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить кол-во лет, месяцев и дней (Формулы/Formulas)
Определить кол-во лет, месяцев и дней
Makcbond Дата: Вторник, 19.01.2016, 11:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!!! Снова нужна помощь, как определить кол-во лет, месяцев и дней
Например,
надо оплатить 15 000 000 назначали платить в год 1 917 418,48 надо понять сколько лет, месяцев, и дней на это уйдет?

15 000 000 руб.
Годовая ставка – 1 917 418,48 руб
15 000 000 / 1 917 418,48 = 7,82
7,82 это 7 лет и «сколько-то» месяцев и «сколько-то» дней.
К сообщению приложен файл: _-_-__.xlsx(9Kb)
 
Ответить
СообщениеЗдравствуйте!!! Снова нужна помощь, как определить кол-во лет, месяцев и дней
Например,
надо оплатить 15 000 000 назначали платить в год 1 917 418,48 надо понять сколько лет, месяцев, и дней на это уйдет?

15 000 000 руб.
Годовая ставка – 1 917 418,48 руб
15 000 000 / 1 917 418,48 = 7,82
7,82 это 7 лет и «сколько-то» месяцев и «сколько-то» дней.

Автор - Makcbond
Дата добавления - 19.01.2016 в 11:00
YouGreed Дата: Вторник, 19.01.2016, 11:15 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
Makcbond, Попробуйте так.
К сообщению приложен файл: --.xlsx(11Kb)
 
Ответить
СообщениеMakcbond, Попробуйте так.

Автор - YouGreed
Дата добавления - 19.01.2016 в 11:15
Makcbond Дата: Вторник, 19.01.2016, 11:29 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
YouGreed, Если сумму которую надо платить в год 1 917 418.48 умножить на 7 лет то получится 13 421 929.36. Остаток от 15 000 000 равен 1 578 070.64. Если годовую сумму разделить на 12 (1 917 418.48/12) и умножить на 10 мес. то получится 1 597 848.73 что-то не то.
 
Ответить
СообщениеYouGreed, Если сумму которую надо платить в год 1 917 418.48 умножить на 7 лет то получится 13 421 929.36. Остаток от 15 000 000 равен 1 578 070.64. Если годовую сумму разделить на 12 (1 917 418.48/12) и умножить на 10 мес. то получится 1 597 848.73 что-то не то.

Автор - Makcbond
Дата добавления - 19.01.2016 в 11:29
китин Дата: Вторник, 19.01.2016, 11:40 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4099
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а вот вам монстрище
Код
=ЕСЛИОШИБКА(ЦЕЛОЕ(A2/B2)&" лет "&ЦЕЛОЕ(ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12)&" "&ВПР(ЦЕЛОЕ(ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12);{1;"месяц":2;"месяца":3;"месяца":4;"месяца":5;"месяцев":6;"месяцев":7;"месяцев":8;"месяцев":9;"месяцев":10;"месяцев":11;"месяцев":12;"месяцев"};2;0)&" "&ЦЕЛОЕ((ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12-ЦЕЛОЕ(ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12))*24)&" "&ВПР(--ПРАВБ(ЦЕЛОЕ((ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12-ЦЕЛОЕ(ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12))*24);1);{1;"день":2;"дня":3;"дня":4;"дня":5;"дней":6;"дней":7;"дней":8;"дней":9;"дней":0;"дней"};2;0);ЦЕЛОЕ(A2/B2)&" лет ")

зото пишет лет,месяцев и дней
К сообщению приложен файл: Makcbond.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 19.01.2016, 11:41
 
Ответить
Сообщениеа вот вам монстрище
Код
=ЕСЛИОШИБКА(ЦЕЛОЕ(A2/B2)&" лет "&ЦЕЛОЕ(ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12)&" "&ВПР(ЦЕЛОЕ(ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12);{1;"месяц":2;"месяца":3;"месяца":4;"месяца":5;"месяцев":6;"месяцев":7;"месяцев":8;"месяцев":9;"месяцев":10;"месяцев":11;"месяцев":12;"месяцев"};2;0)&" "&ЦЕЛОЕ((ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12-ЦЕЛОЕ(ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12))*24)&" "&ВПР(--ПРАВБ(ЦЕЛОЕ((ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12-ЦЕЛОЕ(ОСТАТ(A2/B2;ЦЕЛОЕ(A2/B2))*12))*24);1);{1;"день":2;"дня":3;"дня":4;"дня":5;"дней":6;"дней":7;"дней":8;"дней":9;"дней":0;"дней"};2;0);ЦЕЛОЕ(A2/B2)&" лет ")

зото пишет лет,месяцев и дней

Автор - китин
Дата добавления - 19.01.2016 в 11:40
_Boroda_ Дата: Вторник, 19.01.2016, 11:40 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Только для определения количества дней обязательно нужна начальная дата. Важно количество дней в начальном и конечном месяцах. Поставьте начальную дату 1/1/16 - станет 27 дней. 1/5/16 - 25 дней.
Зеленое - проверка. Сумма не точна из-за того, что есть не только дни, но и часы-минуты-секунды
К сообщению приложен файл: -1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Только для определения количества дней обязательно нужна начальная дата. Важно количество дней в начальном и конечном месяцах. Поставьте начальную дату 1/1/16 - станет 27 дней. 1/5/16 - 25 дней.
Зеленое - проверка. Сумма не точна из-за того, что есть не только дни, но и часы-минуты-секунды

Автор - _Boroda_
Дата добавления - 19.01.2016 в 11:40
YouGreed Дата: Вторник, 19.01.2016, 11:44 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
Makcbond, совершенно верно подмечено. А теперь?
Разница за счет округления вверх.
К сообщению приложен файл: 3976039.xlsx(12Kb)
 
Ответить
СообщениеMakcbond, совершенно верно подмечено. А теперь?
Разница за счет округления вверх.

Автор - YouGreed
Дата добавления - 19.01.2016 в 11:44
Makcbond Дата: Вторник, 19.01.2016, 11:52 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Блин снова чувствую себя просто ребенком идеально, гениально, и т.д.
Всем спасибо огромное!!!!
 
Ответить
СообщениеБлин снова чувствую себя просто ребенком идеально, гениально, и т.д.
Всем спасибо огромное!!!!

Автор - Makcbond
Дата добавления - 19.01.2016 в 11:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить кол-во лет, месяцев и дней (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!