Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Список дней рождения в этом месяце. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Список дней рождения в этом месяце. (Формулы/Formulas)
Список дней рождения в этом месяце.
bumnik Дата: Четверг, 21.01.2016, 17:20 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
Здравствуйте! Пытаюсь составить список дней рождения в этом месяце. Подскажите в чём ошибка.
К сообщению приложен файл: 4915231.xlsx(29Kb)


Сообщение отредактировал bumnik - Четверг, 21.01.2016, 17:22
 
Ответить
СообщениеЗдравствуйте! Пытаюсь составить список дней рождения в этом месяце. Подскажите в чём ошибка.

Автор - bumnik
Дата добавления - 21.01.2016 в 17:20
mechanix85 Дата: Четверг, 21.01.2016, 18:06 | Сообщение № 2
Группа: Друзья
Ранг: Форумчанин
Сообщений: 229
Репутация: 34 ±
Замечаний: 0% ±

посмотрите лист1, дальше думаю сами справитесь
К сообщению приложен файл: 1729292.xlsx(31Kb)
 
Ответить
Сообщениепосмотрите лист1, дальше думаю сами справитесь

Автор - mechanix85
Дата добавления - 21.01.2016 в 18:06
Pelena Дата: Четверг, 21.01.2016, 18:16 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11601
Репутация: 2572 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Ещё вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДниРождения;НАИМЕНЬШИЙ(ЕСЛИ((МЕСЯЦ(ДниРождения)=МЕСЯЦ($B$12))*(ДниРождения<>"")*ЕЧЁТН(СТРОКА());СТРОКА(ДниРождения)-1);СТРОКА(A1)/2+1));"")
К сообщению приложен файл: 7463997.xlsx(29Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДниРождения;НАИМЕНЬШИЙ(ЕСЛИ((МЕСЯЦ(ДниРождения)=МЕСЯЦ($B$12))*(ДниРождения<>"")*ЕЧЁТН(СТРОКА());СТРОКА(ДниРождения)-1);СТРОКА(A1)/2+1));"")

Автор - Pelena
Дата добавления - 21.01.2016 в 18:16
bumnik Дата: Четверг, 21.01.2016, 18:17 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
mechanix85, класс! спасибо!!!!!
 
Ответить
Сообщениеmechanix85, класс! спасибо!!!!!

Автор - bumnik
Дата добавления - 21.01.2016 в 18:17
bumnik Дата: Четверг, 21.01.2016, 18:23 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
Pelena, Большое Спасибо!!!
 
Ответить
СообщениеPelena, Большое Спасибо!!!

Автор - bumnik
Дата добавления - 21.01.2016 в 18:23
jakim Дата: Четверг, 21.01.2016, 18:24 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 804
Репутация: 206 ±
Замечаний: 0% ±

Может такой вариант подойдет, а если нет, то я думаю, что сможете применить в дальнейшем для разработки своего документа предлагаемую мной формулу.

Код
=IFERROR(INDEX(Список!$B$2:$B$150;AGGREGATE(15;6;ROW(A1:A$150)/(MONTH(Список!$L$2:$L$150)=MONTH(A$1))/(Список!$L$2:$L$150<>"");ROW(A1)));"")
К сообщению приложен файл: 4612142.xlsx(25Kb)
 
Ответить
Сообщение
Может такой вариант подойдет, а если нет, то я думаю, что сможете применить в дальнейшем для разработки своего документа предлагаемую мной формулу.

Код
=IFERROR(INDEX(Список!$B$2:$B$150;AGGREGATE(15;6;ROW(A1:A$150)/(MONTH(Список!$L$2:$L$150)=MONTH(A$1))/(Список!$L$2:$L$150<>"");ROW(A1)));"")

Автор - jakim
Дата добавления - 21.01.2016 в 18:24
Gustav Дата: Четверг, 21.01.2016, 19:42 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1442
Репутация: 550 ±
Замечаний: 0% ±

начинал с Excel 4.0...
Подскажите в чём ошибка

Ошибку не искал. "Вне конкурса" составил по Вашим данным свой список на простейших формулах (как исповедующий принцип KISS в Excel). Выкладываю как узелок на память - вполне может потом пригодиться самому. Зацените уместность элемента управления "счётчик" для комфортной прокрутки по месяцам! :)
К сообщению приложен файл: bumnik_3.xlsx(20Kb)


Мой tip box - яд 41001663842605
 
Ответить
Сообщение
Подскажите в чём ошибка

Ошибку не искал. "Вне конкурса" составил по Вашим данным свой список на простейших формулах (как исповедующий принцип KISS в Excel). Выкладываю как узелок на память - вполне может потом пригодиться самому. Зацените уместность элемента управления "счётчик" для комфортной прокрутки по месяцам! :)

Автор - Gustav
Дата добавления - 21.01.2016 в 19:42
bumnik Дата: Пятница, 22.01.2016, 08:40 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
jakim, Gustav, Спасибо!!!
 
Ответить
Сообщениеjakim, Gustav, Спасибо!!!

Автор - bumnik
Дата добавления - 22.01.2016 в 08:40
Wasilich Дата: Пятница, 22.01.2016, 10:58 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1195
Репутация: 316 ±
Замечаний: 0% ±

2003
Ну и я примерчик выложу на всякий. :)
К сообщению приложен файл: 4969783.xls(21Kb)
 
Ответить
СообщениеНу и я примерчик выложу на всякий. :)

Автор - Wasilich
Дата добавления - 22.01.2016 в 10:58
_Boroda_ Дата: Пятница, 22.01.2016, 15:44 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не, так не интересно. Дни рождения должны по порядку выстраиваться. И ближайшее подкрашиваться должно.
Для дат
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ((МЕСЯЦ(Список!L$2:L$108)=МЕСЯЦ(СЕГОДНЯ()))*Список!L$2:L$108;Список!L$2:L$108-(1&-ГОД(Список!L$2:L$108))+1);СТРОКА(E2)/2);"")

Для фамилий
Код
=ЕСЛИОШИБКА(ИНДЕКС(Список!B$1:B$108;ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ((МЕСЯЦ(Список!L$2:L$108)=МЕСЯЦ(СЕГОДНЯ()))*Список!L$2:L$108;Список!L$2:L$108-(1&-ГОД(Список!L$2:L$108))+1+СТРОКА(Список!L$2:L$108)%%);СТРОКА(E2)/2);1)/1%%);"")

Ну и там в возрасте еще формулы поменял (кстати, возраст меняется при наступлении даты дня рождения) и условное форматирование сделал
К сообщению приложен файл: 4915231_1.xlsx(29Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе, так не интересно. Дни рождения должны по порядку выстраиваться. И ближайшее подкрашиваться должно.
Для дат
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ((МЕСЯЦ(Список!L$2:L$108)=МЕСЯЦ(СЕГОДНЯ()))*Список!L$2:L$108;Список!L$2:L$108-(1&-ГОД(Список!L$2:L$108))+1);СТРОКА(E2)/2);"")

Для фамилий
Код
=ЕСЛИОШИБКА(ИНДЕКС(Список!B$1:B$108;ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ((МЕСЯЦ(Список!L$2:L$108)=МЕСЯЦ(СЕГОДНЯ()))*Список!L$2:L$108;Список!L$2:L$108-(1&-ГОД(Список!L$2:L$108))+1+СТРОКА(Список!L$2:L$108)%%);СТРОКА(E2)/2);1)/1%%);"")

Ну и там в возрасте еще формулы поменял (кстати, возраст меняется при наступлении даты дня рождения) и условное форматирование сделал

Автор - _Boroda_
Дата добавления - 22.01.2016 в 15:44
bumnik Дата: Воскресенье, 24.01.2016, 09:26 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
_Boroda_, Большое спасибо за формулы! Но некоторые даты рождения не совсем верны. Например: на листе Список у Хомича НН дата рождения 23.11.1979, а формула вычисляет 22.11.1979.
 
Ответить
Сообщение_Boroda_, Большое спасибо за формулы! Но некоторые даты рождения не совсем верны. Например: на листе Список у Хомича НН дата рождения 23.11.1979, а формула вычисляет 22.11.1979.

Автор - bumnik
Дата добавления - 24.01.2016 в 09:26
_Boroda_ Дата: Воскресенье, 24.01.2016, 13:58 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Действительно. Не учел. Тогда формулу из фамилий тупо переносим на даты и не морочим себе голову
К сообщению приложен файл: 4915231_2.xlsx(32Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДействительно. Не учел. Тогда формулу из фамилий тупо переносим на даты и не морочим себе голову

Автор - _Boroda_
Дата добавления - 24.01.2016 в 13:58
bumnik Дата: Понедельник, 25.01.2016, 06:19 | Сообщение № 13
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
_Boroda_, спасибо, работает! :)
 
Ответить
Сообщение_Boroda_, спасибо, работает! :)

Автор - bumnik
Дата добавления - 25.01.2016 в 06:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Список дней рождения в этом месяце. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!