Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУммирование по нескольким параметрам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУммирование по нескольким параметрам (Формулы/Formulas)
СУммирование по нескольким параметрам
zuzikmba Дата: Вторник, 26.01.2016, 06:43 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
Всем доброго утра!

Помогите пожалуйста со следующей задачей.

Есть варианты упрощения формулы?

Подробности в прикрепленном файле
К сообщению приложен файл: 9265229.xlsx(11Kb)
 
Ответить
СообщениеВсем доброго утра!

Помогите пожалуйста со следующей задачей.

Есть варианты упрощения формулы?

Подробности в прикрепленном файле

Автор - zuzikmba
Дата добавления - 26.01.2016 в 06:43
_Boroda_ Дата: Вторник, 26.01.2016, 07:18 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9818
Репутация: 4146 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(C$4:C$21*(--ПСТР(B$4:B$21;6;1)<3))

Код
=СУММПРОИЗВ(C$4:C$21*(--ПРАВБ(B$4:B$21;3)<30))
3 потому, что у Вас в хвосте счётов пробел затесался
К сообщению приложен файл: 9265229_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(C$4:C$21*(--ПСТР(B$4:B$21;6;1)<3))

Код
=СУММПРОИЗВ(C$4:C$21*(--ПРАВБ(B$4:B$21;3)<30))
3 потому, что у Вас в хвосте счётов пробел затесался

Автор - _Boroda_
Дата добавления - 26.01.2016 в 07:18
китин Дата: Вторник, 26.01.2016, 07:20 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3696
Репутация: 574 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
И вам не хворать!!! пробуйте формулы массива
Код
=СУММПРОИЗВ($C$4:$C$21*(--ПРАВБ(СЖПРОБЕЛЫ($B$4:$B$21);1)<=2))
.Там еще парочка аналогичных для других параметров
К сообщению приложен файл: zuzikmba.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеИ вам не хворать!!! пробуйте формулы массива
Код
=СУММПРОИЗВ($C$4:$C$21*(--ПРАВБ(СЖПРОБЕЛЫ($B$4:$B$21);1)<=2))
.Там еще парочка аналогичных для других параметров

Автор - китин
Дата добавления - 26.01.2016 в 07:20
zuzikmba Дата: Вторник, 26.01.2016, 07:27 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
А если необходимо суммировать по 6 знаку счета начинающиеся на разные цифры,
например здесь в файле только счет 1877,
если возникает необходимость просуммировать счета 1877, 1878, 1879 по 6 знаку (от 0 до 2, от 3 до 8 и 9)
 
Ответить
СообщениеА если необходимо суммировать по 6 знаку счета начинающиеся на разные цифры,
например здесь в файле только счет 1877,
если возникает необходимость просуммировать счета 1877, 1878, 1879 по 6 знаку (от 0 до 2, от 3 до 8 и 9)

Автор - zuzikmba
Дата добавления - 26.01.2016 в 07:27
китин Дата: Вторник, 26.01.2016, 07:40 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3696
Репутация: 574 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
тогда так
Код
=СУММПРОИЗВ($C$4:$C$21*(--ПСТР($B$4:$B$21;6;1)<=8)*(--ПСТР($B$4:$B$21;6;1)>2))
[p.s.]Вы бы все хотелки в файле бы показали, проще было бы
К сообщению приложен файл: zuzikmba_2.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 26.01.2016, 07:41
 
Ответить
Сообщениетогда так
Код
=СУММПРОИЗВ($C$4:$C$21*(--ПСТР($B$4:$B$21;6;1)<=8)*(--ПСТР($B$4:$B$21;6;1)>2))
[p.s.]Вы бы все хотелки в файле бы показали, проще было бы

Автор - китин
Дата добавления - 26.01.2016 в 07:40
zuzikmba Дата: Вторник, 26.01.2016, 07:49 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
Извиняюсь если непонятно,
выкладываю более детальный файл с объяснениями что мне необходимо
К сообщению приложен файл: 2218063.xlsx(15Kb)
 
Ответить
СообщениеИзвиняюсь если непонятно,
выкладываю более детальный файл с объяснениями что мне необходимо

Автор - zuzikmba
Дата добавления - 26.01.2016 в 07:49
zuzikmba Дата: Вторник, 26.01.2016, 07:50 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
Почему добавляют в начале формул два минуса/тире/дефис (незнаю как интерпретировать)
 
Ответить
СообщениеПочему добавляют в начале формул два минуса/тире/дефис (незнаю как интерпретировать)

Автор - zuzikmba
Дата добавления - 26.01.2016 в 07:50
китин Дата: Вторник, 26.01.2016, 07:53 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3696
Репутация: 574 ±
Замечаний: 0% ±

Excel 2007;Excel 2010


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеЧто такое -- или как превратить ИСТИНА в 1, а ЛОЖЬ в 0?

Автор - китин
Дата добавления - 26.01.2016 в 07:53
zuzikmba Дата: Вторник, 26.01.2016, 07:59 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
Можно ли пулу подсчетов присвоить одно имя и через формулу сделать так чтобы автоматом суммировались только те счета попадающие в это имя?
 
Ответить
СообщениеМожно ли пулу подсчетов присвоить одно имя и через формулу сделать так чтобы автоматом суммировались только те счета попадающие в это имя?

Автор - zuzikmba
Дата добавления - 26.01.2016 в 07:59
zuzikmba Дата: Вторник, 26.01.2016, 08:18 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
Я так понимаю упростить формулу никак не получится :(
Придется писать километровую формулу %)
 
Ответить
СообщениеЯ так понимаю упростить формулу никак не получится :(
Придется писать километровую формулу %)

Автор - zuzikmba
Дата добавления - 26.01.2016 в 08:18
Pelena Дата: Вторник, 26.01.2016, 10:07 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 10401
Репутация: 2354 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Посмотрите такой вариант
Код
=СУММПРОИЗВ($C$7:$C$241*ЕЧИСЛО(ПОИСК(ПСТР($B$7:$B$241;6;1);$E2))*(--ЛЕВСИМВ($B$7:$B$241;4)=F$1)*(ДЛСТР($B$7:$B$241)>4))
К сообщению приложен файл: 3447094.xlsx(15Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПосмотрите такой вариант
Код
=СУММПРОИЗВ($C$7:$C$241*ЕЧИСЛО(ПОИСК(ПСТР($B$7:$B$241;6;1);$E2))*(--ЛЕВСИМВ($B$7:$B$241;4)=F$1)*(ДЛСТР($B$7:$B$241)>4))

Автор - Pelena
Дата добавления - 26.01.2016 в 10:07
pabchek Дата: Вторник, 26.01.2016, 10:16 | Сообщение № 12
Группа: Проверенные
Ранг: Ветеран
Сообщений: 664
Репутация: 147 ±
Замечаний: 0% ±

Excel 2007
А если сводной?
К сообщению приложен файл: 2536976.xlsx(36Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеА если сводной?

Автор - pabchek
Дата добавления - 26.01.2016 в 10:16
zuzikmba Дата: Вторник, 26.01.2016, 11:03 | Сообщение № 13
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
Всем спасибо!
Взял вариант который предложила Пелена.

Идеи других я тоже использовал в некоторых местах.
 
Ответить
СообщениеВсем спасибо!
Взял вариант который предложила Пелена.

Идеи других я тоже использовал в некоторых местах.

Автор - zuzikmba
Дата добавления - 26.01.2016 в 11:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУммирование по нескольким параметрам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!