Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Свести в строку №1 данные из каждого 3-го столбца строки №2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Свести в строку №1 данные из каждого 3-го столбца строки №2 (Формулы/Formulas)
Свести в строку №1 данные из каждого 3-го столбца строки №2
Belfigor Дата: Среда, 03.02.2016, 18:21 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Подскажите пожалуйста. Не могу придумать как это сделать :(
Есть таблица, где в целевую строку, в каждый столбец подряд, нужно собрать информацию из каждого третьего столбца другой строки.
Файл таблицы приложен. Но в нём я вручную ссылаюсь на нужные мне столбцы, это невозможно при большом количестве записей :(

P.S. Нужен способ с использованием формул
К сообщению приложен файл: 5749997.xlsx(11Kb)


Сообщение отредактировал Belfigor - Среда, 03.02.2016, 18:27
 
Ответить
СообщениеПодскажите пожалуйста. Не могу придумать как это сделать :(
Есть таблица, где в целевую строку, в каждый столбец подряд, нужно собрать информацию из каждого третьего столбца другой строки.
Файл таблицы приложен. Но в нём я вручную ссылаюсь на нужные мне столбцы, это невозможно при большом количестве записей :(

P.S. Нужен способ с использованием формул

Автор - Belfigor
Дата добавления - 03.02.2016 в 18:21
Udik Дата: Среда, 03.02.2016, 18:34 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1376
Репутация: 178 ±
Замечаний: 0% ±

Excel 2016 х 64
так вроде
Код
=ИНДЕКС($A$6:$R$6;;СТОЛБЕЦ()*3)
К сообщению приложен файл: 0t.xlsx(14Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Среда, 03.02.2016, 18:35
 
Ответить
Сообщениетак вроде
Код
=ИНДЕКС($A$6:$R$6;;СТОЛБЕЦ()*3)

Автор - Udik
Дата добавления - 03.02.2016 в 18:34
Belfigor Дата: Среда, 03.02.2016, 20:47 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Большое спасибо! То что надо :)
 
Ответить
СообщениеБольшое спасибо! То что надо :)

Автор - Belfigor
Дата добавления - 03.02.2016 в 20:47
Belfigor Дата: Четверг, 04.02.2016, 17:34 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
так вроде
Код
=ИНДЕКС($A$6:$R$6;;СТОЛБЕЦ()*3)

Подскажите как применить этот способ для того чтобы суммировать данные из каждого третьего столбца заданного диапазона, в идущие подряд столбцы другой строки?
Я пытался сделать так:
Код
=СУММЕСЛИ($C$47:$C$102;$A9;M$47:ИНДЕКС(M$47:M$101;30))

чуть модифицировав приведенный выше способ, но у меня ничего не вышло.

Я пытаюсь с помощью функции СУММЕСЛИ, просуммировать исходя из категории затраты на каждую категорию на каждый день
[moder]Пример нормальный приведите. С цифрами, а не тестами. И желаемый результат покажите[/moder]
К сообщению приложен файл: primer_2.xls(81Kb)


Сообщение отредактировал Belfigor - Четверг, 04.02.2016, 18:54
 
Ответить
Сообщение
так вроде
Код
=ИНДЕКС($A$6:$R$6;;СТОЛБЕЦ()*3)

Подскажите как применить этот способ для того чтобы суммировать данные из каждого третьего столбца заданного диапазона, в идущие подряд столбцы другой строки?
Я пытался сделать так:
Код
=СУММЕСЛИ($C$47:$C$102;$A9;M$47:ИНДЕКС(M$47:M$101;30))

чуть модифицировав приведенный выше способ, но у меня ничего не вышло.

Я пытаюсь с помощью функции СУММЕСЛИ, просуммировать исходя из категории затраты на каждую категорию на каждый день
[moder]Пример нормальный приведите. С цифрами, а не тестами. И желаемый результат покажите[/moder]

Автор - Belfigor
Дата добавления - 04.02.2016 в 17:34
Udik Дата: Четверг, 04.02.2016, 18:23 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1376
Репутация: 178 ±
Замечаний: 0% ±

Excel 2016 х 64
без примера, как-то так можно
Код
=СУММ(СМЕЩ($A$1;;СТОЛБЕЦ()*3;22))


22-количество строк для суммы


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениебез примера, как-то так можно
Код
=СУММ(СМЕЩ($A$1;;СТОЛБЕЦ()*3;22))


22-количество строк для суммы

Автор - Udik
Дата добавления - 04.02.2016 в 18:23
gling Дата: Четверг, 04.02.2016, 18:47 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1514
Репутация: 376 ±
Замечаний: 0% ±

2010
Если правильно понял. Расширив диапазон в формуле от Udik из Сообщения №2, и заключив в скобки суммы, у Вас будет суммироваться каждый третий столбец в ячейки строки
Код
=СУММ(ИНДЕКС($A$6:$R$11;;СТОЛБЕЦ()*3))
Под нужный диапазон, измените сами.
А в Вашей формуле ошибка, потому что СУММЕСЛИ не работает на разных диапазонах, по размеру диапазоны должны быть одинаковы. измените на такую и посмотрите.
Код
=СУММЕСЛИ($C$47:ИНДЕКС(C$47:C$101;30));$A9;M$47:ИНДЕКС(M$47:M$101;30))
К сообщению приложен файл: 8254997.xlsx(13Kb)


Сообщение отредактировал gling - Четверг, 04.02.2016, 19:00
 
Ответить
СообщениеЕсли правильно понял. Расширив диапазон в формуле от Udik из Сообщения №2, и заключив в скобки суммы, у Вас будет суммироваться каждый третий столбец в ячейки строки
Код
=СУММ(ИНДЕКС($A$6:$R$11;;СТОЛБЕЦ()*3))
Под нужный диапазон, измените сами.
А в Вашей формуле ошибка, потому что СУММЕСЛИ не работает на разных диапазонах, по размеру диапазоны должны быть одинаковы. измените на такую и посмотрите.
Код
=СУММЕСЛИ($C$47:ИНДЕКС(C$47:C$101;30));$A9;M$47:ИНДЕКС(M$47:M$101;30))

Автор - gling
Дата добавления - 04.02.2016 в 18:47
Belfigor Дата: Четверг, 04.02.2016, 18:55 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Ой, незаметил что он был слишком большой для прикрепления

Нужно собрать данные из диапазонов M24:M58 P24:P58 S24:S58 ... До бесконечности
И распределить их по категориям и по дням в диапазоне C16:L16.
Я смог исходя из категории собрать данные из диапазона M24:M58 в диапазон C2:C16, но я не могу растянуть его так чтобы добиться этого результата в последующих колонках.
К сообщению приложен файл: primer_3.zip(67Kb)


Сообщение отредактировал Belfigor - Четверг, 04.02.2016, 19:00
 
Ответить
СообщениеОй, незаметил что он был слишком большой для прикрепления

Нужно собрать данные из диапазонов M24:M58 P24:P58 S24:S58 ... До бесконечности
И распределить их по категориям и по дням в диапазоне C16:L16.
Я смог исходя из категории собрать данные из диапазона M24:M58 в диапазон C2:C16, но я не могу растянуть его так чтобы добиться этого результата в последующих колонках.

Автор - Belfigor
Дата добавления - 04.02.2016 в 18:55
Udik Дата: Четверг, 04.02.2016, 20:12 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1376
Репутация: 178 ±
Замечаний: 0% ±

Excel 2016 х 64
если я Вас правильно понял, то для С16

Код
=СУММ(СМЕЩ($K$24;;(СТОЛБЕЦ()-2)*3-1;35))


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениеесли я Вас правильно понял, то для С16

Код
=СУММ(СМЕЩ($K$24;;(СТОЛБЕЦ()-2)*3-1;35))

Автор - Udik
Дата добавления - 04.02.2016 в 20:12
Belfigor Дата: Четверг, 04.02.2016, 20:20 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
если я Вас правильно понял, то для С16

[Перевод / Translate]
=СУММ(СМЕЩ($K$24;;(СТОЛБЕЦ()-2)*3-1;35))

Суть в том что надо не просто просуммировать, а просуммировать для C16, находящейся в строке "Хоз товары", только те строки из колонки начинающейся на k24 вниз, которые совпадут по категории из колонки C24 с "Хоз товары"
то есть для C16 формула должна дать 0, а для C9 должна дать 1000,99р
 
Ответить
Сообщение
если я Вас правильно понял, то для С16

[Перевод / Translate]
=СУММ(СМЕЩ($K$24;;(СТОЛБЕЦ()-2)*3-1;35))

Суть в том что надо не просто просуммировать, а просуммировать для C16, находящейся в строке "Хоз товары", только те строки из колонки начинающейся на k24 вниз, которые совпадут по категории из колонки C24 с "Хоз товары"
то есть для C16 формула должна дать 0, а для C9 должна дать 1000,99р

Автор - Belfigor
Дата добавления - 04.02.2016 в 20:20
_Boroda_ Дата: Четверг, 04.02.2016, 21:05 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ($K$24:ИНДЕКС($222:$222;СЧЁТ($1:$1)*3)*($C$24:$C$222=$A2)*($K$22:ИНДЕКС($22:$22;СЧЁТ($1:$1)*3)=C$1))

До 222 строки. Если больше, то все 222 измените на нужный номер
Формула длинная, но зато быстрая и не волатильная (см. поиск по форуму), как СМЕЩ.
Данные вправо можно добавлять.
К сообщению приложен файл: 7792787.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ($K$24:ИНДЕКС($222:$222;СЧЁТ($1:$1)*3)*($C$24:$C$222=$A2)*($K$22:ИНДЕКС($22:$22;СЧЁТ($1:$1)*3)=C$1))

До 222 строки. Если больше, то все 222 измените на нужный номер
Формула длинная, но зато быстрая и не волатильная (см. поиск по форуму), как СМЕЩ.
Данные вправо можно добавлять.

Автор - _Boroda_
Дата добавления - 04.02.2016 в 21:05
Udik Дата: Четверг, 04.02.2016, 21:20 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 1376
Репутация: 178 ±
Замечаний: 0% ±

Excel 2016 х 64
или так для С16
Код
=СУММПРОИЗВ(ИНДЕКС($K$24:$AN$58;;(СТОЛБЕЦ()-2)*3)*(ИНДЕКС($C$24:$C$58;;1)=$A2))
К сообщению приложен файл: 6406535.zip(70Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Четверг, 04.02.2016, 21:36
 
Ответить
Сообщениеили так для С16
Код
=СУММПРОИЗВ(ИНДЕКС($K$24:$AN$58;;(СТОЛБЕЦ()-2)*3)*(ИНДЕКС($C$24:$C$58;;1)=$A2))

Автор - Udik
Дата добавления - 04.02.2016 в 21:20
Belfigor Дата: Четверг, 04.02.2016, 21:37 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Всем спасибо! Особенно спасибо Udik!
 
Ответить
СообщениеВсем спасибо! Особенно спасибо Udik!

Автор - Belfigor
Дата добавления - 04.02.2016 в 21:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Свести в строку №1 данные из каждого 3-го столбца строки №2 (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!